• We would like to invite you to check out the latest 1.0 alpha versions. You can read more about what's new here. Please note, that this is still an early release and will contain new bugs ¯\_(ツ)_/¯
  • If you need help or want to discuss things, you now can also join us on our Discord Server!

Bot does not react to commands written in chat

Night

Member
Dear BombasGamer ,

If you didnt create a user account with your identity.

Binding a TS user to a bot account
Open your control panel and head over to Settings -> User Accounts. Now click on edit right to the account that you want to connect to your TS account. Please make sure that both the bot and you are connected to the server to accomplish this.
In the edit user dialog scroll down until you get to Identity. Using the drop down Bind to another identity you should find yourself with the nickname you are using on the TS server. Select it and hit Save changes at the bottom of the page.
Make sure that you have all the required privileges activated with those green and red boxes (green = granted permission, red = revoked permission).
The bot will now listen to the commands you send.

If you create a user account with good permissions can you paste a error log of your Instance?

Best regards,
Adrian
 
Dear BombasGamer ,

If you didnt create a user account with your identity.

Binding a TS user to a bot account
Open your control panel and head over to Settings -> User Accounts. Now click on edit right to the account that you want to connect to your TS account. Please make sure that both the bot and you are connected to the server to accomplish this.
In the edit user dialog scroll down until you get to Identity. Using the drop down Bind to another identity you should find yourself with the nickname you are using on the TS server. Select it and hit Save changes at the bottom of the page.
Make sure that you have all the required privileges activated with those green and red boxes (green = granted permission, red = revoked permission).
The bot will now listen to the commands you send.

If you create a user account with good permissions can you paste a error log of your Instance?

Best regards,
Adrian
2019-03-08T18:50:45+00:00 Could not send description command: HTTP returned an error: Timeout while waiting for callback; Code: 500; Message: Timeout while waiting for callback (Now playing: Cidade FM) 4e6f7720706c6179696e673a2043696461646520464d
2019-03-08T18:50:41+00:00 PLAY [admin] 31df52da-3b9f-4655-9789-547f4a4a1b7e OK
2019-03-08T18:50:35+00:00 PLAY [admin] 31df52da-3b9f-4655-9789-547f4a4a1b7e OK
2019-03-08T18:50:33+00:00 VOLUME-SET [admin] 7 OK
2019-03-08T10:26:19+00:00 TS |INFO | | |successfully downloaded revocation list
2019-03-07T22:41:33+00:00 STOP [admin] OK
2019-03-07T22:41:23+00:00 TS |INFO |Update | |Check license: version=4, min_version=4, my_license_version=4, my_license_min_version=1
2019-03-07T22:41:23+00:00 New connection status 4; Error 0
2019-03-07T22:41:23+00:00 TS |INFO |PermManager | |Loading permissions from cache
2019-03-07T22:41:23+00:00 TS |INFO |ClientUI |1 |Connect status: Connection established
2019-03-07T22:41:23+00:00 New connection status 3; Error 0
2019-03-07T22:41:23+00:00 TS |INFO |ClientUI |1 |Connect status: Establishing connection
2019-03-07T22:41:23+00:00 New connection status 2; Error 0
2019-03-07T22:41:22+00:00 TS |INFO |ClientUI |1 |Connect status: Connected
2019-03-07T22:41:21+00:00 TS |INFO |Update | |Checking for updates...
2019-03-07T22:41:21+00:00 TS |INFO |ClientUI | |Checking for update
2019-03-07T22:41:21+00:00 TS |INFO |ClientUI | |Last update check was: ter jan 1 00:00:01 2019
2019-03-07T22:41:21+00:00 TS |INFO |Bookmarks | |Collecting autoconnect bookmarks
2019-03-07T22:41:21+00:00 New connection status 1; Error 0
2019-03-07T22:41:21+00:00 TS |INFO |ClientUI |1 |Connect status: Connecting
2019-03-07T22:41:21+00:00 TS |DEVELOP |PktHandler | |Puzzle solve time: 7
2019-03-07T22:41:21+00:00 TS |INFO |PreProSpeex |1 |Speex version: 1.2rc1
2019-03-07T22:41:21+00:00 TS |INFO |ClientUI |1 |Initiating connection: 127.0.0.1:9987
2019-03-07T22:41:21+00:00 TS |INFO |ClientUI |1 |Connect to server: 127.0.0.1
2019-03-07T22:41:21+00:00 TS |INFO |ClientUI | |ts3server: 127.0.0.1?port=9987&nickname=Z%C3%A9Ordenado&password=&cid=48&channelpassword=
2019-03-07T22:41:20+00:00 TS |INFO |ClientUI | |Using configuration location: /opt/bot1/data/ts3/6980a2f3-524f-4598-a1e3-c289a3c53839/aca7a67a-e2d3-4e36-98be-fcf54a4e3c7d/settings.db
2019-03-07T22:41:20+00:00 TS |INFO |ClientUI | |Qt version: 5.6.1
2019-03-07T22:41:20+00:00 TS |INFO |ClientUI | |Failed to init text to speech engine
2019-03-07T22:41:20+00:00 TS |DEVELOP |ClientUI | |Notifications init: Soundpack path: /opt/bot1/TeamSpeak3-Client-linux_amd64/sound/nosounds
2019-03-07T22:41:20+00:00 TS |INFO | | |*** Time [INIT]: 647
2019-03-07T22:41:20+00:00 TS |INFO | | |*** Time [MAINWINDOW]: 647
2019-03-07T22:41:20+00:00 Could not send config: HTTP returned an error: Error; Code: 500; Message: Error
2019-03-07T22:41:20+00:00 Could not send config: HTTP returned an error: Error; Code: 500; Message: Error
2019-03-07T22:41:20+00:00 Could not send description command: HTTP returned an error: Error; Code: 500; Message: Error (Now playing: Ozuna - Topic - Baila Baila Baila) 4e6f7720706c6179696e673a204f7a756e61202d20546f706963202d204261696c61204261696c61204261696c61
2019-03-07T22:41:20+00:00 TS |INFO |Plugins | |Loading plugin: libsoundbot_plugin.so
2019-03-07T22:41:19+00:00 TS |INFO |Addons | |Checking for addon updates...
2019-03-07T22:41:19+00:00 TS |INFO | | |successfully downloaded revocation list
2019-03-07T22:41:19+00:00 TS |INFO |ClientUI | |Unable to create an Open GL context.
2019-03-07T22:41:19+00:00 TS |ERROR |SoundBckndIntf| |/opt/bot1/TeamSpeak3-Client-linux_amd64/soundbackends/libpulseaudio_linux_amd64.so error: INIT_PA_IMPL
2019-03-07T22:41:19+00:00 TS |ERROR |PulseAudio | |pa_context_connect failed -
2019-03-07T22:41:19+00:00 TS |ERROR |PulseAudio | |failed to connect to pulse audio server -
2019-03-07T22:41:18+00:00 TS |INFO | | |Using hardware aes
2019-03-07T22:41:18+00:00 TS |INFO | | |SystemInformation: Linux 4.4.0-142-generic #168-Ubuntu SMP Wed Jan 16 21:00:45 UTC 2019 x86_64 Binary: 64bit
2019-03-07T22:41:18+00:00 TS |INFO | | |TeamSpeak 3 Client 3.1.8 (2018-01-22 09:50:07)
2019-03-07T22:41:16+00:00 Starting instance ts3server://127.0.0.1?port=9987&nickname=Z%C3%A9Ordenado&password=&cid=48&channelpassword=
2019-03-07T22:41:16+00:00 Auto-Playing last track
2019-03-07T22:41:16+00:00 Could not create Notifications-Tabletable Notifications already exists
2019-03-07T22:41:16+00:00 Could not create WhisperReceive-Tabletable WhisperReceive already exists
2019-03-07T22:41:16+00:00 Could not create Chat-Tabletable Chat already exists
2019-03-07T22:41:15+00:00 Last track was 6b011834-c33e-4be1-ae61-d17de9573c2c, will auto-play soon
2019-03-07T22:41:15+00:00 Auto-Starting 6980a2f3-524f-4598-a1e3-c289a3c53839/aca7a67a-e2d3-4e36-98be-fcf54a4e3c7d in 500 ms...
2019-03-07T22:41:15+00:00 Initialization complete
2019-03-07T22:41:15+00:00 Digital_Clock:159 Channel for Line #1 doesn't exists! Disabling Digital Clock v1.8...
2019-03-07T22:41:15+00:00 Loading script Digital_Clock
2019-03-07T22:41:15+00:00 Loading script welcome
 

Night

Member
Did you create a new user account with full permissions? Then try to connect into channel where is bot and write a command.

3076
3077
3078

And check the permission of bot on teamspeak and webpanel!
Maybe you choose option for ignore a commands via channel-chat/private messages.

Best regards,
Adrian
 

Night

Member
Can you paste here a Bot log? There are errors then if your commands dont work.
Thanks in advance!
 
Can you paste here a Bot log? There are errors then if your commands dont work.
Thanks in advance!
2019-03-08T19:43:06+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:43:04+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:43:03+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:43:03+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:43:03+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:43:02+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:43:02+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:43:01+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:43:01+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:43:00+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:43:00+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:43:00+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:42:59+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:42:59+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:42:58+00:00 USER-PATCH [admin] (bombasgamer) OK
2019-03-08T19:42:50+00:00 USER-CREATE [admin] (bombasgamer) OK
2019-03-08T19:42:50+00:00 Added new user bombasgamer
2019-03-08T19:42:47+00:00 USER-CREATE [admin] (bombasgamer) NOK
2019-03-08T19:42:46+00:00 USER-CREATE [admin] (bombasgamer) NOK
2019-03-08T19:42:31+00:00 USER-CREATE [admin] (bombasgamer) NOK
2019-03-08T19:42:30+00:00 USER-CREATE [admin] (bombasgamer) NOK
2019-03-08T19:42:27+00:00 USER-CREATE [admin] (bombasgamer) NOK
2019-03-08T19:42:18+00:00 USER-CREATE [admin] (bombasgamer) NOK
2019-03-08T19:42:18+00:00 USER-CREATE [admin] (bombasgamer) NOK
2019-03-08T19:42:17+00:00 USER-CREATE [admin] (bombasgamer) NOK
2019-03-08T19:42:17+00:00 USER-CREATE [admin] (bombasgamer) NOK
2019-03-08T19:42:17+00:00 USER-CREATE [admin] (bombasgamer) NOK
2019-03-08T19:42:14+00:00 USER-CREATE [admin] (bombasgamer) NOK
2019-03-08T19:12:47+00:00 JOBS-ADD [admin] https://www.youtube.com/watch?v=-lcSQvTiAzw OK
2019-03-08T19:03:24+00:00 USER-PATCH [admin] (admin) OK
2019-03-07T22:41:31+00:00 LOGIN [admin] OK
2019-03-07T22:41:15+00:00 Loading instance://5aa8fc60-9486-4b5a-a503-61a7d83946cb
2019-03-07T22:41:15+00:00 Loading instance://aca7a67a-e2d3-4e36-98be-fcf54a4e3c7d
2019-03-07T22:41:15+00:00 Loading instances
 

Night

Member
Can you paste a config here?

Did you try to download a song from webpanel of sinusbot?
3079
Maybe your youtube installation dont work.
 
Last edited:
Same for me. I installed the bot with the script but it doesn't recognise commands such as !register !yt or !vol … Dunno what to do actually
 

Kir-à

Helping Hand
is awesome!
Contributor
Hey,

It seems that Youtube-DL is not installed, to do so download it here, and drag it into the main directory.

Don't forget to indicate the path in the config.ini.

If you have any further questions or issues, just reply.

3082
 
Hey,

It seems that Youtube-DL is not installed, to do so download it here, and drag it into the main directory.

Don't forget to indicate the path in the config.ini.

If you have any further questions or issues, just reply.

View attachment 3082
I already installed what I said on the site to download the music, but in teamspeak by chat the bot does not respond to commands.
 

Similar threads

Top