• If you need help or want to discuss things, you now can also join us on our Discord Server!

Solved [Debian 10] Bot startet nicht mehr

DasBill

Member
Hallo allerseits,

ich habe heute meinen Server, auf dem der Bot läuft aktualisiert auf Debian 10 Buster und nun kommt mein Bot nicht mehr hoch. Ich habe alle Pakete und Abhängigkeiten erneut installiert aber ohne Erfolg. Hier mal ein Auszug aus den Logs:

Mit dem TS3 Client 3.2.5:
Code:
2019/07/07 14:03:12 e6e40fba b5cdc874 WARN   Could not create Chat-Tabletable Chat already exists
2019/07/07 14:03:12 e6e40fba b5cdc874 WARN   Could not create WhisperReceive-Tabletable WhisperReceive already exists
2019/07/07 14:03:12 e6e40fba b5cdc874 WARN   Could not create Notifications-Tabletable Notifications already exists
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 14:03:12 e6e40fba b5cdc874 INFO   Starting instance ts3server://xxx.xxx.org?port=1337&nickname=Musik&password=&channel=&channelpassword=
2019/07/07 14:03:12 X [MAIN] New connection
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  TS>Crashdump ENABLED,  directory is: /ts3data/tsbot/data/ts3/e6e40fba-64a7-417b-b075-cae7cc3ae9fc/b5cdc874-d538-437f-86b1-3dce75f35114/crashdumps
2019/07/07 14:03:12 e6e40fba b5cdc874 DEBUG  TS>DUMP defined! Dumpdir is: /ts3data/tsbot/data/ts3/e6e40fba-64a7-417b-b075-cae7cc3ae9fc/b5cdc874-d538-437f-86b1-3dce75f35114/crashdumps
2019/07/07 14:03:12 X [MAIN] New connection
2019/07/07 14:03:12 X [MAIN] New connection
2019/07/07 14:03:12 e6e40fba b5cdc874 INFO   TS |INFO    |              |   |TeamSpeak 3 Client 3.2.5 (2019-04-17 16:07:33)
2019/07/07 14:03:12 e6e40fba b5cdc874 INFO   TS |INFO    |              |   |SystemInformation: Linux 4.19.0-5-amd64 #1 SMP Debian 4.19.37-5 (2019-06-19) x86_64 Binary: 64bit
2019/07/07 14:03:12 e6e40fba b5cdc874 INFO   TS |INFO    |              |   |Using hardware aes
2019/07/07 14:03:12 X [MAIN] New connection
2019/07/07 14:03:12 [GENERAL/YTDL   ] INFO   youtube-dl version compatible, support enabled
2019/07/07 14:03:12 [GENERAL/!!!!!!!] NOTICE You may now configure and launch the bots from the webinterface. http://159.69.147.14:1338
Mit dem neuesten TS3 Client 3.3.0:
Code:
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Prespawn.
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  About to run.
2019/07/07 13:59:59 e6e40fba b5cdc874 WARN   Could not create Chat-Tabletable Chat already exists
2019/07/07 13:59:59 e6e40fba b5cdc874 WARN   Could not create WhisperReceive-Tabletable WhisperReceive already exists
2019/07/07 13:59:59 e6e40fba b5cdc874 WARN   Could not create Notifications-Tabletable Notifications already exists
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 13:59:59 e6e40fba b5cdc874 INFO   Starting instance ts3server://xxx.xxx.org?port=1337&nickname=Musik&password=&channel=&channelpassword=
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  TS>qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  TS>This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  TS>
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  TS>Available platform plugins are: xcb.
2019/07/07 13:59:59 e6e40fba b5cdc874 DEBUG  TS>
Hier ist noch die Ausgabe zum Diag Script:
Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
- Operating System: Debian GNU/Linux 10 (buster)
- Kernel: Linux 4.19.0-5-amd64 x86_64
- Load Average: 0.21 0.05 0.04
- Uptime: 0 days, 0 hours, 29 minutes, 19 seconds
- OS x64 check: OK
- OS Updates: 0 (well done!)
- OS Missing Packages: None
- OS APT Last Update: 07.07.2019 12:22:02 CEST +02:00:00
- Shell Locale: en_US.UTF-8
- Bot Start Script: found at /etc/systemd/system/ts3bot.service [perms: 644]
- CPU:
    Architecture:        x86_64
    CPU(s):              1
    Thread(s) per core:  1
    Core(s) per socket:  1
    Socket(s):           1
    Model name:          Intel Xeon Processor (Skylake, IBRS)
    CPU MHz:             2100.000
    Hypervisor vendor:   KVM
    Virtualization type: full
- RAM: 260.40 MB/1.90 GB in use (13%)
- SWAP: 0 B/0 B in use (0%) (SWAP disabled)
- DISK: 2.76 GB/18.71 GB in use (14%)
- Package versions:
   - libglib: 2.58.3-2

BOT INFORMATION
- Status: not running
- Webinterface: port locally not reachable (Port: 1338)
- Binary: /ts3data/tsbot/sinusbot
- Binary Info: MD5 Hash: 6f301dac3e4dfd45ce149933c5dadd08, Perms: 755, User: ts3
- Version: 1.0.0-beta.1-06a54d7
- TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: 59c9a688307aa73af9573029a7625fc5
   - TS3 Client: 59c9a688307aa73af9573029a7625fc5
- Config:
   - LogLevel = 10 (debug log active)
   - TS3Path = /ts3data/tsbot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 (Version 3.2.5)
   - YoutubeDLPath = /ts3data/tsbot/youtube-dl (does exist, version: 2017.04.28)
- Installed scripts: advertising.js; alonemode.js; aloneMode.js; badchan.js; bookmark.js; command.js; covatar.js; dev.js; digitalclock.js; followme.js; idle.js; Jail.js; metadata.js; norecording.js; reconnect.js; rememberChannel.js; showcase.js; sound.js; tunakills_ranking.js; twitch_status.js; welcome.js; welcometext.js; youtube.js

BOT TECHNICAL INFORMATION
- File exists:
   - TS3Client/libqxcb-glx-integration.so: yes
- LDD output:
    linux-vdso.so.1 (0x00007ffd2f4d5000)
    libswresample.so.2 => /ts3data/tsbot/libswresample.so.2 (0x00007f777625e000)
    libavfilter.so.6 => /ts3data/tsbot/libavfilter.so.6 (0x00007f7775f06000)
    libavformat.so.57 => /ts3data/tsbot/libavformat.so.57 (0x00007f7775b05000)
    libavcodec.so.57 => /ts3data/tsbot/libavcodec.so.57 (0x00007f77751a0000)
    libavutil.so.55 => /ts3data/tsbot/libavutil.so.55 (0x00007f7774f2c000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f7774f1f000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f7774d9a000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f7774d79000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f7774bf5000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f7774bdb000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f7774a1a000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f77747fc000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f77747f0000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f777647a000)

REACHABILITY CHECKS
- HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
- HTTPS check with IPv6 mode: IGNORED [Disabled]
- DNS resolution check: SUCCESS [www.sinusbot.com resolved to 104.28.15.74]
- Update server checks:
    update01.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update02.sinusbot.com -> 104.28.14.74: SUCCESS [CODE #404]
    update03.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]

TIME INFORMATION
- Time (local): 07.07.2019 14:11:18 CEST +02:00:00
- Time (remote): 07.07.2019 14:11:18 CEST +02:00:00
- Time (difference): 0 secs (Time diff less than 2 secs. Good.)
- Timezone: Europe/Berlin

OTHER INFORMATION
- TeamSpeak3 Version: 3.2.5
- youtube-dl Version: 2017.04.28
- DiagScript Version: 0.8.0
==========================================================

Hat hier jemand evtl. eine Idee?

Danke & Grüße

DasBill
 
Last edited:

DasBill

Member
Danke, ich habe es mit der Version probiert. Der Bot startet aber weiterhin nicht.

Code:
2019/07/07 20:58:57 e6e40fba b5cdc874 WARN   Could not create Chat-Tabletable Chat already exists
2019/07/07 20:58:57 e6e40fba b5cdc874 WARN   Could not create WhisperReceive-Tabletable WhisperReceive already exists
2019/07/07 20:58:57 e6e40fba b5cdc874 WARN   Could not create Notifications-Tabletable Notifications already exists
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2019/07/07 20:58:57 e6e40fba b5cdc874 INFO   Starting instance ts3server://xxx.xxx.org?port=1337&nickname=Musik&password=&channel=&channelpassword=
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  TS>qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  TS>This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  TS>
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  TS>Available platform plugins are: xcb.
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  TS>
2019/07/07 20:58:57 e6e40fba b5cdc874 DEBUG  Closed.
2019/07/07 20:58:57 e6e40fba b5cdc874 INFO   TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019/07/07 20:58:57 [GENERAL/YTDL   ] INFO   youtube-dl version compatible, support enabled
2019/07/07 20:58:57 [GENERAL/!!!!!!!] NOTICE You may now configure and launch the bots from the webinterface. http://xx.xx.xx.xx:1338

dpkg -l
ii  libx11-xcb1:amd64     2:1.6.7-1    amd64        Xlib/XCB interface library
un  libxcb-doc            <none>       <none>       (no description available)
ii  libxcb-dri2-0:amd64   1.13.1-2     amd64        X C Binding, dri2 extension
ii  libxcb-dri3-0:amd64   1.13.1-2     amd64        X C Binding, dri3 extension
ii  libxcb-glx0:amd64     1.13.1-2     amd64        X C Binding, glx extension
ii  libxcb-present0:amd64 1.13.1-2     amd64        X C Binding, present extension
ii  libxcb-sync1:amd64    1.13.1-2     amd64        X C Binding, sync extension
ii  libxcb-xfixes0:amd64  1.13.1-2     amd64        X C Binding, xfixes extension
ii  libxcb1:amd64         1.13.1-2     amd64        X C Binding
ii  libxcb1-dev:amd64     1.13.1-2     amd64        X C Binding, development files
ii  xcb                   2.4-4.3      amd64        Pigeon holes for your cut and paste selections
 

TwentyFour

Well-Known Member
is awesome!
V.I.P.
Konnte den Fehler auf Debian 10 reproduzieren. Mit den Standard Dependencies (des SinusBot) läuft es nicht. :confused:

EDIT: Es werden natürlich auch die entsprechenden TeamSpeak Client Dependencies (für 3.3.0) benötigt:
apt install libpci3 libxslt1.1 libxkbcommon0

Danke an @irgendwr
 
Last edited:

DasBill

Member
Hier der Ouput:

Danke bereits für deine/eure Mithilfe!

Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
- Operating System: Debian GNU/Linux 10 (buster)
- Kernel: Linux 4.19.0-5-amd64 x86_64
- Load Average: 0.11 0.06 0.01
- Uptime: 19 days, 5 hours, 0 minutes, 28 seconds
- OS x64 check: OK
- OS Updates: 1 (updates available!)
- OS Missing Packages: None
- OS APT Last Update: 26.07.2019 04:20:32 CEST +02:00:00
- Shell Locale: en_US.UTF-8
- Bot Start Script: found at /etc/systemd/system/ts3bot.service [perms: 755]
- CPU:
    Architecture:        x86_64
    CPU(s):              1
    Thread(s) per core:  1
    Core(s) per socket:  1
    Socket(s):           1
    Model name:          Intel Xeon Processor (Skylake, IBRS)
    CPU MHz:             2100.000
    Hypervisor vendor:   KVM
    Virtualization type: full
- RAM: 343.91 MB/1.90 GB in use (17%)
- SWAP: 0 B/0 B in use (0%) (SWAP disabled)
- DISK: 3.00 GB/18.71 GB in use (16%)
- Package versions:
   - libglib: 2.58.3-2

BOT INFORMATION
- Status: running
- Webinterface: port locally not reachable (Port: 1338)
- Binary: /ts3data/tsbot/sinusbot
- Binary Info: MD5 Hash: d770dee2259d159aa78550962d3251e3, Perms: 755, User: ts3
- Version: 1.0.0-beta.3-735814e
- TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: 2e771e4332cf87da1f72d58aa6923f9f
   - TS3 Client: 2e771e4332cf87da1f72d58aa6923f9f
- Config:
   - LogLevel = 10 (debug log active)
   - TS3Path = /ts3data/tsbot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 (Version 3.3.0)
   - YoutubeDLPath = /ts3data/tsbot/youtube-dl (does exist, version: 2017.04.28)
- Installed scripts: advertising.js; alonemode.js; aloneMode.js; badchan.js; bookmark.js; command.js; covatar.js; dev.js; digitalclock.js; followme.js; idle.js; Jail.js; metadata.js; norecording.js; reconnect.js; rememberChannel.js; showcase.js; sound.js; tunakills_ranking.js; twitch_status.js; welcome.js; welcometext.js; youtube.js

BOT TECHNICAL INFORMATION
- File exists:
   - TS3Client/libqxcb-glx-integration.so: yes
- LDD output:
    linux-vdso.so.1 (0x00007ffea11cc000)
    libswresample.so.2 => /ts3data/tsbot/libswresample.so.2 (0x00007f8c14ab1000)
    libavfilter.so.6 => /ts3data/tsbot/libavfilter.so.6 (0x00007f8c14759000)
    libavformat.so.57 => /ts3data/tsbot/libavformat.so.57 (0x00007f8c14358000)
    libavcodec.so.57 => /ts3data/tsbot/libavcodec.so.57 (0x00007f8c139f3000)
    libavutil.so.55 => /ts3data/tsbot/libavutil.so.55 (0x00007f8c1377f000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f8c13772000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f8c135ed000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f8c135cc000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f8c13448000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f8c1342e000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f8c1326d000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f8c1304f000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f8c13043000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f8c14ccd000)

REACHABILITY CHECKS
- HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
- HTTPS check with IPv6 mode: IGNORED [Disabled]
- DNS resolution check: SUCCESS [www.sinusbot.com resolved to 104.28.15.74]
- Update server checks:
    update01.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update02.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update03.sinusbot.com -> 104.28.14.74: SUCCESS [CODE #404]

TIME INFORMATION
- Time (local): 26.07.2019 18:42:27 CEST +02:00:00
- Time (remote): 26.07.2019 18:44:06 CEST +02:00:00
- Time (difference): 99 secs (Time diff greater than 30 secs!)
- Timezone: Europe/Berlin

OTHER INFORMATION
- TeamSpeak3 Version: 3.3.0
- youtube-dl Version: 2017.04.28
- DiagScript Version: 0.8.0
==========================================================
So wie es ausschaut öffnet er den Port 1338 nicht obwohl er verfügbar sein sollte:
Code:
tcp        0      0 0.0.0.0:30033           0.0.0.0:*               LISTEN      1000       15944      591/./ts3server     
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      0          14299      602/sshd            
tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      0          15441      809/master          
tcp        0      0 0.0.0.0:61209           0.0.0.0:*               LISTEN      0          14763      566/python3         
tcp        0      0 0.0.0.0:10011           0.0.0.0:*               LISTEN      1000       15960      591/./ts3server     
tcp        0      0 0.0.0.0:10022           0.0.0.0:*               LISTEN      1000       15966      591/./ts3server     
tcp6       0      0 :::9100                 :::*                    LISTEN      1001       370235     28392/node_exporter 
tcp6       0      0 :::30033                :::*                    LISTEN      1000       15945      591/./ts3server     
tcp6       0      0 :::25                   :::*                    LISTEN      0          15442      809/master          
tcp6       0      0 :::10011                :::*                    LISTEN      1000       15961      591/./ts3server     
tcp6       0      0 :::9090                 :::*                    LISTEN      1001       369875     28337/prometheus    
tcp6       0      0 :::10022                :::*                    LISTEN      1000       15967      591/./ts3server     
udp        0      0 0.0.0.0:9987            0.0.0.0:*                           1000       15955      591/./ts3server     
udp        0      0 0.0.0.0:68              0.0.0.0:*                           0          12658      407/dhclient        
udp        0      0 0.0.0.0:1337            0.0.0.0:*                           1000       15957      591/./ts3server     
udp6       0      0 :::9987                 :::*                                1000       15956      591/./ts3server     
udp6       0      0 :::1337                 :::*                                1000       15958      591/./ts3server
 

irgendwr

semi-inactive™
Staff member
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
Lösch bitte mal die libqxcb-glx-integration.so, wie's auch in der Dokumentation steht.
Sollte via rm TeamSpeak3-Client-linux_amd64/xcbglintegrations/libqxcb-glx-integration.so gehen, ggf. muss der Pfad angepasst werden.
Und rm -rf data/ts3 ist bei TS upgrades auch zu empfehlen.

Solltest auch das start-script um die neuen Einträge ergänzen: https://raw.githubusercontent.com/SinusBot/linux-startscript/master/sinusbot.service
Environment=QT_XCB_GL_INTEGRATION=none drin zu haben wär gut.
Wenn du schon dabei bist kannst du ja noch youtube-dl aktualisieren, denn 2017.04.28 ist ja schon sehr alt.
 

DasBill

Member
Vielen Dank, das hat das Problem auf Anhieb gelöst!

Bin deinen Schritten gefolgt und siehe da, der Bot ließ sich direkt wieder starten. :)
 

TwentyFour

Well-Known Member
is awesome!
V.I.P.
Sehr schön, genau das war meine Vermutung, da bereits im ersten Log von dir, das File noch drin war. ;)
 

Similar threads

Top