• We would like to invite you to check out the latest 1.0 alpha versions. You can read more about what's new here. Please note, that this is still an early release and will contain new bugs ¯\_(ツ)_/¯
  • If you need help or want to discuss things, you now can also join us on our Discord Server!

Error 1797 - The bot could not connect

Hi, Sinusbot cannot connect to a specific server. This same installation works correctly with other servers.
Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
- Operating System: Debian GNU/Linux 8.10 (jessie) (OpenVZ)
- Kernel: Linux 2.6.32-042stab127.2 x86_64
- Load Average: 0.30 0.07 0.02
- Uptime: 0 days, 1 hours, 0 minutes, 57 seconds
- OS x64 check: OK
- OS Updates: 3 (updates available!)
- OS Missing Packages: None
- OS APT Last Update: 02.03.2018 15:42:45 EST -05:00:00
- SHELL LOCALE LANG: (not set)
- Bot Start Script: not found
- DNS resolution check: www.sinusbot.com resolved to 104.18.41.220 -> OK
- HTTPS check with IPv4 mode: SUCCESS [Connection was established to www.sinusbot.com, CODE #200]
- HTTPS check with IPv6 mode: IGNORE
- CPU:
    (failed retrieving information)
- RAM:  B/256.00 MB in use (%)
- SWAP:  B/ B in use (%)
- DISK: 855.83 MB/3.70 GB in use (22%)
- Package versions:
   + libglib: 2.42.1-1+b1

BOT INFORMATION
- Status: running (PIDs: 3294 3293, User: bot)
- Webinterface: port locally reachable (Port: 7000)
- Binary: /home/bot/sinusbot
- Binary Info: MD5 Hash: febce0ebdd2d2e9d7f69701bc5a7c339, Perms: 755, User: bot
- Version: 0.10.8-71ba94b
- TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: 5d26494473e8bc268a3859768f4b3e3f
   - TS3 Client: 5d26494473e8bc268a3859768f4b3e3f
- Config:
   - LogLevel = 10 (debug log active)
   - TS3Path = /home/bot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 (Version 3.0.19.4)
   - YoutubeDLPath = /home/bot/youtube-dl (does exist, version: 2018.03.03)
- Installed scripts: advertising.js; alonemode.js; bookmark.js; followme.js; norecording.js; rememberChannel.js; welcome.js

TIME INFORMATION
- Time (local): 02.03.2018 16:42:59 EST -05:00:00
- Time (remote): <Failed retrieving remote time!>
- Time (difference): n/a secs
- Timezone: America/New_York

OTHER INFORMATION
- TeamSpeak 3 Version: 3.0.19.4
- youtube-dl Version: 2018.03.03
- DiagScript Version: 0.7.0
==========================================================
  • used version (SinusBot, TS Client / Server)
    • SinusBot: 0.10.8-71ba94b
    • TS Client 3.0.19.4 And 3.0.18.2
    • TS Server: 3.0.12.2 on Linux
  • used operating system (e.g. Windows, 64bit)
    • Debian 8 - OpenVZ (NAT IPv4)
  • hardware specs (e.g. VPS, Core i7, 8 GB RAM)
    • VPS
    • 1Vcpu Xeon E5
    • 256 MB Ram
  • used browser (and maybe plugins)
    • Chrome
  • your config.ini
Code:
TS3Path = "/home/bot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64"
ListenHost = "0.0.0.0"
DataDir = "/home/bot/data/"
ListenPort = 7000
LocalPlayback = false
EnableLocalFS = false
MaxBulkOperations = 300
LogLevel = 10
EnableProfiler = false
YoutubeDLPath = "/home/bot/youtube-dl"
EnableDebugConsole = false
UploadLimit = 83886080
RunAsUser = 0
RunAsGroup = 0
InstanceActionLimit = 6
UseSSL = false
SSLKeyFile = ""
SSLCertFile = ""
Hostname = ""
SampleInterval = 60
StartVNC = false
EnableWebStream = false
LogFile = ""
LicenseKey = "qAHVu8KGjGlKR7ko4EMkF3dlsr49Yl4QtNQvI1******"
IsProxied = false
DenyStreamURLs = []
Pragma = 0

[YoutubeDL]
  BufferSize = 524288
  MaxDownloadSize = 419430400
  MaxDownloadRate = 104857600
  CacheStreamed = false

[TS3]
  AvatarMaxWidth = 0
  AvatarMaxHeight = 0
  AllowGIF = false

[StreamRewrites]

[Scripts]
  AllowReload = false
  EnableTimer = false
  DisableLegacyEvents = false
  ScriptTimeout = 5

[Themes]
  Default = ""

[SpeechRecognition]
  Enable = false

[FFmpeg]
  UserAgent = "SinusBot (0.10.8-71ba94b)"

[DAV]
  Enable = false

[XServer]
  Delay = 0
  Debug = false

[SHMem]
  Enable = false
  Size = 0
  Delay = 0
  Interval = 0

[RadioStations]
  URL = ""
  UpdateInterval = 0
  • Instance log:
Code:
2018/03/02 17:01:34 X [MAIN] Starting up fake x-server...
___ ___ _  _ _   _ ___ ___  ___ _____  BETA
/ __|_ _| \| | | | / __| _ )/ _ \_   _|
\__ \| || .` | |_| \__ \ _ \ (_) || |
|___/___|_|\_|\___/|___/___/\___/ |_|

Version: 0.10.8-71ba94b
(C) 2013-2017 Michael Friese. All rights reserved.

2018/03/02 17:01:35 [GENERAL/SCRIPTS] INFO   Loading ScriptPlugin advertising.js
2018/03/02 17:01:35 [GENERAL/SCRIPTS] INFO   Loading ScriptPlugin alonemode.js
2018/03/02 17:01:35 [GENERAL/SCRIPTS] INFO   Loading ScriptPlugin bookmark.js
2018/03/02 17:01:35 [GENERAL/SCRIPTS] INFO   Loading ScriptPlugin followme.js
2018/03/02 17:01:35 [GENERAL/SCRIPTS] INFO   Loading ScriptPlugin norecording.js
2018/03/02 17:01:35 [GENERAL/SCRIPTS] INFO   Loading ScriptPlugin rememberChannel.js
2018/03/02 17:01:35 [GENERAL/SCRIPTS] INFO   Loading ScriptPlugin welcome.js
2018/03/02 17:01:36 3b9312ad          INFO   Loading instances
2018/03/02 17:01:36 3b9312ad          INFO   Loading instance://bf027890-82ce-4cb7-be97-fad72f72e135
2018/03/02 17:01:36 3b9312ad bf027890 INFO   Initialization complete
2018/03/02 17:01:36 [GENERAL/FFMPEG ] INFO   FFmpeg/avcodec v3741798; license: LGPL version 2.1 or later; 81 codecs
2018/03/02 17:01:36 [GENERAL/FFMPEG ] INFO   FFmpeg/avformat v3742052; license: LGPL version 2.1 or later; 143 formats
2018/03/02 17:01:36 [GENERAL/YTDL   ] INFO   youtube-dl checking...
2018/03/02 17:01:38 [GENERAL/YTDL   ] INFO   youtube-dl version compatible, support enabled
2018/03/02 17:01:38 [GENERAL/!!!!!!!] NOTICE You may now configure and launch the bots from the webinterface. http://0.0.0.0:7000
2018/03/02 17:01:38 [GENERAL/RADIO  ] INFO   RadioStation data loaded
2018/03/02 17:01:39 [GENERAL/RADIO  ] INFO   Imported radio stations
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Prespawn.
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  About to run.
2018/03/02 17:01:45 3b9312ad bf027890 WARN   Could not create Chat-Tabletable Chat already exists
2018/03/02 17:01:45 3b9312ad bf027890 WARN   Could not create WhisperReceive-Tabletable WhisperReceive already exists
2018/03/02 17:01:45 3b9312ad bf027890 WARN   Could not create Notifications-Tabletable Notifications already exists
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Could not delete from FileTransferno such table: FileTransfer
2018/03/02 17:01:45 3b9312ad bf027890 DEBUG  Could not insert into FileTransfer-Tableno such table: FileTransfer
2018/03/02 17:01:46 3b9312ad bf027890 INFO   Starting instance ts3server://*TS3SERVER*&nickname=SinusBot&password=&channel=&channelpassword=
2018/03/02 17:01:46 X [MAIN] New connection
2018/03/02 17:01:46 3b9312ad bf027890 DEBUG  TS>Crashdump ENABLED,  directory is: /home/bot/data/ts3/3b9312ad-467d-4e80-8a0e-8682dffbb083/bf027890-82ce-4cb7-be97-fad72f72e135/crashdumps
2018/03/02 17:01:46 3b9312ad bf027890 DEBUG  TS>DUMP defined! Dumpdir is: /home/bot/data/ts3/3b9312ad-467d-4e80-8a0e-8682dffbb083/bf027890-82ce-4cb7-be97-fad72f72e135/crashdumps
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |INFO    |              |   |TeamSpeak 3 Client 3.0.19.4 (2016-07-14 10:16:58)
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |INFO    |              |   |SystemInformation: Linux 2.6.32-042stab127.2 #1 SMP Thu Jan 4 16:41:44 MSK 2018 x86_64 Binary: 64bit
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |INFO    |              |   |Using hardware aes
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |ERROR   |SoundBckndIntf|   |libasound.so.2: cannot open shared object file: No such file or directory
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |ERROR   |SoundBckndIntf|   |libpulse.so.0: cannot open shared object file: No such file or directory
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |WARNING |SoundDevManager|   |Did not load any sound backends. No (usable) dynamic libraries found.
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |INFO    |              |   |Loading plugin: libclientquery_plugin
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |INFO    |              |   |Loading plugin: liblua_plugin
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |INFO    |              |   |Loading plugin: libsoundbot_plugin
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |INFO    |              |   |Loading plugin: libtest_plugin
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |INFO    |Query         |   |listening on 127.0.0.1:25639
2018/03/02 17:01:46 X [MAIN] New connection
2018/03/02 17:01:46 3b9312ad bf027890 DEBUG  TS>ClientQueryPlugin: currentServerConnectionChanged 1 (0)
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |   |Failed to init text to speech engine
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |   |Qt version: 5.5.1
2018/03/02 17:01:46 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |   |Using configuration location: /home/bot/data/ts3/3b9312ad-467d-4e80-8a0e-8682dffbb083/bf027890-82ce-4cb7-be97-fad72f72e135/settings.db
2018/03/02 17:01:47 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |   |ts3server: *TS3SERVER*&nickname=SinusBot&password=&channel=&channelpassword=
2018/03/02 17:01:47 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |1  |Connect to server: *TS3SERVER*
2018/03/02 17:01:47 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |1  |Trying to resolve *TS3SERVER*
18/03/02 17:01:47 3b9312ad bf027890 INFO   TS |INFO    |TSDNS         |   |DNS resolve successful, "*TS3SERVER*"=***.***.***.***
2018/03/02 17:01:47 3b9312ad bf027890 INFO   TS |INFO    |TSDNS         |   |TSDNS found at "*TS3SERVER*" and queried successfully. Result: ***.***.***.***:****
2018/03/02 17:01:47 3b9312ad bf027890 INFO   TS |INFO    |TSDNS         |   |SRV TSDNS found at "_tsdns._tcp.*TS3SERVER*"=>"*TS3SERVER*:41144" and queried successfully. Result: ***.***.***.***:****
2018/03/02 17:01:47 3b9312ad bf027890 INFO   TS |INFO    |TSDNS         |   |SRV DNS resolve unsuccessful for "_ts3._udp.*TS3SERVER*"
2018/03/02 17:01:47 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |1  |Lookup finished: ***.***.***.*** **** *TS3SERVER* 1 0
2018/03/02 17:01:47 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |1  |Resolve successful: ***.***.***.***:****
2018/03/02 17:01:47 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |1  |Blacklist check ok
2018/03/02 17:01:47 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |1  |Initiating connection: ****.****.****.****:**** *TS3SERVER*
2018/03/02 17:01:47 3b9312ad bf027890 INFO   TS |INFO    |PreProSpeex   |1  |Speex version: 1.2rc1
2018/03/02 17:01:48 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |1  |Connect status: Connecting
2018/03/02 17:01:48 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |   |Last update check was: Tue Jan 1 00:00:01 2019
2018/03/02 17:01:48 3b9312ad bf027890 INFO   New connection status 1; Error 0
2018/03/02 17:01:48 3b9312ad bf027890 INFO   TS |INFO    |              |   |Statistics report: Not yet, next report on Fri Mar 9 15:53:21 2018
2018/03/02 17:01:53 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |1  |Connect status: Disconnected
2018/03/02 17:01:53 3b9312ad bf027890 INFO   TS |INFO    |ClientUI      |1  |Failed to connect to server, want autoreconnect = 0
2018/03/02 17:01:53 3b9312ad bf027890 INFO   The bot could not connect. This might have several reasons: the server doesn't exist at that address, the server password is wrong, the default channel doesn't exist, the bot has been banned, the server is an illegal installation or the password is wrong , the security level of your identity is too low or the server does not allow the version of the client you are using. See our Wiki / Forums for more help.
2018/03/02 17:01:53 3b9312ad bf027890 INFO   New connection status 0; Error 1797
2018/03/02 17:01:54 3b9312ad bf027890 DEBUG  TS>libpng warning: iCCP: known incorrect sRGB profile
2018/03/02 17:01:54 3b9312ad bf027890 DEBUG  TS>warning: The VAD has been replaced by a hack pending a complete rewrite
2018/03/02 17:01:54 3b9312ad bf027890 DEBUG  Closed.
2018/03/02 17:01:54 3b9312ad bf027890 INFO   TSClient quit.
2018/03/02 17:02:06 3b9312ad bf027890 DEBUG  Storing configuration.

2018/03/02 17:02:30 [GENERAL        ] Shutting down... Hold on...
Update:
  • The server doesn't exist at that address
    • Verified, the address is correct
  • The server password is wrong
    • The server does not require a password
  • The default channel doesn't exist
    • The default channel is defined and exists
  • The bot has been banned
    • There are no registered bans, and from the server side there are no connection attempts by the bot.
  • The server is an illegal installation or the password is wrong
    • The server is not blacklisted or a password is requested
  • The security level of your identity is too low
    • The bot meets the minimum required by default, increasing the security of the identity did not solve the problem (Tested).
  • The server does not allow the version of the client you are using
    • There are 2 instances in the server, Sinusbot connects perfectly to one, but it is impossible in the other.
 
Last edited:

Confi

New Member
For anyone who encounters this (& you're sure your server settings are fine)

The fix for me was to allow outgoing UDP connection to the port of the server.
Let's say your bot should connect to myts.sinusbot.com:9987 then you should allow outbound UDP port 9987 to myts.sinusbot.com (or 0.0.0.0 if you don't mind) on your firewall.
 
Thread starter Similar threads Forum Replies Date
M General Questions 6
A General Questions 11
T General Questions 2
H General Questions 4
Gox112 General Questions 1

Similar threads

Top