• TeamSpeak has reported a vulnerability in it's client that can potentially lead to RCE. A new version has been released that fixes it. So please update the client in your bot installation as soon as possible as well. Click here for more information.
  • If you need help or want to discuss things, you now can also join us on our Discord Server!

ERROR: Unable to download webpage: HTTP Error 429

Status
Not open for further replies.

Grepher76

Active Member
Hello,

I have a problem with youtube-dl !!

Here are my logs :

ERROR: Unable to download webpage: HTTP Error 429: Too Many Requests (caused by HTTPError()); please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; type youtube-dl -U to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.

youtube-dl -U = youtube-dl is up-to-date (2016.01.15).

youtube-dl --verbose
:

[debug] System config: [u'--extract-audio', u'--no-mtime']
[debug] User config: []
[debug] Command-line args: [u'--verbose', u'
[debug] Encodings: locale ANSI_X3.4-1968, fs ANSI_X3.4-1968, out ANSI_X3.4-1968, pref ANSI_X3.4-1968
[debug] youtube-dl version 2016.01.15
[debug] Python version 2.7.3 - Linux-2.6.32-openvz-042stab106.4-amd64-x86_64-with-debian-7.9
[debug] exe versions: none
[debug] Proxy map: {}
[youtube] TMSIR210mRg: Downloading webpage
ERROR: Unable to download webpage: HTTP Error 429: Too Many Requests (caused by HTTPError()); please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; type youtube-dl -U to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.
File "/usr/local/bin/youtube-dl/youtube_dl/extractor/common.py", line 351, in _request_webpage
return self._downloader.urlopen(url_or_request)
File "/usr/local/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 1890, in urlopen
return self._opener.open(req, timeout=self._socket_timeout)
File "/usr/lib/python2.7/urllib2.py", line 407, in open
response = meth(req, response)
File "/usr/lib/python2.7/urllib2.py", line 520, in http_response
'http', request, response, code, msg, hdrs)
File "/usr/lib/python2.7/urllib2.py", line 445, in error
return self._call_chain(*args)
File "/usr/lib/python2.7/urllib2.py", line 379, in _call_chain
result = func(*args)
File "/usr/lib/python2.7/urllib2.py", line 528, in http_error_default
raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)

Can you help me please ?

Thank you for help.

Ps: sorry for my english , I'm french.
 

Xuxe

Containerholic
Staff member
V.I.P.
is awesome!
Contributor
Insider
ERROR: Unable to download webpage: HTTP Error 429: Too Many Requests (caused by HTTPError()); please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; type youtube-dl -U to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.
Hey,

Simply you have done to many requests to the Youtube servers. Wait some time and try again.
 

Seph29

Donor
is awesome!
J'ai eu le même problème avec mon bot chez ovh et une ipv6
peux tu essayer cette commande

i had the same problem with ovh and ipv6
Can you try this cmd

Code:
youtube-dl --force-ipv4 https://www.youtube.com/watch?v=TMSIR210mRg
 

Grepher76

Active Member
#Seph29: Ta solution ne fonctionne pas !

#Seph29: Your solution does not work !

#Xuxe: It does not work for 1 week! so I waited seven days ;)

Do you have any other options for me please ?
 

mauzao9

Member
This is messed up, it seems the whole OVH entire network on ipv6 is blocked Youtube-wise. How can we work around on Sinusbot, to enforce ipv4 every time? Because that's the only way to get this working now.
 

Mystik

Member
As a fellow OVH user it seems that I'm having the same problem as described here, but I can't add the IPV4 force because there is no configuration "youtube-dl.conf" in /etc/ :eek: Tested youtube_dl manually from terminal and it works fine with -4 parameter, so it must be installed correctly.

Perhaps I'm just missing something very simple here?

OS: Debian 8 64-bit
TS3 Client: 3.0.18.2 64-bit
youtube_dl: 2016.03.27
 
Last edited:

DTBA

New Member
I am running a windows vm with the bot installed. Now the same thing is happening to me. I got around it by exporting my firefox cookies and making youtube-dl read the config file by adding --cookies to %APPDATA%\youtube-dl\config.txt.

Now this works 100% if I use the cmd and youtube-dl. But as soon as I use sinus bot it ignores the youtube-dl config


Is there a way around this. To force sinus bot to add the command --cookies to it
 
Status
Not open for further replies.

Similar threads

Top