• TeamSpeak has reported a vulnerability in it's client that can potentially lead to RCE. A new version has been released that fixes it. So please update the client in your bot installation as soon as possible as well. Click here for more information.
  • If you need help or want to discuss things, you now can also join us on our Discord Server!

LogLevel has been increased

Schmand

Member
Hallo zusammen,

ich habe gerade SinusBot über das Install Script installiert, erhalte jedoch nun immer die Fehlermeldung "LogLevel has been increased" anschließend verschwindet der Bot wieder aus dem TS und im Webinterface ist er ebenso wieder ausgeschaltet. Ich hoffe jemand hat eine Idee :)

Danke im Vorraus ;)

Log:
Code:
2019-05-15T20:11:07+02:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019-05-15T20:11:07+02:00 TS |INFO |Integrations | |Requesting integration icon download from https://ts3services.teamspeak.com/integration_icons/twitch/twitch.svg
2019-05-15T20:11:07+02:00 TS |INFO | | |Statistics report: Not yet, next report on Mo. Mai 27 16:43:55 2019
2019-05-15T20:11:07+02:00 TS |INFO |ClientUI | |Last update check was: Sa. Jan. 1 00:00:01 2022
2019-05-15T20:11:07+02:00 TS |INFO |Bookmarks | |Collecting autoconnect bookmarks
2019-05-15T20:11:07+02:00 New connection status 4; Error 0
2019-05-15T20:11:07+02:00 TS |INFO |PermManager | |Loading permissions from cache
2019-05-15T20:11:07+02:00 TS |INFO |ClientUI |1 |Connect status: Connection established
2019-05-15T20:11:07+02:00 TS |INFO |ClientUI |1 |Connect status: Establishing connection
2019-05-15T20:11:07+02:00 New connection status 3; Error 0
2019-05-15T20:11:07+02:00 New connection status 2; Error 0
2019-05-15T20:11:07+02:00 TS |INFO |ClientUI |1 |Connect status: Connected
2019-05-15T20:11:07+02:00 TS |INFO |ClientUI |1 |Connect status: Connecting
2019-05-15T20:11:07+02:00 New connection status 1; Error 0
2019-05-15T20:11:07+02:00 TS |DEVELOP |PktHandler | |Puzzle solve time: 4
2019-05-15T20:11:07+02:00 TS |INFO |PreProSpeex |1 |Speex version: 1.2rc1
2019-05-15T20:11:07+02:00 TS |INFO |ClientUI |1 |Initiating connection: 192.168.0.102:9987
2019-05-15T20:11:07+02:00 TS |INFO |ClientUI |1 |Connect to server: 192.168.0.102
2019-05-15T20:11:07+02:00 TS |INFO |ClientUI | |ts3server: 192.168.0.102?port=9987&nickname=&password=&channel=&channelpassword=
2019-05-15T20:11:06+02:00 TS |INFO |ClientUI | |Using configuration location: /home/teamspeak3/teamspeak3-server_linux_amd64/sinusbot/data/ts3/8d789d00-e28c-43ea-a131-724fa0ec8b2c/e2a8311f-3605-4ff0-a6e7-84465b86979d/settings.db
2019-05-15T20:11:06+02:00 TS |INFO |ClientUI | |Qt version: 5.6.1
2019-05-15T20:11:06+02:00 TS |INFO |ClientUI | |Failed to init text to speech engine
2019-05-15T20:11:06+02:00 TS |DEVELOP |ClientUI | |Notifications init: Soundpack path: /home/teamspeak3/teamspeak3-server_linux_amd64/sinusbot/teamspeak3-client/sound/nosounds
2019-05-15T20:11:06+02:00 TS |INFO | | |*** Time [INIT]: 122
2019-05-15T20:11:06+02:00 TS |INFO | | |*** Time [MAINWINDOW]: 121
2019-05-15T20:11:06+02:00 TS |INFO |Plugins | |Loading plugin: libsoundbot_plugin.so
2019-05-15T20:11:06+02:00 TS |INFO |Addons | |Checking for addon updates...
2019-05-15T20:11:06+02:00 TS |ERROR |RevocationListCache| |Failed to import revocation list from cache
2019-05-15T20:11:06+02:00 TS |INFO |ClientUI | |Unable to create an Open GL context.
2019-05-15T20:11:06+02:00 TS |ERROR |SoundBckndIntf| |libpulse.so.0: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
2019-05-15T20:11:06+02:00 TS |INFO | | |Using hardware aes
2019-05-15T20:11:06+02:00 TS |INFO | | |SystemInformation: Linux 4.19.0-4-amd64 #1 SMP Debian 4.19.28-2 (2019-03-15) x86_64 Binary: 64bit
2019-05-15T20:11:06+02:00 TS |INFO | | |TeamSpeak 3 Client 3.2.5 (2019-04-17 16:07:33)
2019-05-15T20:11:06+02:00 Starting instance ts3server://192.168.0.102?port=9987&nickname=Bunkerfunk&password=&channel=&channelpassword=
2019-05-15T20:11:06+02:00 Could not create Notifications-Tabletable Notifications already exists
2019-05-15T20:11:06+02:00 Could not create WhisperReceive-Tabletable WhisperReceive already exists
2019-05-15T20:11:06+02:00 Could not create Chat-Tabletable Chat already exists
2019-05-15T20:11:02+02:00 script command loaded
2019-05-15T20:11:02+02:00 Initialization complete
 

Schmand

Member
Hey, danke für die schnelle Rückmeldung.

Den LogLevel hatte ich schon auf 10 gesetzt. Brachte leider keine Veränderung.

  • die benutzte Sinusbot- und TS Client & Server Version
    • Beides jeweils aktuellste
  • das Betriebssystem (z.B. Windows, 64bit)
    • Debian Buster x64
  • verwendete Hardware (z.B. VPS, Core i7, 8 GB RAM):
    • ESXi Host 8 CPUs x Intel(R) Xeon(R) CPU D-1540 @ 2.00GHz
    • 32GB DDR4
Hier einmal der Instanz-Log

Code:
2019-05-15T21:10:51+02:00 Storing configuration.
2019-05-15T21:10:28+02:00 Closed.
2019-05-15T21:10:28+02:00 TS>QMutex: destroying locked mutex
2019-05-15T21:10:28+02:00 TS>140152879590656:error:0E076071:configuration file routines:MODULE_RUN:unknown module name:conf_mod.c:222:module=ssl_conf
2019-05-15T21:10:28+02:00 TS>140152879590656:error:0E07506E:configuration file routines:MODULE_LOAD_DSO:error loading dso:conf_mod.c:285:module=ssl_conf, path=ssl_conf
2019-05-15T21:10:28+02:00 TS>140152879590656:error:25070067:DSO support routines:DSO_load:could not load the shared library:dso_lib.c:244:
2019-05-15T21:10:28+02:00 TS>140152879590656:error:25066067:DSO support routines:DLFCN_LOAD:could not load the shared library:dso_dlfcn.c:185:filename(libssl_conf.so): libssl_conf.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
2019-05-15T21:10:28+02:00 TS>Auto configuration failed
2019-05-15T21:10:28+02:00 TS>libpng warning: iCCP: known incorrect sRGB profile
2019-05-15T21:10:28+02:00 TS>QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
2019-05-15T21:10:28+02:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019-05-15T21:10:28+02:00 TS>QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
2019-05-15T21:10:28+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2019-05-15T21:10:28+02:00 TS |INFO |Integrations | |Requesting integration icon download from https://ts3services.teamspeak.com/integration_icons/twitch/twitch.svg
2019-05-15T21:10:28+02:00 TS |INFO | | |Statistics report: Setting next report date to: Sa. Juni 8 21:10:28 2019
2019-05-15T21:10:28+02:00 TS |INFO | | |Statistics report: First run, report later in 1-30 days
2019-05-15T21:10:28+02:00 TS |INFO |ClientUI | |Last update check was: Sa. Jan. 1 00:00:01 2022
2019-05-15T21:10:28+02:00 TS |INFO |Bookmarks | |Collecting autoconnect bookmarks
2019-05-15T21:10:28+02:00 New connection status 4; Error 0
2019-05-15T21:10:28+02:00 TS |INFO |PermManager | |Requesting permissions from server
2019-05-15T21:10:28+02:00 TS |INFO |ClientUI |1 |Connect status: Connection established
2019-05-15T21:10:28+02:00 Masterhero joined the channel
2019-05-15T21:10:28+02:00 M3ndez joined the channel
2019-05-15T21:10:28+02:00 Ghost joined the channel
2019-05-15T21:10:28+02:00 Andre | Schmand joined the channel
2019-05-15T21:10:28+02:00 New connection status 3; Error 0
2019-05-15T21:10:28+02:00 TS |INFO |ClientUI |1 |Connect status: Establishing connection
2019-05-15T21:10:28+02:00 New connection status 2; Error 0
2019-05-15T21:10:28+02:00 TS |INFO |ClientUI |1 |Connect status: Connected
2019-05-15T21:10:28+02:00 New connection status 1; Error 0
2019-05-15T21:10:28+02:00 TS |DEVELOP |PktHandler | |Puzzle solve time: 3
2019-05-15T21:10:28+02:00 TS |INFO |ClientUI |1 |Connect status: Connecting
2019-05-15T21:10:28+02:00 TS |INFO |PreProSpeex |1 |Speex version: 1.2rc1
2019-05-15T21:10:28+02:00 TS |INFO |ClientUI |1 |Initiating connection: 127.0.0.1:9987
2019-05-15T21:10:28+02:00 TS |INFO |ClientUI |1 |Connect to server: 127.0.0.1
2019-05-15T21:10:28+02:00 TS |INFO |ClientUI | |ts3server: 127.0.0.1?port=9987&nickname=SinusBot&password=&channel=&channelpassword=
2019-05-15T21:10:27+02:00 TS |INFO |ClientUI | |Using configuration location: /opt/sinusbot/data/ts3/f67c11da-9fa5-41b5-89ec-5ce3e5ac0b87/a9acef73-a8df-4b04-a786-62a80c32f930/settings.db
2019-05-15T21:10:27+02:00 TS |INFO |ClientUI | |Qt version: 5.6.1
2019-05-15T21:10:27+02:00 TS |INFO |ClientUI | |Failed to init text to speech engine
2019-05-15T21:10:27+02:00 TS |DEVELOP |ClientUI | |Notifications init: Soundpack path: /opt/sinusbot/teamspeak3-client/sound/nosounds
2019-05-15T21:10:27+02:00 TS |INFO | | |*** Time [INIT]: 101
2019-05-15T21:10:27+02:00 TS |INFO | | |*** Time [MAINWINDOW]: 101
2019-05-15T21:10:27+02:00 TS |INFO |Plugins | |Loading plugin: libsoundbot_plugin.so
2019-05-15T21:10:27+02:00 TS |INFO |Addons | |Checking for addon updates...
2019-05-15T21:10:27+02:00 TS |ERROR |RevocationListCache| |Failed to import revocation list from cache
2019-05-15T21:10:27+02:00 TS |INFO |ClientUI | |Unable to create an Open GL context.
2019-05-15T21:10:27+02:00 TS |ERROR |SoundBckndIntf| |libpulse.so.0: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
2019-05-15T21:10:27+02:00 TS |INFO | | |Using hardware aes
2019-05-15T21:10:27+02:00 TS |INFO | | |SystemInformation: Linux 4.19.0-4-amd64 #1 SMP Debian 4.19.28-2 (2019-03-15) x86_64 Binary: 64bit
2019-05-15T21:10:27+02:00 TS |INFO | | |TeamSpeak 3 Client 3.2.5 (2019-04-17 16:07:33)
2019-05-15T21:10:27+02:00 TS>DUMP defined! Dumpdir is: /opt/sinusbot/data/ts3/f67c11da-9fa5-41b5-89ec-5ce3e5ac0b87/a9acef73-a8df-4b04-a786-62a80c32f930/crashdumps
2019-05-15T21:10:27+02:00 TS>Crashdump ENABLED, directory is: /opt/sinusbot/data/ts3/f67c11da-9fa5-41b5-89ec-5ce3e5ac0b87/a9acef73-a8df-4b04-a786-62a80c32f930/crashdumps
2019-05-15T21:10:27+02:00 Starting instance ts3server://127.0.0.1?port=9987&nickname=SinusBot&password=&channel=&channelpassword=
2019-05-15T21:10:27+02:00 Could not insert into News-Tableno such table: News
2019-05-15T21:10:27+02:00 Could not delete from Newsno such table: News
2019-05-15T21:10:27+02:00 Could not insert into News-Tableno such table: News
2019-05-15T21:10:27+02:00 Could not delete from Newsno such table: News
2019-05-15T21:10:27+02:00 Could not insert into News-Tableno such table: News
2019-05-15T21:10:27+02:00 Could not delete from Newsno such table: News
2019-05-15T21:10:27+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-05-15T21:10:27+02:00 Could not delete from FileTransferno such table: FileTransfer
2019-05-15T21:10:27+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-05-15T21:10:27+02:00 Could not delete from FileTransferno such table: FileTransfer
2019-05-15T21:10:27+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-05-15T21:10:27+02:00 Could not delete from FileTransferno such table: FileTransfer
2019-05-15T21:10:27+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-05-15T21:10:27+02:00 Could not delete from FileTransferno such table: FileTransfer
2019-05-15T21:10:27+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-05-15T21:10:27+02:00 Could not delete from FileTransferno such table: FileTransfer
2019-05-15T21:10:27+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-05-15T21:10:27+02:00 Could not delete from FileTransferno such table: FileTransfer
2019-05-15T21:10:27+02:00 About to run.
2019-05-15T21:10:27+02:00 Prespawn.
2019-05-15T21:10:22+02:00 script command loaded
2019-05-15T21:10:22+02:00 module registered as command
2019-05-15T21:10:22+02:00 registered callback for event chat
2019-05-15T21:10:22+02:00 Initialization complete
2019-05-15T21:10:22+02:00 executing script command
Hier noch der Code vom DiagScript ^^

Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
- Operating System: Debian GNU/Linux buster/sid
- Kernel: Linux 4.19.0-4-amd64 x86_64
- Load Average: 0.05 0.06 0.06
- Uptime: 0 days, 5 hours, 5 minutes, 15 seconds
- OS x64 check: OK
- OS Updates: 0 (well done!)
- OS Missing Packages: None
- OS APT Last Update: 15.05.2019 21:06:46 CEST +02:00:00
- SHELL LOCALE LANG: de_DE.UTF-8
- Bot Start Script: not found
- DNS resolution check: www.sinusbot.com resolved to 104.28.14.74 -> OK
- HTTPS check with IPv4 mode: SUCCESS [Connection was established to www.sinusbot.com, CODE #200]
- HTTPS check with IPv6 mode: IGNORE
- CPU:
    Architecture:        x86_64
    CPU(s):              2
    Thread(s) per core:  1
    Core(s) per socket:  1
    Socket(s):           2
    Model name:          Intel(R) Xeon(R) CPU D-1540 @ 2.00GHz
    CPU MHz:             1999.998
    Hypervisor vendor:   VMware
    Virtualization type: full
- RAM: 305.50 MB/987.28 MB in use (30%)
- SWAP: 768.00 KB/1021.99 MB in use (0%)
- DISK: 2.07 GB/18.57 GB in use (11%)
- Package versions:
   + libglib: 2.58.3-1

BOT INFORMATION
- Status: not running
- Webinterface: port locally not reachable (Port: 8087)
- Binary: /opt/sinusbot/sinusbot
- Binary Info: MD5 Hash: 6f301dac3e4dfd45ce149933c5dadd08, Perms: 755, User: sinusbot
- Version: 1.0.0-beta.1-06a54d7
- TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: 59c9a688307aa73af9573029a7625fc5
   - TS3 Client: 59c9a688307aa73af9573029a7625fc5
- Config:
   - LogLevel = 10
   - TS3Path = /opt/sinusbot/teamspeak3-client/ts3client_linux_amd64 (Version 3.2.5)
   - YoutubeDLPath = /usr/local/bin/youtube-dl (does exist, version: )
- Installed scripts: advertising.js; alonemode.js; bookmark.js; command.js; followme.js; norecording.js; rememberChannel.js; welcome.js

TIME INFORMATION
- Time (local): 15.05.2019 21:37:59 CEST +02:00:00
- Time (remote): 15.05.2019 21:37:59 CEST +02:00:00
- Time (difference): 0 secs (Time diff less than 2 secs. Good.)
- Timezone: Europe/Berlin

OTHER INFORMATION
- TeamSpeak 3 Version: 3.2.5
- youtube-dl Version:
- DiagScript Version: 0.7.1
==========================================================
Vielleicht hat ja jemand eine Idee. Btw. hatte ich damals Sinusbot laufend und voll funktionsfähig. Ich kann den Fehler irgendwie gerade nicht nachvollziehen :(

//EDIT
Ggf. ist Sinusbot nicht mit Debian 10 kompatibel?
 
Last edited:

Himsel

Donor
is awesome!
Contributor
Hat eventuell dein User nicht genügend Rechte?

Wenn du im Installer bei "Benutzer erstellen" nichts eingegeben hast sollte es "sinusbot" sein

dann versuche mal folgendes (Falls du einen Benutzer eingegeben hast bitte "sinusbot:sinusbot" entsprechend abändern)

chown -R sinusbot:sinusbot /opt/sinusbot


und dann schau mal ob es funktioniert
 
Last edited:

Schmand

Member
Die vermutung hatte ich auch schon. Hatte ich ausgeführt, brachte leider nicht den gewünschten erfolg.

//EDIT
Selbst die manuelle Installation funktionierte nur mit den gleichen Fehlern :(
 

Himsel

Donor
is awesome!
Contributor
Ich hab dein OS erst garnicht gesehen aber befürchte es hat was mit Debian Buster zutun. (Bin mir nicht sicher)
 
Last edited:

flyth

is reticulating splines
Staff member
Developer
Contributor
Vielleicht hilft das hier? Ich selbst bin noch nicht dazu gekommen, es zu testen.
 

Schmand

Member
Danke für die Hilfe flyth ;)
Trägt man das ganze in eine cfg ein, oder soll man das manuell ausführen? Verstehe nicht so ganz was er da treibt ^^.

Danke euch erstmal ;)
 

flyth

is reticulating splines
Staff member
Developer
Contributor
Im Prinzip erstellt er nur eine "Kopie" der Datei libssl.so.1.0.0 nach libssl_conf.so. "Kopie" in Anführungszeichen, weil es nur ein Symlink ist.
Es kann sein, dass sich da in der Benennung was getan hat und unter dem neuen Debian nach einer anderen Datei gesucht wird.
 

Himsel

Donor
is awesome!
Contributor
Danke für die Hilfe flyth ;)
Trägt man das ganze in eine cfg ein, oder soll man das manuell ausführen? Verstehe nicht so ganz was er da treibt ^^.

Danke euch erstmal ;)
Da du den Installer benutzt hast wird folgender command in der Console stimmen
cd /opt/sinusbot/teamspeak3-client/ && ln -s libssl.so.1.0.0 libssl_conf.so

der andere ist bloß wenn man es manuell installiert hat. Er kann ja nicht wissen wohin du es installiert hast
 
Last edited:

Schmand

Member
Hallo zusammen,

um das ganze einmal aufzuklären, sollte jemand dasselbe Problem haben :)
Die Lösung war es tatsächlich einen symbolischen Link zu erstellen.

Danke euch. Für die Hilfe :)

:closed:
 

flyth

is reticulating splines
Staff member
Developer
Contributor
Danke fürs Feedback! Nehmen wir dann bald mal in die Installationsanleitung auf!
 
Top