• If you need help or want to discuss things, you now can also join us on our Discord Server!
  • Happy New Year everyone! A new version (1.0.0-beta.16) is out for Linux, fixing an issue that could lock the bot up when using it with TS3. Please visit the resources section or the main page (https://www.sinusbot.com) for the new package.

Mein Sinusbot findet TeamSpeak nicht

SxWolfxS

New Member
Wenn ich den Bot starten will kommt nur diese Fehler meldung

Could not find TeamSpeak 3 Client: stat /opt/sinusbot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64: no such file or directory
Sanity checks failed, unable to run. Please read the installation-guide carefully and contact support if necessary.


Mein Server ist ein VServer
System ist Debian 10



==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
- Operating System: Debian GNU/Linux 10 (buster)
- Kernel: Linux 4.19.0-9-amd64 x86_64
- Load Average: 0.02 0.03 0.00
- Uptime: 0 days, 1 hours, 44 minutes, 48 seconds
- OS x64 check: OK
- OS Updates: 0 (well done!)
- OS Missing Packages: None
- OS APT Last Update: 30.06.2020 19:44:24 CEST +02:00:00
- Shell Locale: de_DE.UTF-8
- Bot Start Script: not found
- CPU:
Architecture: x86_64
CPU(s): 1
Thread(s) per core: 1
Core(s) per socket: 1
Socket(s): 1
Model name: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
CPU MHz: 4008.004
Hypervisor vendor: KVM
Virtualization type: full
- RAM: 374.56 MB/3.81 GB in use (9%)
- SWAP: 0 B/3.95 GB in use (0%)
- DISK: 2.98 GB/35.22 GB in use (8%)
- Package versions:
- libglib: 2.58.3-2+deb10u2

BOT INFORMATION
- Status: not running
- Webinterface: port locally not reachable (Port: 8087)
- Binary: /opt/ts3soundboard/sinusbot
- Binary Info: MD5 Hash: 224b687db910b732fe5a7cfec4f6c78e, Perms: 775, User: sinusbot
- Version: 1.0.0-beta.10-202ee4d
- TS3 Plugin: unknown (TS3client not found)
- Bot Plugin: unknown
- TS3 Client: unknown
- Config:
- LogLevel =
- TS3Path = /opt/sinusbot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 (TS3client-binary does not exist!)
- YoutubeDLPath = not set
- Installed scripts: advertising.js; alonemode.js; bookmark.js; command.js; followme.js; norecording.js; rememberChannel.js; sinusbot-commands.js; welcome.js

BOT TECHNICAL INFORMATION
- File exists:
- TS3Client/libqxcb-glx-integration.so:
- LDD output:
linux-vdso.so.1 (0x00007fff749ba000)
libswresample.so.2 => /opt/ts3soundboard/libswresample.so.2 (0x00007f7e497ae000)
libavfilter.so.6 => /opt/ts3soundboard/libavfilter.so.6 (0x00007f7e49456000)
libavformat.so.57 => /opt/ts3soundboard/libavformat.so.57 (0x00007f7e49055000)
libavcodec.so.57 => /opt/ts3soundboard/libavcodec.so.57 (0x00007f7e486f0000)
libavutil.so.55 => /opt/ts3soundboard/libavutil.so.55 (0x00007f7e4847c000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f7e48470000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f7e482eb000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f7e482ca000)
libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f7e48146000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f7e4812c000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f7e47f6b000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f7e47d4d000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f7e47d41000)
/lib64/ld-linux-x86-64.so.2 (0x00007f7e499ca000)

REACHABILITY CHECKS
- HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
- HTTPS check with IPv6 mode: IGNORED [Disabled]
- DNS resolution check: SUCCESS [www.sinusbot.com resolved to 104.28.14.74]
- Update server checks:
update01.sinusbot.com -> 104.28.14.74: SUCCESS [CODE #404]
update02.sinusbot.com -> 104.28.14.74: SUCCESS [CODE #404]
update03.sinusbot.com -> 172.67.132.160: SUCCESS [CODE #404]

TIME INFORMATION
- Time (local): 30.06.2020 21:33:00 CEST +02:00:00
- Time (remote): 30.06.2020 21:33:00 CEST +02:00:00
- Time (difference): 0 secs (Time diff less than 2 secs. Good.)
- Timezone: Europe/Berlin

OTHER INFORMATION
- TeamSpeak3 Version: unknown
- youtube-dl Version: unknown
- DiagScript Version: 0.8.0
==========================================================
 

Himsel

Well-Known Member
Contributor
hi

bist du dir denn sicher, dass du den client auch dorthin installiert hast?
- TS3Path = /opt/sinusbot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64

Falls nötig, kannst du den pfad auch in /opt/sinusbot/config.ini anpassen

wie @Multivitamin richtig gesehen hat musst du den pfad dann natürlich in /opt/ts3soundboard/config.ini anpassen.
 
Last edited:

Multivitamin

Well-Known Member
Tier III
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
/opt/sinusbot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 (TS3client-binary does not exist!)

wie du siehst ist in deiner config.ini eingetragen dass sich der sinusbot unter /opt/sinusbot befinden soll aber dein bot unter /opt/ts3soundboard installiert ist
 
Top