• If you need help or want to discuss things, you now can also join us on our Discord Server!

Sinusbot - TS Client crash on play

Gustav76

Member
Hello there!

I hope you can help me. Some days ago i bought a new root server. After i installed some basic things i had to get my Sinusbots back. Same like on the Server before i used the Installscript
Code:
https://sinusbot-installer.de/
It always worked fine without any problems. But now it was different. Installation finished without any Errors. I logged in into the Webpanel and added one Radiostation. The Bot joint my Teamspeak without problems. When i click on 'Play' the Bot loose connection after some seconds.

Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
 - Operating System: Debian GNU/Linux 9.9 (stretch)
 - Kernel: Linux 4.19-ovh-xxxx-std-ipv6-64 x86_64
 - Load Average: 0.46 0.30 0.27
 - Uptime: 4 days, 20 hours, 39 minutes, 23 seconds
 - OS x64 check: OK
 - OS Updates: 2 (updates available!)
 - OS Missing Packages: None
 - OS APT Last Update: 06.08.2019 18:00:06 UTC +00:00:00
 - Shell Locale: de_DE.UTF-8
 - Bot Start Script: not found
 - CPU:
    CPU(s):                4
    CPU MHz:               863.135
 - RAM: 2.00 GB/3.81 GB in use (52%)
 - SWAP: 5.03 MB/15.99 GB in use (0%)
 - DISK: 81.76 GB/1.77 TB in use (4%)
 - Package versions:
   - libglib: 2.50.3-2

BOT INFORMATION
 - Status: running (PIDs: 18173 18172, User: web1 sinusbot)
 - Webinterface: port locally reachable (Port: 8087)
 - Binary: /opt/sinusbot/sinusbot
 - Binary Info: MD5 Hash: d770dee2259d159aa78550962d3251e3, Perms: 755, User: sinusbot
 - Version: 1.0.0-beta.3-735814e
 - TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: 2e771e4332cf87da1f72d58aa6923f9f
   - TS3 Client: 2e771e4332cf87da1f72d58aa6923f9f
 - Config:
   - LogLevel = 10 (debug log active)
   - TS3Path = /opt/sinusbot/teamspeak3-client/ts3client_linux_amd64 (Version 3.3.0)
   - YoutubeDLPath = /usr/local/bin/youtube-dl (does exist, version: 2019.08.02)
 - Installed scripts: advertising.js; alonemode.js; bookmark.js; command.js; followme.js; norecording.js; rememberChannel.js; welcome.js

BOT TECHNICAL INFORMATION
 - File exists:
   - TS3Client/libqxcb-glx-integration.so: no
 - LDD output:
    linux-vdso.so.1 (0x00007ffc175a1000)
    libswresample.so.2 => /opt/sinusbot/libswresample.so.2 (0x00007f2df1bc2000)
    libavfilter.so.6 => /opt/sinusbot/libavfilter.so.6 (0x00007f2df186a000)
    libavformat.so.57 => /opt/sinusbot/libavformat.so.57 (0x00007f2df1469000)
    libavcodec.so.57 => /opt/sinusbot/libavcodec.so.57 (0x00007f2df0b04000)
    libavutil.so.55 => /opt/sinusbot/libavutil.so.55 (0x00007f2df0890000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f2df068c000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f2df0388000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f2df016b000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f2defde9000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f2defbd2000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f2def833000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f2def619000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f2def411000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f2df1ddc000)

REACHABILITY CHECKS
 - HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
 - HTTPS check with IPv6 mode: IGNORED [Disabled]
 - DNS resolution check: SUCCESS [www.sinusbot.com resolved to 104.28.15.74]
 - Update server checks:
    update01.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update02.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update03.sinusbot.com -> 104.28.14.74: SUCCESS [CODE #404]

TIME INFORMATION
 - Time (local): 06.08.2019 19:54:03 UTC +00:00:00
 - Time (remote): <Failed retrieving remote time!>
 - Time (difference): n/a secs
 - Timezone: Europe/Paris

OTHER INFORMATION
 - TeamSpeak3 Version: 3.3.0
 - youtube-dl Version: 2019.08.02
 - DiagScript Version: 0.8.0
==========================================================
Code:
Instance Log
2019-08-06T21:53:56+02:00 Storing configuration.
2019-08-06T21:53:44+02:00 VOLUME-SET [admin] 100 OK
2019-08-06T21:53:40+02:00 closing channels
2019-08-06T21:53:40+02:00 new track info: HardBase.FM - HardBase.FM - 24h Hardstyle, Jumpstyle and More (48617264426173652e464d202d2048617264426173652e464d202d2032346820486172647374796c652c204a756d707374796c6520616e64204d6f7265)
2019-08-06T21:53:39+02:00 TSClient quit.
2019-08-06T21:53:39+02:00 TS>Starting Error Reporter: /opt/sinusbot/teamspeak3-client/error_report
2019-08-06T21:53:39+02:00 TS>Breakpad crash /opt/sinusbot/data/ts3/c9966a8f-3450-491b-925f-c6a7d028ec38/59bf14a2-b93c-41cc-ad63-c030355c7b84/crashdumps/a60bb333-9064-4595-c51574b3-bd93c4be.dmp
2019-08-06T21:53:38+02:00 new track info: HardBase.FM (48617264426173652e464d)
2019-08-06T21:53:38+02:00 PLAY [admin] 3ad08c9c-2388-4267-8e4f-cfce00d3b63b OK
If you need any more Information, let me know. I hope you can understand :)

Thanks for your help :)
 

Gustav76

Member
I also installed fresh debian 9.4 on my old server and installed only sinusbot with sinusbot installer. The Problem i got is the same. The Hardware is a bit different so i don't think that there is a Hardware conflict
 

R3v07v3R

Donor
is awesome!
is uber awesome!
I see you're running 1.0.0-b3
BOT INFORMATION
- Status: running (PIDs: 18173 18172, User: web1 sinusbot)
- Webinterface: port locally reachable (Port: 8087)
- Binary: /opt/sinusbot/sinusbot
- Binary Info: MD5 Hash: d770dee2259d159aa78550962d3251e3, Perms: 755, User: sinusbot
- Version: 1.0.0-beta.3-735814e
Here is the Update Process for 1.0.0-b5 (check paths for your system)
Code:
su sinusbot
cd /opt/sinusbot
curl -O https://www.sinusbot.com/pre/sinusbot-1.0.0-beta.5-b262b6a.tar.bz2
tar -xjvf sinusbot-1.0.0-beta.5-b262b6a.tar.bz2
cp plugin/libsoundbot_plugin.so teamspeak3-client/plugins
 

Gustav76

Member
Sometimes the Solution can be so easy :p
i will try this later when I'm @home. But it's very strange that the installer script doesn't install the newest version. Looks like it is outdated :eek:
 

Gustav76

Member
Hi there!

Thanks for your help. The Update was easily done without complications. But i doesn't have any good news. The Problem is not solved. Maybe do you have another solution? Of course i stopped Sinusbot before i installed the Update

Here again a new Diagnostic Script:
Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
 - Operating System: Debian GNU/Linux 9.9 (stretch)
 - Kernel: Linux 4.19-ovh-xxxx-std-ipv6-64 x86_64
 - Load Average: 0.55 0.51 0.40
 - Uptime: 5 days, 20 hours, 13 minutes, 37 seconds
 - OS x64 check: OK
 - OS Updates: 3 (updates available!)
 - OS Missing Packages: None
 - OS APT Last Update: 07.08.2019 18:00:05 UTC +00:00:00
 - Shell Locale: de_DE.UTF-8
 - Bot Start Script: not found
 - CPU:
    CPU(s):                4
    CPU MHz:               1053.392
 - RAM: 2.07 GB/3.81 GB in use (54%)
 - SWAP: 5.03 MB/15.99 GB in use (0%)
 - DISK: 81.82 GB/1.77 TB in use (4%)
 - Package versions:
   - libglib: 2.50.3-2

BOT INFORMATION
 - Status: running (PIDs: 9776 9775, User: web1 sinusbot)
 - Webinterface: port locally reachable (Port: 8087)
 - Binary: /opt/sinusbot/sinusbot
 - Binary Info: MD5 Hash: 2ee075d4cb2a3a640862b4eefa0fa6b1, Perms: 755, User: sinusbot
 - Version: 1.0.0-beta.5-b262b6a
 - TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: 2e771e4332cf87da1f72d58aa6923f9f
   - TS3 Client: 2e771e4332cf87da1f72d58aa6923f9f
 - Config:
   - LogLevel = 10 (debug log active)
   - TS3Path = /opt/sinusbot/teamspeak3-client/ts3client_linux_amd64 (Version 3.3.0)
   - YoutubeDLPath = /usr/local/bin/youtube-dl (does exist, version: 2019.08.02)
 - Installed scripts: advertising.js; alonemode.js; bookmark.js; command.js; followme.js; norecording.js; rememberChannel.js; welcome.js

BOT TECHNICAL INFORMATION
 - File exists:
   - TS3Client/libqxcb-glx-integration.so: no
 - LDD output:
    linux-vdso.so.1 (0x00007ffe4fbec000)
    libswresample.so.2 => /opt/sinusbot/libswresample.so.2 (0x00007f6e75683000)
    libavfilter.so.6 => /opt/sinusbot/libavfilter.so.6 (0x00007f6e7532b000)
    libavformat.so.57 => /opt/sinusbot/libavformat.so.57 (0x00007f6e74f2a000)
    libavcodec.so.57 => /opt/sinusbot/libavcodec.so.57 (0x00007f6e745c5000)
    libavutil.so.55 => /opt/sinusbot/libavutil.so.55 (0x00007f6e74351000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f6e7414d000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f6e73e49000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f6e73c2c000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f6e738aa000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f6e73693000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f6e732f4000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f6e730da000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f6e72ed2000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f6e7589d000)

REACHABILITY CHECKS
 - HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
 - HTTPS check with IPv6 mode: IGNORED [Disabled]
 - DNS resolution check: SUCCESS [www.sinusbot.com resolved to 104.28.15.74]
 - Update server checks:
    update01.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update02.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update03.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]

TIME INFORMATION
 - Time (local): 07.08.2019 19:28:17 UTC +00:00:00
 - Time (remote): <Failed retrieving remote time!>
 - Time (difference): n/a secs
 - Timezone: Europe/Paris

OTHER INFORMATION
 - TeamSpeak3 Version: 3.3.0
 - youtube-dl Version: 2019.08.02
 - DiagScript Version: 0.8.0
==========================================================
Code:
Full Instance-Log
2019-08-07T21:23:58+02:00 Storing configuration.
2019-08-07T21:23:32+02:00 closing channels
2019-08-07T21:23:32+02:00 new track info: HardBase.FM - HardBase.FM - 24h Hardstyle, Jumpstyle and More (48617264426173652e464d202d2048617264426173652e464d202d2032346820486172647374796c652c204a756d707374796c6520616e64204d6f7265)
2019-08-07T21:23:31+02:00 TSClient quit.
2019-08-07T21:23:31+02:00 TS>Starting Error Reporter: /opt/sinusbot/teamspeak3-client/error_report
2019-08-07T21:23:31+02:00 TS>Breakpad crash /opt/sinusbot/data/ts3/c9966a8f-3450-491b-925f-c6a7d028ec38/bf803d9f-8d09-4704-9ecb-4d9b3cf26931/crashdumps/8fa7ab1c-c08e-41ca-d72a11b9-a0186e62.dmp
2019-08-07T21:23:31+02:00 new track info: HardBase.FM (48617264426173652e464d)
2019-08-07T21:23:31+02:00 PLAY [admin] 3ad08c9c-2388-4267-8e4f-cfce00d3b63b OK
2019-08-07T21:23:31+02:00 New channel 3ad08c9c-2388-4267-8e4f-cfce00d3b63b () ID 113651fc-dacd-4a65-86c0-2e0afe85b7eb (cc 0)
2019-08-07T21:23:28+02:00 Storing configuration.
2019-08-07T21:23:25+02:00 Lara Schmid joined the channel
2019-08-07T21:23:20+02:00 TS/ERR 2564 e'access to default group is forbidden' x'' r'PR:{32c7fa28-a3f0-4fa3-8818-4823cc7d4938}:66/GCLL'
2019-08-07T21:23:19+02:00 New connection status 4; Error 0
2019-08-07T21:23:19+02:00 TS |INFO |PermManager | |Loading permissions from cache
2019-08-07T21:23:19+02:00 TS |INFO |ClientUI |1 |Connect status: Connection established
2019-08-07T21:23:19+02:00 Lara Schmid joined the channel
2019-08-07T21:23:19+02:00 New connection status 3; Error 0
2019-08-07T21:23:19+02:00 TS |INFO |ClientUI |1 |Connect status: Establishing connection
2019-08-07T21:23:19+02:00 New connection status 2; Error 0
2019-08-07T21:23:19+02:00 TS |INFO |ClientUI |1 |Connect status: Connected
2019-08-07T21:23:19+02:00 TS |DEVELOP |PktHandler | |Puzzle solve time: 21
2019-08-07T21:23:19+02:00 TS |INFO | | |Statistics report: Not yet, next report on Sa. Aug. 10 20:11:05 2019
2019-08-07T21:23:19+02:00 TS |INFO |ClientUI | |Last update check was: Sa. Jan. 1 00:00:01 2022
2019-08-07T21:23:19+02:00 TS |INFO |Bookmarks | |Collecting autoconnect bookmarks
2019-08-07T21:23:19+02:00 New connection status 1; Error 0
2019-08-07T21:23:19+02:00 TS |INFO |ClientUI |1 |Connect status: Connecting
2019-08-07T21:23:19+02:00 TS |INFO |PreProSpeex |1 |Speex version: 1.2rc1
2019-08-07T21:23:18+02:00 TS |INFO |ClientUI |1 |Initiating connection: 127.0.0.1:9987
2019-08-07T21:23:18+02:00 TS |INFO |ClientUI |1 |Connect to server: 127.0.0.1
2019-08-07T21:23:18+02:00 TS |INFO |ClientUI | |ts3server: 127.0.0.1?port=9987&nickname=Maria%20Kr%C3%A4mer&password=&channel=&channelpassword=
2019-08-07T21:23:18+02:00 TS |INFO |ClientUI | |Using configuration location: /opt/sinusbot/data/ts3/c9966a8f-3450-491b-925f-c6a7d028ec38/bf803d9f-8d09-4704-9ecb-4d9b3cf26931/settings.db
2019-08-07T21:23:18+02:00 TS |INFO |ClientUI | |Qt version: 5.12.1
2019-08-07T21:23:18+02:00 TS |INFO |ClientUI | |Failed to init text to speech engine
2019-08-07T21:23:18+02:00 TS |DEVELOP |ClientUI | |Notifications init: Soundpack path: /opt/sinusbot/teamspeak3-client/sound/nosounds
2019-08-07T21:23:18+02:00 TS |INFO | | |*** Time [INIT]: 1338
2019-08-07T21:23:18+02:00 TS |INFO | | |*** Time [MAINWINDOW]: 1338
2019-08-07T21:23:18+02:00 TS>ClientQueryPlugin: currentServerConnectionChanged 1 (0)
2019-08-07T21:23:17+02:00 TS |INFO |Query | |listening on 127.0.0.1:25639
2019-08-07T21:23:17+02:00 TS |INFO |Plugins | |Loading plugin: libclientquery_plugin_linux_amd64.so
2019-08-07T21:23:17+02:00 TS |INFO |Plugins | |Loading plugin: libsoundbot_plugin.so
2019-08-07T21:23:17+02:00 TS |INFO |Addons | |Checking for addon updates...
2019-08-07T21:23:17+02:00 TS |INFO | | |*** Time [ICONMANGER]: 933
2019-08-07T21:23:17+02:00 TS |INFO | | |successfully downloaded revocation list for accounting
2019-08-07T21:23:17+02:00 TS |INFO | | |successfully downloaded revocation list for myteamspeak id
2019-08-07T21:23:17+02:00 TS |ERROR |RevocationListCache| |Failed to import revocation list from cache
2019-08-07T21:23:17+02:00 TS |INFO |ClientUI | |Unable to create an Open GL context.
2019-08-07T21:23:17+02:00 TS |DEBUG |PulseAudio | |connected to pulse audio server -
2019-08-07T21:23:16+02:00 TS |INFO | | |SystemInformation: Linux 4.19-ovh-xxxx-std-ipv6-64 #829949 SMP Wed Jul 31 08:31:49 UTC 2019 x86_64 Binary: 64bit
2019-08-07T21:23:16+02:00 TS |INFO | | |TeamSpeak 3 Client 3.3.0 (2019-06-18 09:29:01)
2019-08-07T21:23:16+02:00 TS>DUMP defined! Dumpdir is: /opt/sinusbot/data/ts3/c9966a8f-3450-491b-925f-c6a7d028ec38/bf803d9f-8d09-4704-9ecb-4d9b3cf26931/crashdumps
2019-08-07T21:23:16+02:00 TS>Crashdump ENABLED, directory is: /opt/sinusbot/data/ts3/c9966a8f-3450-491b-925f-c6a7d028ec38/bf803d9f-8d09-4704-9ecb-4d9b3cf26931/crashdumps
2019-08-07T21:23:16+02:00 Starting instance ts3server://127.0.0.1?port=9987&nickname=Maria%20Kr%C3%A4mer&password=&channel=&channelpassword=
2019-08-07T21:23:16+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-08-07T21:23:16+02:00 Could not delete from FileTransferno such table: FileTransfer
2019-08-07T21:23:16+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-08-07T21:23:16+02:00 Could not delete from FileTransferno such table: FileTransfer
2019-08-07T21:23:16+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-08-07T21:23:16+02:00 Could not delete from FileTransferno such table: FileTransfer
2019-08-07T21:23:16+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-08-07T21:23:16+02:00 Could not delete from FileTransferno such table: FileTransfer
2019-08-07T21:23:16+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-08-07T21:23:16+02:00 Could not delete from FileTransferno such table: FileTransfer
2019-08-07T21:23:16+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-08-07T21:23:16+02:00 Could not delete from FileTransferno such table: FileTransfer
2019-08-07T21:23:16+02:00 Could not create Notifications-Tabletable Notifications already exists
2019-08-07T21:23:16+02:00 Could not create WhisperReceive-Tabletable WhisperReceive already exists
2019-08-07T21:23:16+02:00 Could not create Chat-Tabletable Chat already exists
2019-08-07T21:23:16+02:00 About to run.
2019-08-07T21:23:16+02:00 Prespawn.
2019-08-07T21:22:58+02:00 script command loaded
2019-08-07T21:22:58+02:00 module registered as command
2019-08-07T21:22:58+02:00 registered callback for event chat
2019-08-07T21:22:58+02:00 Initialization complete
2019-08-07T21:22:58+02:00 executing script command
 

TwentyFour

Well-Known Member
is awesome!
V.I.P.
Make sure all dependencies are installed:
Code:
apt-get update
apt-get upgrade
apt-get install -y x11vnc xvfb libxcursor1 ca-certificates bzip2 libnss3 libegl1-mesa x11-xkb-utils libasound2 libpci3 libxslt1.1 libxkbcommon0 curl libglib2.0-0
 

Gustav76

Member
Make sure all dependencies are installed:
Code:
apt-get update
apt-get upgrade
apt-get install -y x11vnc xvfb libxcursor1 ca-certificates bzip2 libnss3 libegl1-mesa x11-xkb-utils libasound2 libpci3 libxslt1.1 libxkbcommon0 curl libglib2.0-0
all these plugins are already installed and are updated. System is also up to date
 

TwentyFour

Well-Known Member
is awesome!
V.I.P.
Depending on your provider, you could be using sources that hold older versions, of the dependencies needed. If that's the case, switching to the official Debian ones could help. Also a fresh install of Debian 10 (most recent version) could be wise. Have my bot running with minimal Debian 10 installation myself, and several others reported to get it working, after struggling on debian 8 and 9.
 

Gustav76

Member
I tried what you sid and switched to the offical Debian sources. That doesn't helped (of course -> apt-get update & apt-get upgrade) On my other Server i tried something differend: i installed sinusbot 1.0.1 beta. This version work fine without any changes
 

TwentyFour

Well-Known Member
is awesome!
V.I.P.

Vizi

Member
Can you post me link to beta.1? i have same problem with beta3-4-5, allways client quit after ckilck play... on debian 10, and now on fresh 9.4
 

TwentyFour

Well-Known Member
is awesome!
V.I.P.
Use beta2... Under Ressources -> History you'll find all versions and the compatibility list.

You're sure, you got all dependencies right? So far everyone I suggested Debian 10 got it working eventually...
Kernel 3.17+? (uname -r)
 
Top