• TeamSpeak has reported a vulnerability in it's client that can potentially lead to RCE. A new version has been released that fixes it. So please update the client in your bot installation as soon as possible as well. Click here for more information.
  • If you need help or want to discuss things, you now can also join us on our Discord Server!

Stale decoder detected - bot stops responding to anything.

olokos

Insider
Insider
Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
- Operating System: Ubuntu 18.04.2 LTS
- Kernel: Linux 5.1.9-050109-generic x86_64
- Load Average: 0.59 0.88 0.88
- Uptime: 2 days, 23 hours, 40 minutes, 55 seconds
- OS x64 check: OK
- OS Updates: 2 (updates available!)
- OS Missing Packages: None
- OS APT Last Update: 19.06.2019 15:32:55 CEST +02:00:00
- Shell Locale: pl_PL.UTF-8
- Bot Start Script: found at /etc/systemd/system/sinusbot.service [perms: 755]
- CPU:
    Architecture:        x86_64
    CPU(s):              cens
    Thread(s) per core:  cens
    Core(s) per socket:  cens
    Socket(s):           cens
    Model name:          QEMU Virtual CPU version 2.5+
    CPU MHz:             cens
    Hypervisor vendor:   KVM
    Virtualization type: full
- RAM: censored/censored GB in use (58%)
- SWAP: censored MB/censored GB in use (10%)
- DISK: censored GB/censored GB in use (62%)
- Package versions:
   - libglib: 2.56.4-0ubuntu0.18.04.3

BOT INFORMATION
- Status: running (PIDs: 18681 18680, User: sinusbot)
- Webinterface: port locally reachable (Port: 8087)
- Binary: /opt/sinusbot/sinusbot
- Binary Info: MD5 Hash: 2472b206ad5fa41d71e2ce3923c8be80, Perms: 755, User: sinusbot
- Version: 1.0.0-beta.2-63286de
- TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: 59c9a688307aa73af9573029a7625fc5
   - TS3 Client: 59c9a688307aa73af9573029a7625fc5
- Config:
   - LogLevel = 10 (debug log active)
   - TS3Path = /opt/sinusbot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 (Version 3.2.5)
   - YoutubeDLPath = /opt/sinusbot/youtube-dl (does exist, version: 2019.06.08)
- Installed scripts: advertising.js; alonemode.js; AntiProxy.js; autoCodec.js; avatarbanner.js; badnickname.js; bookmark.js; come.js; command.js; followme.js; norecording.js; rememberChannel.js; saveCPU.js; theSimpliestSupport.js; unusedchanneldeleter.js; volumeKeeper.js; welcome.js; youtube.js; youtube-web.js

BOT TECHNICAL INFORMATION
- File exists:
   - TS3Client/libqxcb-glx-integration.so: no
- LDD output:
    linux-vdso.so.1 (0x00007ffe585aa000)
    libswresample.so.2 => /opt/sinusbot/libswresample.so.2 (0x00007f560903c000)
    libavfilter.so.6 => /opt/sinusbot/libavfilter.so.6 (0x00007f5608ce4000)
    libavformat.so.57 => /opt/sinusbot/libavformat.so.57 (0x00007f56088e3000)
    libavcodec.so.57 => /opt/sinusbot/libavcodec.so.57 (0x00007f5607f7e000)
    libavutil.so.55 => /opt/sinusbot/libavutil.so.55 (0x00007f5607d0a000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f5607b06000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f5607768000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f5607549000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f56071c0000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f5606fa8000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f5606bb7000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f560699a000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f5606792000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f5609256000)

REACHABILITY CHECKS
- HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
- HTTPS check with IPv6 mode: IGNORED [Disabled]
- DNS resolution check: SUCCESS [www.sinusbot.com resolved to 104.28.15.74]
- Update server checks:
    update01.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update02.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update03.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]

TIME INFORMATION
- Time (local): 20.06.2019 01:26:02 CEST +02:00:00
- Time (remote): 20.06.2019 01:26:02 CEST +02:00:00
- Time (difference): 0 secs (Time diff less than 2 secs. Good.)
- Timezone: Europe/Warsaw

OTHER INFORMATION
- TeamSpeak3 Version: 3.2.5
- youtube-dl Version: 2019.06.08
- DiagScript Version: 0.8.0
==========================================================
Code:
2019-06-20T01:20:16+02:00 TS |ERROR |Decode | |Stale Decoder detected, terminating it. Was ever active = 0
2019-06-20T01:20:16+02:00 TS |ERROR |Decode | |Stale Decoder detected, terminating it. Was ever active = 0
2019-06-20T01:20:16+02:00 TS |ERROR |Decode | |Stale Decoder detected, terminating it. Was ever active = 0
2019-06-20T01:20:16+02:00 TS |ERROR |Decode | |Stale Decoder detected, terminating it. Was ever active = 0
Console is basically filled with this error and bots are not responding to commands at all.
Running beta2 of sinusbot on ubuntu server 18.04 LTS x64
After restarting sinusbot it works good, but it will most likely come up again after a while.
 
Last edited:

Similar threads

Top