• TeamSpeak has reported a vulnerability in it's client that can potentially lead to RCE. A new version has been released that fixes it. So please update the client in your bot installation as soon as possible as well. Click here for more information.
  • If you need help or want to discuss things, you now can also join us on our Discord Server!

Bug !sub doesn't work unless after restart, !subchan on start

Status
Not open for further replies.

LukBoy99

Donor
is awesome!
!sub doesn't work most of the time and if I restart it works then it's bugged again, also !subchan would be nice to see enabled in bot channel by default as I could've just crontabbed restart sinusbot and that would've fixed the issue.
 

LukBoy99

Donor
is awesome!
UPDATE: I tried to look at the console when !sub wasn't working, by that time the console is actually dead, anythig I do doesn't appear even tho the bots are working and streaming in channels/playing youtube links/using scripts.
 

mxschmitt

Looking for another possibility to make sports.
Staff member
V.I.P.
is awesome!
Contributor
Insider
Check please, if !info is actually in working.
 

mxschmitt

Looking for another possibility to make sports.
Staff member
V.I.P.
is awesome!
Contributor
Insider
If the bot does not respond to anything of the chat, the bot has the deadlock bug. Thats a known bug, but we can detect what is wrong. The Logs can`t help us :/
 

LukBoy99

Donor
is awesome!
This is what I see interesting in logs
In bot log:
Code:
2016-07-16T14:42:24+03:00 Added EVListener
2016-07-16T14:03:27+03:00 Server seems broken or unreachable. Maybe ICY? Trying GET
2016-07-16T14:03:26+03:00 Server seems broken, doesn't understand us. Hopefully it's a stream...
2016-07-16T14:03:25+03:00 Server seems broken or unreachable. Maybe ICY? Trying GET
In instance log:
Code:
2016-07-16T14:42:42+03:00 Helium joined the channel
2016-07-16T14:03:53+03:00 Storing configuration.
2016-07-16T14:03:31+03:00 PRIVATE-CHAT [Helium] !subchan
2016-07-16T14:03:29+03:00 TS/ERR 2564 e'access to default group is forbidden' x'' r'PR:{164ab806-b4b7-4981-9e4a-922ca2492663}:14/GCLL'
2016-07-16T14:03:29+03:00 TS>invalid utf8 string send to logging
2016-07-16T14:03:29+03:00 PRIVATE-CHAT [GamersBase] [COLOR=#0000ff][✖] Welcome : [ TOP HITS BOT ] . [✖] Your first visit was in : [ 15.07.2016 11:20:55 ] . [✖] This the connection number : [ 8 ] . [✖] Your Server ID : [ 85FR97yzYNP7/MM+siuIJGzv++E= ] .[/COLOR] [COLOR=#FF0000]For activation and server groups click [url=http://gamersbase.co/en/]here[/url]. [url=http://gamersbase.co]اضغط هنا[/url] لتفعيل نفسك و التعديل على رتبك[/COLOR]
2016-07-16T14:03:29+03:00 TS |INFO |LicenseViewer | |Found cached license for version 1 and language en
2016-07-16T14:03:29+03:00 TS |INFO |LicenseViewer | |License language: en
2016-07-16T14:03:29+03:00 TS |INFO |Update | |Check license version: 1
2016-07-16T14:03:29+03:00 New connection status 4; Error 0
2016-07-16T14:03:29+03:00 TS |INFO |PermManager | |Loading permissions from cache
2016-07-16T14:03:29+03:00 TS |INFO |ClientUI |1 |Connect status: Connection established
2016-07-16T14:03:29+03:00 Zezo1 joined the channel
2016-07-16T14:03:29+03:00 Helium joined the channel
2016-07-16T14:03:29+03:00 New connection status 3; Error 0
2016-07-16T14:03:29+03:00 TS |INFO |ClientUI |1 |Connect status: Establishing connection
2016-07-16T14:03:29+03:00 New connection status 2; Error 0
2016-07-16T14:03:29+03:00 TS |INFO |ClientUI |1 |Connect status: Connected
2016-07-16T14:03:29+03:00 TS |INFO |Update | |Checking for updates...
2016-07-16T14:03:28+03:00 New connection status 1; Error 0
2016-07-16T14:03:28+03:00 TS |DEVELOP |PktHandler | |Puzzle solve time: 2
2016-07-16T14:03:28+03:00 TS |INFO |ClientUI | |Checking for update
2016-07-16T14:03:28+03:00 TS |INFO |ClientUI | |Last update check was: Sun Jan 1 00:00:01 2017
2016-07-16T14:03:28+03:00 TS |INFO |ClientUI |1 |Connect status: Connecting
2016-07-16T14:03:28+03:00 TS |INFO |PreProSpeex |1 |Speex version: 1.2rc1
2016-07-16T14:03:28+03:00 TS |INFO |ClientUI |1 |Initiating connection: 51.254.161.138:9987 51.254.161.138
2016-07-16T14:03:28+03:00 TS |INFO |ClientUI |1 |Blacklist check ok
2016-07-16T14:03:28+03:00 TS |INFO |ClientUI |1 |Connect to server: 51.254.161.138
2016-07-16T14:03:28+03:00 TS |INFO |ClientUI | |ts3server: 51.254.161.138?port=9987&nickname=TOP%20HITS%20BOT&password=&cid=24&channelpassword=
2016-07-16T14:03:28+03:00 TS |INFO |ClientUI | |Using configuration location: /home/sinusbot/data//ts3/20f0dd96-0caa-4470-bd45-6c4d17df2c93/3c6a1e3f-9ccd-8ae5-a874-91fa68057a2a/settings.db
2016-07-16T14:03:28+03:00 TS |INFO |ClientUI | |Qt version: 5.5.1
2016-07-16T14:03:28+03:00 TS |INFO |ClientUI | |Failed to init text to speech engine
2016-07-16T14:03:28+03:00 Could not send description command
2016-07-16T14:03:28+03:00 Error on call #5
2016-07-16T14:03:28+03:00 Could not send config.
2016-07-16T14:03:28+03:00 Could not send chat command
2016-07-16T14:03:27+03:00 TS |ERROR |Query | |bind failed on 127.0.0.1:25639
2016-07-16T14:03:27+03:00 TS |INFO | | |Loading plugin: libtest_plugin
2016-07-16T14:03:27+03:00 TS |INFO | | |Loading plugin: libsoundbot_plugin
2016-07-16T14:03:27+03:00 TS |INFO | | |Loading plugin: liblua_plugin
2016-07-16T14:03:27+03:00 TS |INFO | | |Loading plugin: libclientquery_plugin
2016-07-16T14:03:27+03:00 TS |ERROR |SoundBckndIntf| |/home/sinusbot/TeamSpeak3-Client-linux_amd64/soundbackends/libpulseaudio_linux_amd64.so error: INIT_PA_IMPL
2016-07-16T14:03:27+03:00 TS |ERROR |PulseAudio | |pa_context_connect failed
2016-07-16T14:03:27+03:00 TS |ERROR |PulseAudio | |failed to connect to pulse audio server
2016-07-16T14:03:27+03:00 New channel
2016-07-16T14:03:27+03:00 TS |INFO | | |Using hardware aes
2016-07-16T14:03:27+03:00 TS |INFO | | |SystemInformation: Linux 2.6.32-042stab115.2 #1 SMP Tue Apr 5 11:46:08 MSK 2016 x86_64 Binary: 64bit
2016-07-16T14:03:27+03:00 TS |INFO | | |TeamSpeak 3 Client 3.0.19.3 (2016-06-23 09:02:14)
2016-07-16T14:03:27+03:00 TS>DUMP defined! Dumpdir is: /home/sinusbot/data//ts3/20f0dd96-0caa-4470-bd45-6c4d17df2c93/3c6a1e3f-9ccd-8ae5-a874-91fa68057a2a/crashdumps
2016-07-16T14:03:27+03:00 TS>Crashdump ENABLED, directory is: /home/sinusbot/data//ts3/20f0dd96-0caa-4470-bd45-6c4d17df2c93/3c6a1e3f-9ccd-8ae5-a874-91fa68057a2a/crashdumps
2016-07-16T14:03:27+03:00 Starting instance ts3server://51.254.161.138?port=9987&nickname=TOP%20HITS%20BOT&password=&cid=24&channelpassword=
2016-07-16T14:03:27+03:00 Could not insert into Notifications-Tableno such table: Notifications
2016-07-16T14:03:27+03:00 Could not delete from Notificationsno such table: Notifications
2016-07-16T14:03:27+03:00 Could not insert into Notifications-Tableno such table: Notifications
2016-07-16T14:03:27+03:00 Could not delete from Notificationsno such table: Notifications
2016-07-16T14:03:27+03:00 Auto-Playing last track
2016-07-16T14:03:24+03:00 Last track was 6a783fa2-e538-4c21-a33f-20a32afd4e17, will auto-play soon
2016-07-16T14:03:24+03:00 Auto-Starting 20f0dd96-0caa-4470-bd45-6c4d17df2c93/3c6a1e3f-9ccd-8ae5-a874-91fa68057a2a in 3000 ms...
2016-07-16T14:03:24+03:00 Initialization complete
 

LukBoy99

Donor
is awesome!
this is output of Diagnostic script:

Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
 - Operating System: Ubuntu 14.04.4 LTS (OpenVZ)
 - OS x64 check: OK
 - Kernel: Linux 2.6.32-042stab115.2 x86_64
 - Load Average: 1.22 1.25 1.38
 - Uptime: 0 days, 20 hours, 47 minutes, 58 seconds
 - OS Updates: 0 (well done!)
 - OS Missing Packages: None (v1)
 - OS APT Last Update: 15.07.2016 21:13:27 EDT -04:00:00
 - Bot Start Script: not found
 - DNS resolution check: google.com -> OK
 - CPU:
    Architecture:          x86_64
    CPU(s):                8
    CPU MHz:               3990.917
    Virtualization:        VT-x
 - RAM:  B/2.00 GB in use (%)
 - SWAP:  B/ B in use (%)
 - DISK: 1.86 GB/4.13 GB in use (45%)
 - Package versions:
   > libglib: 2.40.2-0ubuntu1

BOT INFORMATION
 - Status: running (PIDs: 2055 2054, User: sinusbot)
 - Webinterface: port locally reachable (Port: 8087)
 - Binary: /home/sinusbot/sinusbot (Hash: 8b94daaaf3ffd829669e70a3c6a5843d)
 - Version: 0.9.12-58b509d
 - TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: 2c207af25e3000543d85b5f4275ef053
   - TS3 Client: 2c207af25e3000543d85b5f4275ef053
 - Config:
   - LogLevel = 10 (debug log active)
   - TS3Path = /home/sinusbot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 (Version 3.0.19.3)
   - YoutubeDLPath = /usr/local/bin/youtube-dl (does exist, version: 2016.07.13)
 - Installed scripts: README.md; advertising.js; aloneMode.js; badchan.js; bookmark.js; covatar.js; dev.js; digitalclock.js; followme.js; idle.js; metadata.js; norecording.js; rememberChannel.js; showcase.js; sound.js; welcometext.js; youtube; youtube.js; youtube_LICENSE

OTHER INFORMATION
 - Report date: 16.07.2016 07:50:51 EDT -04:00:00 (timezone: America/New_York)
 - TeamSpeak 3 Version: 3.0.19.3
 - youtube-dl Version: 2016.07.13
 - DiagScript version: 0.4.5
==========================================================
 

mxschmitt

Looking for another possibility to make sports.
Staff member
V.I.P.
is awesome!
Contributor
Insider
Thanks for the support, but the logs can´t help us. It is an internal problem, which just appear with the 3.0.19+++
The actual only solution, to solve that, is to downgrade to the 3.0.18.2 ;)
 

LukBoy99

Donor
is awesome!
Well it should be easy for you to find what you changed and exclude probabilities till you find what's causing it and change it? even if that means another pre-release before v1.0 as this is really a killer bug.
 

LukBoy99

Donor
is awesome!
Well it should be easy for you to find what you changed and exclude probabilities till you find what's causing it and change it? even if that means another pre-release before v1.0 as this is really a killer bug.
NVM i guess you mean teamspeak version, will do.
 
Status
Not open for further replies.

Similar threads

Top