• If you need help or want to discuss things, you now can also join us on our Discord Server!

Solved Unable to connect after TS3 Server update (outdated kernel!)

Status
Not open for further replies.
Hi,

My TS3 Server updates itself every 1 day each month. Yesterday my server did an update and since then i'm unable to start any instance. I already did an update via sinusbot-installer.de but it did not help. Can i just update the ts client of sinusbot?
Here is the Sinusbot log (just changed the password to XXXX):

Code:
2019-12-01T23:07:28-03:00 Storing configuration.
2019-12-01T23:07:15-03:00 closing channels
2019-12-01T23:07:15-03:00 eof from voice
2019-12-01T23:07:14-03:00 Closed.
2019-12-01T23:07:14-03:00 TS>terminating with uncaught exception of type boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::uuids::entropy_error> >: getrandom
2019-12-01T23:07:14-03:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019-12-01T23:07:14-03:00 TS>QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
2019-12-01T23:07:14-03:00 TS>QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-MuckeFukker'
2019-12-01T23:07:14-03:00 TS>qt.qpa.xkeyboard: no keyboard layouts with latin keys present
2019-12-01T23:07:14-03:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2019-12-01T23:07:14-03:00 TS>/opt/sinusbot/teamspeak3-client/ts3client_linux_amd64: /lib/x86_64-linux-gnu/libdbus-1.so.3: no version information available (required by /opt/sinusbot/teamspeak3-client/libQt5WebEngineCore.so.5)
2019-12-01T23:07:14-03:00 Starting instance ts3server://127.0.0.1?port=9987&nickname=%E2%99%ACMuckke%E2%99%AAMaster%E2%99%AB&password=XXXX&cid=11&channelpassword=
2019-12-01T23:07:14-03:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-12-01T23:07:14-03:00 Could not delete from FileTransferno such table: FileTransfer
2019-12-01T23:07:14-03:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-12-01T23:07:14-03:00 Could not delete from FileTransferno such table: FileTransfer
2019-12-01T23:07:14-03:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-12-01T23:07:14-03:00 Could not delete from FileTransferno such table: FileTransfer
2019-12-01T23:07:14-03:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-12-01T23:07:14-03:00 Could not delete from FileTransferno such table: FileTransfer
2019-12-01T23:07:14-03:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-12-01T23:07:14-03:00 Could not delete from FileTransferno such table: FileTransfer
2019-12-01T23:07:14-03:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2019-12-01T23:07:14-03:00 Could not delete from FileTransferno such table: FileTransfer
2019-12-01T23:07:14-03:00 Could not create Notifications-Tabletable Notifications already exists
2019-12-01T23:07:14-03:00 Could not create WhisperReceive-Tabletable WhisperReceive already exists
2019-12-01T23:07:14-03:00 Could not create Chat-Tabletable Chat already exists
2019-12-01T23:07:14-03:00 About to run.
2019-12-01T23:07:14-03:00 Prespawn.
And here is the diag script:

Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
 - Operating System: Debian GNU/Linux 8.11 (jessie)
 - Kernel: Linux 3.16.0-9-amd64 x86_64
 - Load Average: 1.07 0.89 0.79
 - Uptime: 74 days, 17 hours, 2 minutes, 35 seconds
 - OS x64 check: OK
 - OS Updates: 6 (updates available!)
 - OS Missing Packages: None
 - OS APT Last Update: 02.12.2019 03:05:06 CET +01:00:00
 - Shell Locale: (not set)
 - Bot Start Script: not found
 - CPU:
    Architecture:          x86_64
    CPU(s):                4
    Thread(s) per core:    1
    Core(s) per socket:    4
    Socket(s):             1
    Model name:            Intel(R) Xeon(R) CPU E5-2680 v4 @ 2.40GHz
    CPU MHz:               2397.222
    Hypervisor vendor:     KVM
    Virtualization type:   full
 - RAM: 5.83 GB/11.76 GB in use (49%)
 - SWAP: 65.80 MB/3.80 GB in use (1%)
 - DISK: 36.36 GB/55.17 GB in use (65%)
 - Package versions:
   - libglib: 2.42.1-1+deb8u32.42.1-1+deb8u3

BOT INFORMATION
 - Status: running (PIDs: 23697 23696, User: MuckeFukker)
 - Webinterface: port locally reachable (Port: 8087)
 - Binary: /opt/sinusbot/sinusbot
 - Binary Info: MD5 Hash: 2ee075d4cb2a3a640862b4eefa0fa6b1, Perms: 755, User: MuckeFukker
 - Version: 1.0.0-beta.5-b262b6a
 - TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: 2e771e4332cf87da1f72d58aa6923f9f
   - TS3 Client: 2e771e4332cf87da1f72d58aa6923f9f
 - Config:
   - LogLevel = 3
   - TS3Path = /opt/sinusbot/teamspeak3-client/ts3client_linux_amd64 (Version 3.3.2)
   - YoutubeDLPath = /usr/local/bin/youtube-dl
/usr/local/bin/youtube-dl (does not exist!)
 - Installed scripts: BetterAFK.js; Change_Channelcodec_And_Quality_Automaticly.js; Minecraft_Server_Info.js; NowPlaying.js; Random_GIFs.js; Sound on Join.js; WelcomeMessagePlus.js; YT-search.js; Youtube_Search.js; advertising.js; alonemode.js; away_mover.js; bookmark.js; come.js; command.js; defaultChannel+.js; followme.js; norecording.js; rankCSGO.js; rememberChannel.js; tunakills_ranking.js; welcome.js; welcomeSound.js; welcomeTTS.js; youtube.js

BOT TECHNICAL INFORMATION
 - File exists:
   - TS3Client/libqxcb-glx-integration.so: no
 - LDD output:
    linux-vdso.so.1 (0x00007ffdd0fb5000)
    libswresample.so.2 => /opt/sinusbot/libswresample.so.2 (0x00007f63bc420000)
    libavfilter.so.6 => /opt/sinusbot/libavfilter.so.6 (0x00007f63bc0c8000)
    libavformat.so.57 => /opt/sinusbot/libavformat.so.57 (0x00007f63bbcc7000)
    libavcodec.so.57 => /opt/sinusbot/libavcodec.so.57 (0x00007f63bb362000)
    libavutil.so.55 => /opt/sinusbot/libavutil.so.55 (0x00007f63bb0ee000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f63baeea000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f63babe9000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f63ba9cc000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f63ba6c1000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f63ba4ab000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f63ba100000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f63b9ee5000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f63b9cdd000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f63bc63a000)

REACHABILITY CHECKS
 - HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
 - HTTPS check with IPv6 mode: IGNORED [Disabled]
 - DNS resolution check: SUCCESS [www.sinusbot.com resolved to 104.28.15.74]
 - Update server checks:
    update01.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update02.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update03.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]

TIME INFORMATION
 - Time (local): 02.12.2019 03:11:46 CET +01:00:00
 - Time (remote): 02.12.2019 03:11:46 CET +01:00:00
 - Time (difference): 0 secs (Time diff less than 2 secs. Good.)
 - Timezone: Europe/Berlin

OTHER INFORMATION
 - TeamSpeak3 Version: 3.3.2
 - youtube-dl Version: unknown
 - DiagScript Version: 0.8.0
==========================================================
 
Sorry for the late reply i don't even know if it matters anyways. I had no time to do a full OS update until today and it is all working perfect. Thanks alot, next time i will check the requirements first ;)

edit: i have no idea how to mark this as solved
 
Status
Not open for further replies.

Similar threads

Top