• We would like to invite you to check out the latest 1.0 alpha versions. You can read more about what's new here. Please note, that this is still an early release and will contain new bugs ¯\_(ツ)_/¯
  • If you need help or want to discuss things, you now can also join us on our Discord Server!

Solved Youtube-DL Soundcloud not working

I have the same problem... using the youtube-dl out of sinusbot context, it works perfectly... but if i use ytdl inside sinusbot i get "no good format found" on ts3 chat or "no valid format found" on the platform
 

rtm516

Member
Just as extra info when you use it outside the bot context (standalone) it downloads as mp3 but I'm sure this format will work fine.
 

Dooley_labs

Donor++
is awesome!
is uber awesome!
Insider
Bumping this. Needs to be fixed at some point please. I've been unable to add music from my desired source for months.
 

Dooley_labs

Donor++
is awesome!
is uber awesome!
Insider
Actually should have already been fixed. Are you using the latest version of YT-DL and latest release of Sinusbot?
 

Dooley_labs

Donor++
is awesome!
is uber awesome!
Insider
Windows or Linux? Not possible to get the error with SoundCloud on Linux anymore unless it's a premium song. Just tested it again today without problems on Debian 9, latest Sinusbot release and Youtube-dl release from the official site.
 

Dooley_labs

Donor++
is awesome!
is uber awesome!
Insider
What about after refreshing the page? Added songs never appear until you refresh.
 

lemon

Member
!yt doesn't dowload the tracks, well, at least it doesn't store them permanently on the bot.

I've restarted the bot several times now after the update, but I restarted it once again now, and it works.. wtf?
 

Dooley_labs

Donor++
is awesome!
is uber awesome!
Insider
The command to store the song permanently is !ytdl. !yt only plays what it's told.
 

Similar threads

Top