1. The bot currently doesn't work with version 3.1 of the TS client. Please downgrade to an older version. Read this for more information on how to downgrade.

Beta for Windows 64bit

Discussion in 'Announcements' started by flyth, Jun 12, 2015.

Thread Status:
Not open for further replies.
  1. EwenJo

    EwenJo Member

    It's no longer available, I don't know why
     
  2. Darkstorm

    Darkstorm New Member

    i found out from chat lol @EwenJo
     
  3. MineMalox

    MineMalox Member

    Ich w├╝rde auch gerne beim Testen helfen nutze SinusBot schon seit Jahren und leider immer nur auf einem Linux Server
     
  4. QuinnG

    QuinnG Member

    I would like to participate.
     
  5. kanalumaddela

    kanalumaddela Insider Insider

  6. BigBoss

    BigBoss Member

    Can I have access to the beta on Windows please ?
     
  7. maxibanki

    maxibanki breaks more stuff Staff Member V.I.P. is awesome! Insider

    no, because the beta is already released :)
     
  8. 88s26

    88s26 New Member

    The windows beta doesn't work :L
    it hasn't worked for me at all the past 2 months since the last ts3 update :/
     
  9. flyth

    flyth breaks stuff Staff Member Developer

    Use a compatible teamspeak version, < 3.1. Then it will work just fine - as it does for hundreds of other people.
     
    • Agree Agree x 1
  10. Peskie

    Peskie Member

    It doesn't work fine!

    I have tried an older version of TeamSpeak with Sinusbot in windows and it doesn't work for me.

    Hundreds of other people who haven't responded are in similar situations or do not have access to older versions of TeamSpeak!
    By the way saying it works ok (or not) for hundreds of others is a poor response.
    I think people would rather you say that workaround may work and that you're working as fast as possible (hope you are) to issue a fix to this.
     
    • Dumb Dumb x 2
  11. kanalumaddela

    kanalumaddela Insider Insider

    • Agree Agree x 1
  12. flyth

    flyth breaks stuff Staff Member Developer

    I already answered to your "it doesn't work but I'm not gonna tell you more about it" posts a few times. There is exactly ONE reason why it wouldn't work with < 3.1 - and that would be if your server administrator forbids all client versions below 3.1. And since I don't know any reason why that should be the case (I'll gladly speed up development if there's ANY hint on the last versions of 3.0.x being more insecure or whatever than 3.1), I'm priorizing other issues / features.

    If that server side restriction is not the case for you, the error is most likely on your side. Again, I asked several times for reports / logs, but didn't get any usable responses besides "it does not work".

    Fact is, the bot is running just fine with 3.0.x on a proper Windows/TS installation. I'm running tests on clean Windows installations and I try to keep dependencies at a minimum so not many things will interfere with the installation (as everyone knows, most especially older Windows installations are pretty messed up when it comes to dependencies / libraries). And if it works for most people AND the few for whom it doesn't work don't provide more information, it's good enough for me to leave such a "poor response". I can't stress enough that this is not a multimillion company but a hobby project of a single person.

    But again, if you installed 3.1 at any time and want the bot to run on the same system, do the following:
    • Uninstall TS 3.1 and make sure it is removed completely
    • Remove the "TeamSpeak 3 Client" directory from your SinusBot installation (per default in C:\SinusBot) as well as the data\ts3 directory; better would be to even remove the C:\SinusBot directory completely.
    • Install TS < 3.1
    • Install the Bot
    • Verify the clients' version in C:\SinusBot\TeamSpeak 3 Client is correct
    One last thing especially for you, @Peskie: I specifically checked all your posts to make sure I didn't miss anything. The only thing I got from your older thread, is that you probably just didn't click the SinusBot logo in the tray (next to the clock) to open the bots' interface or messed up the config prior to start. There is not a single sign in your reports that your issue has got ANYTHING to do with the _client_ installation at all, as the bot would start in _any_ case (given you didn't mess up the config file). Run the bot from a command line to get more output on what's going on with it.
     
    • Winner Winner x 4
  13. Gatki

    Gatki Member

    Once you set a higher level of security in Identity, it works!

    @I wish I could install on a newer version. If it could work!
     
    Last edited: Apr 24, 2017
Thread Status:
Not open for further replies.

Share This Page