• TeamSpeak has reported a vulnerability in it's client that can potentially lead to RCE. A new version has been released that fixes it. So please update the client in your bot installation as soon as possible as well. Click here for more information.
  • If you need help or want to discuss things, you now can also join us on our Discord Server!

Docker: Bot doesn't connect to Server.

AndreasTgeDead

New Member
I use the official Docker build and my Problem is that the bot doesn't connect to my server. The bot and the TS server are on the Same root server but different Container. I don't want to have both in the same Container so I can restart the Bot or The server independent.

Does anybody have an Idea why it doesn't connect?
 
Was someone able to solve this issue? I run into the same error.
  1. Firewall is configured correctly.
  2. Bot has correct security level (25)
  3. Bot does not connect to server ip directly OR domain (which is behind cloudflare (DNS only))
  4. Bot and TeamSpeak are both in different docker containers.
  5. Bot can connect to other servers on different physical servers.
Thank you.
 

AndreasTgeDead

New Member
I did not get it until your comment. The Teamspeak-Server and the Sinusbot uses different dockers in the same network. Witch My Problem the Bot was working after i let the bot connect to the Teamspeak3 Server with the local IP of the Server.


so I looked the Container IP of the Teamspeak3 Server with the command
Code:
sudo docker inspect [DockerID]
As I then used the given IP (172.17.X.X) the Bot would connect to the server and everything works.


I hope this is understandable, if not, feel free to ask.
 

Similar threads

Top