• If you need help or want to discuss things, you now can also join us on our Discord Server!

Help to install SinusBot in CentOS

Natan_Gameron

New Member
I'm trying to install SinusBot on my CentOS 7, but it doesn't have the 3.17 kernel and the TS3 client doesn't work, I tried to install the 3.2.5 client and I couldn't, it always gives the error:
Code:
Found invalid playback device 'SinusBot', using default device 'ts3.pa.dummy.playbackdefault
Found invalid capture device 'SinusBot', using default device 'ts3.pa.dummy.capturedefault
Api version is not compatible for plugin: /opt/sinusbot/TeamSpeak3-Client-linux_amd64/plugins/libsoundbot_plugin.so
Could not request shutdown. Please make sure that the plugin is installed correctly; HTTP returned an error: Timeout; Code: 500; Message: Timeout
 

TwentyFour

BinusSot Junkie
V.I.P.
Contributor
Insider
- CentOS, not ideal for running SinusBot natively
- Kernel < 3.17, not possible for client >3.3.x
- Client 3.2.5, not working on servers >3.10.x
- Kernel version is not only depending from the OS, rather your virtualization, such as OpenVZ ... -> KVM gives you own control over your kernel

Long story short, only way to get it running would be using Docker, so you can prolly bypass the kernel requirement. (see @flyth post here)
Of course only if switching from CentOS is no option for you.
 

Natan_Gameron

New Member
I managed to install SinusBot version 1.0.0-beta.2, but when trying to connect the bot to my server, it gave the following error:

2020-03-21T16:28:13-03:00 tsclient quit.
2020-03-21T16:28:12-03:00 New connection status 0; Error 1797
2020-03-21T16:28:12-03:00 The bot could not connect. This might have several reasons: the server doesn't exist at that address, the server password is wrong, the default channel doesn't exist, the bot has been banned, the server is an illegal installation, the password is wrong, the security level of your identity is too low, the nickname is too short or too long or the server does not allow the version of the client you are using. See our Wiki / Forums for more help.


I tried to increase Identity, but it still remains the same error. My TS3 server is version 3.10.0
 

TwentyFour

BinusSot Junkie
V.I.P.
Contributor
Insider
I managed to install SinusBot version 1.0.0-beta.2, but when trying to connect the bot to my server, it gave the following error:

I tried to increase Identity, but it still remains the same error. My TS3 server is version 3.10.0
- Client 3.2.5, not working on servers >3.10.x
As I already told, it won't work, see changelog of the ts-server.
## Server Release 3.10.0 6 November 2019

### Important
- TeamSpeak Client 3.3.0 or later is needed to connect to this and upcoming server
releases.
 

Natan_Gameron

New Member
Is it possible to downgrade the TS3 server to some version compatible with SinusBOT v1.0.0-beta2?? I can only use CentOS 7, as my sites are hosted on it.
 

TwentyFour

BinusSot Junkie
V.I.P.
Contributor
Insider
Is it possible to downgrade the TS3 server to some version compatible with SinusBOT v1.0.0-beta2?? I can only use CentOS 7, as my sites are hosted on it.
If they was no change to the DB of the TS-server, maybe ... but most of the time downgrades don't work like that.
But you can try and error ... In any case you can use your current backup then again.

But for the long term, you really should get rid of that CentOS and switch to Debian or Ubuntu.
 

Similar threads

Top