• If you need help or want to discuss things, you now can also join us on our Discord Server!

Python process problem.

#1
hello,
I'm having problems for some time with this bot, simply, rarely, known that, you create numerous processes on my vps.
As you can see from the attached screenshot below.
when these processes are generated, the whole server starts to lag, the CPU reaches 100% and if I dont close the bot and the python processes quickly, the whole machine crashes and restarts.
I noticed that this happens when, sometimes, when I try to start a song from a playlist, at the top it shows "Error: Could not playback the selected file / stream." usually then restarting the bot the problem is solved, on the log it is not null apart from the command terminated as NOK.
however I do normal use of the bot, not the effort ever since only I have the powers to use it.
I am aware that my vps is weak, has 1gb ram and 1vcore, and it is vmware, but when everything works quietly, the ram is occupied for 40% and cpu never exceeds 15%.
the o.s. is debian 8, and I've always kept both the sinusbot and the client I'm using at the latest version, but this problem has been dealt with by several versions..
 

Attachments

Multivitamin

V.I.P.
V.I.P.
is awesome!
is uber awesome!
Contributor
Insider
Tier III
#3
youtube-dl uses python

Got those problems aswell when it just starts rapidly switching songs without even starting to play one when using youtube playlists
Restarting the Sinusbot resolved the problem for me back then
 
#4
youtube-dl uses python

Got those problems aswell when it just starts rapidly switching songs without even starting to play one when using youtube playlists
Restarting the Sinusbot resolved the problem for me back then
I have this problem for several months, every time I have this problem I restart the bot, but it always remained, in any case, on purpose to avoid problems change song calmly without stressing the bot, but the problem remains the same
 

Similar threads