• If you need help or want to discuss things, you now can also join us on our Discord Server!

SinusBot connectet nicht auf meinen Server

Hallo Leute,
ich installiere eigentlich nicht zum ersten mal einen Sinusbot. Doch jetzt habe ich das Problem, dass der Bot einfach nicht auf den Teamspeak connecten möchte.
Das Loglvl habe ich schon auf 10 geändert.

Irgendwie findet er die libpulse.so.0: cannot open shared object file: No such file or directory
Aber wie bekomme ich das behoben?

Außerdem hat er irgendein cache Problem. |ERROR |RevocationListCache| |Failed to import revocation list from cache

Naja vielleicht hat ja jemand eine Idee, wie er mir helfen kann.
Danke

2021-03-29T17:33:16+02:00 closing channels
2021-03-29T17:33:15+02:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2021-03-29T17:33:15+02:00 Closed.
2021-03-29T17:33:15+02:00 TS>libpng warning: iCCP: known incorrect sRGB profile
2021-03-29T17:33:15+02:00 TS>QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
2021-03-29T17:33:15+02:00 TS>QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
2021-03-29T17:33:15+02:00 TS>QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-admin'
2021-03-29T17:33:15+02:00 TS>qt.qpa.xkeyboard: no keyboard layouts with latin keys present
2021-03-29T17:33:15+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2021-03-29T17:33:14+02:00 TS |INFO | | |Statistics report: Not yet, next report on Fri Apr 2 10:37:26 2021
2021-03-29T17:33:14+02:00 TS |INFO |ClientUI | |Last update check was: Sat Jan 1 00:00:01 2022
2021-03-29T17:33:14+02:00 TS |INFO |Bookmarks | |Collecting autoconnect bookmarks
2021-03-29T17:33:14+02:00 New connection status 0; Error 0
2021-03-29T17:33:14+02:00 The bot could not connect. This might have several reasons: the server doesn't exist at that address, the server password is wrong, the default channel doesn't exist, the bot has been banned, the server is an illegal installation, the password is wrong, the security level of your identity is too low, the nickname is too short or too long or the server does not allow the version of the client you are using. See our Wiki / Forums for more help.
2021-03-29T17:33:14+02:00 TS |INFO |ClientUI |1 |Disconnected or forced to leave, want autoreconnect = 0
2021-03-29T17:33:14+02:00 TS |INFO |ClientUI |1 |Connect status: Disconnected
2021-03-29T17:33:14+02:00 TS/ERR 1280 e'database error' x'' r''
2021-03-29T17:33:14+02:00 New connection status 1; Error 0
2021-03-29T17:33:14+02:00 TS |DEVELOP |PktHandler |1 |Puzzle solve time: 2
2021-03-29T17:33:14+02:00 TS |INFO |ClientUI |1 |Connect status: Connecting
2021-03-29T17:33:14+02:00 TS |INFO |ClientUI |1 |Initiating connection: 157.90.185.70:9988
2021-03-29T17:33:14+02:00 TS |INFO |ClientUI |1 |Connect to server: 157.90.185.70
2021-03-29T17:33:14+02:00 TS |INFO |ClientUI | |ts3server: 157.90.185.70?port=9988&nickname=Sn4pbot&password=&channel=&channelpassword=
2021-03-29T17:33:14+02:00 TS |INFO | | |successfully downloaded revocation list for myteamspeak id
2021-03-29T17:33:14+02:00 TS |INFO |ClientUI | |Using configuration location: /opt/sinusbot/data/ts3/ef3d767d-9065-4c0c-9802-5a754c9de621/4bba1fc8-514d-44aa-99b1-e8e1b3b96996/settings.db
2021-03-29T17:33:14+02:00 TS |INFO |ClientUI | |Qt version: 5.12.1
2021-03-29T17:33:14+02:00 TS |INFO |ClientUI | |Failed to init text to speech engine
2021-03-29T17:33:14+02:00 TS |INFO | | |*** Time [INIT]: 159
2021-03-29T17:33:14+02:00 TS |INFO | | |*** Time [MAINWINDOW]: 158
2021-03-29T17:33:14+02:00 TS>ClientQueryPlugin: currentServerConnectionChanged 1 (0)
2021-03-29T17:33:14+02:00 TS |INFO | | |successfully downloaded revocation list for accounting
2021-03-29T17:33:14+02:00 TS |INFO |Query | |listening on 127.0.0.1:25639
2021-03-29T17:33:14+02:00 TS |INFO |Plugins | |Loading plugin: libclientquery_plugin_linux_amd64.so
2021-03-29T17:33:14+02:00 TS |INFO |Plugins | |Loading plugin: libsoundbot_plugin.so
2021-03-29T17:33:14+02:00 TS |INFO |Addons | |Checking for addon updates...
2021-03-29T17:33:14+02:00 TS |ERROR |RevocationListCache| |Failed to import revocation list from cache
2021-03-29T17:33:14+02:00 TS |INFO |ClientUI | |Unable to create an Open GL context.
2021-03-29T17:33:14+02:00 TS |ERROR |SoundBckndIntf| |libpulse.so.0: cannot open shared object file: No such file or directory
2021-03-29T17:33:14+02:00 TS |INFO | | |Using hardware aes
2021-03-29T17:33:14+02:00 TS |INFO | | |SystemInformation: Linux 4.19.0-5-amd64 #1 SMP Debian 4.19.37-5+deb10u2 (2019-08-08) x86_64 Binary: 64bit
2021-03-29T17:33:14+02:00 TS |INFO | | |TeamSpeak Client 3.5.3 (2020-05-06 09:07:50)
2021-03-29T17:33:14+02:00 TS>DUMP defined! Dumpdir is: /opt/sinusbot/data/ts3/ef3d767d-9065-4c0c-9802-5a754c9de621/4bba1fc8-514d-44aa-99b1-e8e1b3b96996/crashdumps
2021-03-29T17:33:14+02:00 TS>Crashdump ENABLED, directory is: /opt/sinusbot/data/ts3/ef3d767d-9065-4c0c-9802-5a754c9de621/4bba1fc8-514d-44aa-99b1-e8e1b3b96996/crashdumps
2021-03-29T17:33:14+02:00 Starting instance ts3server://157.90.185.70?port=9988&nickname=Sn4pbot&password=&channel=&channelpassword=
2021-03-29T17:33:14+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2021-03-29T17:33:14+02:00 Could not delete from FileTransferno such table: FileTransfer
2021-03-29T17:33:14+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2021-03-29T17:33:14+02:00 Could not delete from FileTransferno such table: FileTransfer
2021-03-29T17:33:14+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2021-03-29T17:33:14+02:00 Could not delete from FileTransferno such table: FileTransfer
2021-03-29T17:33:14+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2021-03-29T17:33:14+02:00 Could not delete from FileTransferno such table: FileTransfer
2021-03-29T17:33:14+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2021-03-29T17:33:14+02:00 Could not delete from FileTransferno such table: FileTransfer
2021-03-29T17:33:14+02:00 Could not insert into FileTransfer-Tableno such table: FileTransfer
2021-03-29T17:33:14+02:00 Could not delete from FileTransferno such table: FileTransfer
2021-03-29T17:33:14+02:00 Could not create Notifications-Tabletable Notifications already exists
2021-03-29T17:33:14+02:00 Could not create WhisperReceive-Tabletable WhisperReceive already exists
2021-03-29T17:33:14+02:00 Could not create Chat-Tabletable Chat already exists
2021-03-29T17:33:14+02:00 About to run.
2021-03-29T17:33:14+02:00 Prespawn.
Und hier der Auszug aus dem Fehlerscript:

==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
- Operating System: Debian GNU/Linux 10 (buster)
- Kernel: Linux 4.19.0-5-amd64 x86_64
- Load Average: 0.23 0.10 0.03
- Uptime: 0 days, 5 hours, 3 minutes, 30 seconds
- OS x64 check: OK
- OS Updates: 2 (updates available!)
- OS Missing Packages: None
- OS APT Last Update: 29.03.2021 06:47:48 EDT -04:00:00
- Shell Locale: en_US.UTF-8
- Bot Start Script: not found
- CPU:
Architecture: x86_64
CPU(s): 2
Thread(s) per core: 1
Core(s) per socket: 2
Socket(s): 1
Model name: AMD EPYC Processor (with IBPB)
CPU MHz: 2495.312
Hypervisor vendor: KVM
Virtualization type: full
- RAM: 539.65 MB/3.85 GB in use (13%)
- SWAP: 0 B/3.99 GB in use (0%)
- DISK: 3.09 GB/45.26 GB in use (6%)
- Package versions:
- libglib: 2.58.3-2+deb10u2

BOT INFORMATION
- Status: running (PIDs: 6458 6457, User: admin)
- Webinterface: port locally reachable (Port: 8087)
- Binary: /opt/sinusbot/sinusbot
- Binary Info: MD5 Hash: 224b687db910b732fe5a7cfec4f6c78e, Perms: 755, User: admin
- Version: 1.0.0-beta.10-202ee4d
- TS3 Plugin: installed (md5 hash match)
- Bot Plugin: aa483aea105cb62033392b1ce6d317ab
- TS3 Client: aa483aea105cb62033392b1ce6d317ab
- Config:
- LogLevel = 10 (debug log active)
- TS3Path = /opt/sinusbot/teamspeak3-client/ts3client_linux_amd64 (Version 3.5.3)
- YoutubeDLPath = /usr/local/bin/youtube-dl (does exist, version: 2021.03.25)
- Installed scripts: advertising.js; alonemode.js; bookmark.js; command.js; followme.js; norecording.js; rememberChannel.js; sinusbot-commands.js; welcome.js

BOT TECHNICAL INFORMATION
- File exists:
- TS3Client/libqxcb-glx-integration.so: no
- LDD output:
linux-vdso.so.1 (0x00007ffc31bd9000)
libswresample.so.2 => /opt/sinusbot/libswresample.so.2 (0x00007f4e52e5a000)
libavfilter.so.6 => /opt/sinusbot/libavfilter.so.6 (0x00007f4e52b02000)
libavformat.so.57 => /opt/sinusbot/libavformat.so.57 (0x00007f4e52701000)
libavcodec.so.57 => /opt/sinusbot/libavcodec.so.57 (0x00007f4e51d9c000)
libavutil.so.55 => /opt/sinusbot/libavutil.so.55 (0x00007f4e51b28000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f4e51b1c000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f4e51997000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f4e51976000)
libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f4e517f2000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f4e517d8000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f4e51617000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f4e513f9000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f4e513ed000)
/lib64/ld-linux-x86-64.so.2 (0x00007f4e53076000)

REACHABILITY CHECKS
- HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
- HTTPS check with IPv6 mode: IGNORED [Disabled]
- DNS resolution check: SUCCESS [www.sinusbot.com resolved to 104.21.13.58]
- Update server checks:
update01.sinusbot.com -> 104.21.13.58: SUCCESS [CODE #404]
update02.sinusbot.com -> 172.67.132.160: SUCCESS [CODE #404]
update03.sinusbot.com -> 104.21.13.58: SUCCESS [CODE #404]

TIME INFORMATION
- Time (local): 29.03.2021 12:07:22 EDT -04:00:00
- Time (remote): 29.03.2021 12:07:22 EDT -04:00:00
- Time (difference): 0 secs (Time diff less than 2 secs. Good.)
- Timezone: America/New_York

OTHER INFORMATION
- TeamSpeak3 Version: 3.5.3
- youtube-dl Version: 2021.03.25
- DiagScript Version: 0.8.0
==========================================================
 
Last edited:

MauriceR

Donor
is awesome!
Contributor
2021-03-29T17:33:14+02:00 The bot could not connect. This might have several reasons: the server doesn't exist at that address, the server password is wrong, the default channel doesn't exist, the bot has been banned, the server is an illegal installation, the password is wrong, the security level of your identity is too low, the nickname is too short or too long or the server does not allow the version of the client you are using. See our Wiki / Forums for more help.
Die ganzen Fehler sollten soweit ich weiß irrelevant sein. Jedoch ist die Fehlermeldung die ich zitiert habe meistens der Grund.
Guck Mal ob die Identität des Sinusbot das entsprechende Sicherheitslevel, welches der Server vorgibt hat. Ansonsten müsstest du dies erhöhen.
 
Danke erstmal für deine Rückmeldung. Dies war auch meine Vermutung, daher habe ich das Sicherhitslvl bereits erhöht. Der Server verlangt Stufe 8 und meine Instanz hat 22, wie auch auf dem Screenshot zu erkennen.
 

Attachments

  • für sinusforum.jpg
    für sinusforum.jpg
    58 KB · Views: 7

flyth

is reticulating splines
Staff member
Developer
Contributor
2021-03-29T17:33:14+02:00 TS/ERR 1280 e'database error' x'' r''

Lösch mal bitte den data/ts3-Ordner und versuch's dann nochmal. Das sieht nach 'ner kaputten Client-Datenbank aus (vermutlich ausgelöst durch einen Crash des Clients/Servers).
 
Hab ich gemacht. /opt/sinusbot/data/ts3
nun geht der Bot irgendwie auf grün, aber auf dem Server ist er dennoch nicht xD
Oder hab ich was falsches gelöscht?
 

MauriceR

Donor
is awesome!
Contributor
Nene, sollte der richtige Ordner gewesen sein. Sende bitte nochmal die Log's rein. Vielleicht kann man jetzt was neues finden
 
Irgendwie ist der Wurm drin.
Habe den Rootserver neugestartet. Nun startet der Bot gar nicht mehr.
Wenn ich das Installerscript nutze kommet folgende Meldung:
W: GPG error: https://packages.sury.org/php buster InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743
E: The repository 'https://packages.sury.org/php buster InRelease' is not signed.
Command which failed was: " apt-get update". Please try to execute it manually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script. Line 263.

Bin irgendwie ratlos.
 

MauriceR

Donor
is awesome!
Contributor
Irgendwie ist der Wurm drin.
Habe den Rootserver neugestartet. Nun startet der Bot gar nicht mehr.
Wenn ich das Installerscript nutze kommet folgende Meldung:


Bin irgendwie ratlos.
Habe Online folgendes als Lösung gefunden:
Code:
apt-get install apt-transport-https lsb-release ca-certificates
wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
Diese 2 Befehle mal ausführen und erneut probieren
 
Habe ihn ohne deine Hilfe wieder zum laufen bekommen.

jetzt ist der ts3 ordner wieder da und Log ist dieser:

2021-03-29T23:01:17+02:00 closing channels
2021-03-29T23:01:16+02:00 TSClient quit.
2021-03-29T23:01:16+02:00 Closed.
2021-03-29T23:01:16+02:00 TS>libpng warning: iCCP: known incorrect sRGB profile
2021-03-29T23:01:16+02:00 TS>QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
2021-03-29T23:01:16+02:00 TS>QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
2021-03-29T23:01:16+02:00 TS>QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-admin'
2021-03-29T23:01:16+02:00 TS>qt.qpa.xkeyboard: no keyboard layouts with latin keys present
2021-03-29T23:01:16+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2021-03-29T23:01:15+02:00 TS |INFO | | |Statistics report: Setting next report date to: Wed Apr 14 17:01:15 2021
2021-03-29T23:01:15+02:00 TS |INFO | | |Statistics report: First run, report later in 1-30 days
2021-03-29T23:01:15+02:00 TS |INFO |ClientUI | |Last update check was: Sat Jan 1 00:00:01 2022
2021-03-29T23:01:15+02:00 TS |INFO |Bookmarks | |Collecting autoconnect bookmarks
2021-03-29T23:01:15+02:00 New connection status 0; Error 0
2021-03-29T23:01:15+02:00 The bot could not connect. This might have several reasons: the server doesn't exist at that address, the server password is wrong, the default channel doesn't exist, the bot has been banned, the server is an illegal installation, the password is wrong, the security level of your identity is too low, the nickname is too short or too long or the server does not allow the version of the client you are using. See our Wiki / Forums for more help.
2021-03-29T23:01:15+02:00 TS |INFO |ClientUI |1 |Disconnected or forced to leave, want autoreconnect = 0
2021-03-29T23:01:15+02:00 TS/ERR 1280 e'database error' x'' r''
2021-03-29T23:01:15+02:00 TS |INFO |ClientUI |1 |Connect status: Disconnected
2021-03-29T23:01:15+02:00 New connection status 1; Error 0
2021-03-29T23:01:15+02:00 TS |DEVELOP |PktHandler |1 |Puzzle solve time: 2
2021-03-29T23:01:15+02:00 TS |INFO |ClientUI |1 |Connect status: Connecting
2021-03-29T23:01:15+02:00 TS |INFO |ClientUI |1 |Initiating connection: 157.90.185.70:9987
2021-03-29T23:01:15+02:00 TS |INFO |ClientUI |1 |Connect to server: 157.90.185.70
2021-03-29T23:01:15+02:00 TS |INFO |ClientUI | |ts3server: 157.90.185.70?port=9987&nickname=Sn4pbot&password=&channel=&channelpassword=

Jetzt ohne den ts3 Ordner folgender Log:

2021-03-29T23:10:07+02:00 Starting instance ts3server://157.90.185.70?port=9987&nickname=Sn4pbot&password=&channel=&channelpassword=
2021-03-29T23:10:07+02:00 About to run.
2021-03-29T23:10:07+02:00 Prespawn.
2021-03-29T23:09:53+02:00 Storing configuration.
2021-03-29T23:09:42+02:00 closing channels
2021-03-29T23:09:41+02:00 TSClient quit.
2021-03-29T23:09:41+02:00 Closed.
2021-03-29T23:09:41+02:00 TS>QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
2021-03-29T23:09:41+02:00 TS>QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-admin'
2021-03-29T23:09:41+02:00 TS>qt.qpa.xkeyboard: no keyboard layouts with latin keys present
2021-03-29T23:09:41+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2021-03-29T23:09:41+02:00 KILL [admin] OK
2021-03-29T23:09:40+02:00 Could not request shutdown. Please make sure that the plugin is installed correctly; HTTP returned an error: Timeout; Code: 500; Message: Timeout
2021-03-29T23:08:53+02:00 Storing configuration.
2021-03-29T23:08:47+02:00 Starting instance ts3server://157.90.185.70?port=9987&nickname=Sn4pbot&password=&channel=&channelpassword=
2021-03-29T23:08:47+02:00 About to run.
2021-03-29T23:08:47+02:00 Prespawn.
2021-03-29T23:07:53+02:00 Storing configuration.
2021-03-29T23:07:45+02:00 closing channels
2021-03-29T23:07:44+02:00 TSClient quit.
2021-03-29T23:07:44+02:00 Closed.
2021-03-29T23:07:44+02:00 TS>libpng warning: iCCP: known incorrect sRGB profile
2021-03-29T23:07:44+02:00 TS>QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
2021-03-29T23:07:44+02:00 TS>QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
2021-03-29T23:07:44+02:00 TS>QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-admin'
2021-03-29T23:07:44+02:00 TS>qt.qpa.xkeyboard: no keyboard layouts with latin keys present
2021-03-29T23:07:44+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
 
Noch mal ein großes Dankeschön für die schnelle Hilfe gestern!.
Das Argument mit dem defekten Datenbankfehler hat mir keine Ruhe gelassen. Tatsächlich konnten neue Benutzer meinem Teamspeak nicht joinen. Nur die alten Identitäten die bereits drauf waren.
Habe nun den Server komplett neu gemacht und siehe da, nun funktioniert auch wieder der Sinusbot.
 

Similar threads

Top