• If you need help or want to discuss things, you now can also join us on our Discord Server!
  • Due to the current COVID-19 situation, we are giving out free extended private licenses for a couple of days to assist you in getting more friends to #stayhome and enjoy some music listening with you. You can read more about it here.

Sinusbot version compatible with TS 3.1.x - Windows, cannot update TS client, any solution?

Aldoxisonfire

New Member
The teamspeak server we connect to is old. So if we update the TS3 client we can't join the server. We can use up to 3.1.9 to join. I had sinusbot working but now it does not support a TS3 client of 3.1.x

Any solutions?

Is there a Sinusbot older version or can I downgrade?

Please help me

Thanks
 

Multivitamin

Well-Known Member
Tier III
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
The only real solution is to update the TeamSpeak Server, thats the only supported solution to this issue
 

Aldoxisonfire

New Member
Ok you mention real solution

Is there a fix instead? something that is not that good of a solution but could probably make it work?
 

TwentyFour

Well-Known Member
V.I.P.
First of all, do I want to know the reason, you're not using a recent TS-server version? :rolleyes:

Real solution = we can help you with that.

If you want to downgrade, you have to do it on your own. In the History section under Ressources there are older SinusBot versions, with all their bugs and stuff.
It has a reason those versions are outdated.
If you make your bot run with older versions, thats good, but we can't help you with old (sort of bad) versions.

Example: People still use Windows 7, it can work, but I would never recommend it, nor help someone with a problem there, from which I know, it is solved by upgrading.
 

Aldoxisonfire

New Member
"First of all, do I want to know the reason, you're not using a recent TS-server version? "

I just told you on my first post. But let me extend a bit... most of the people that play the game I do connect to and old server. So I had to open an old server myself if not no one would join mine (because they use TS 3.1.x). I cannot force all people to update because they want to connect to the main old server, and the owner of that won't update it.

I can't find older sinusbot versions tbh, not even in the Resources section. Maybe I am doing something wrong.

And yes I know software is outdated for a reason, but you must understand not everyone can have it updated because cases like this and probably many others cases...
 

Multivitamin

Well-Known Member
Tier III
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
You still did not provide a valid reason why you did not update... The excuse you gave is just simple lazyness nothing else, sorry thats why we cant help you with that!
 

Aldoxisonfire

New Member
Dear god

Is not my lazyness

I have downloaded TS many times and updating it takes just 5min. So is not like I don't wanna do something

I play an MMORPG and provide a server for many people that play such an MMORPG. But for that game my server is not the most used.

Most of the people, if not all. Join a server that is owned by someone else that is NOT ME. Such person, lets call him "Brian" is one of the most known persons in that game and is the leader of a clan. He is not my friend or anything. He has this server that is the most used and he won't update it because many configurations he has applied to the TS will be lost when updating etc... well that is his own will, that is Brians will, I can't fix that, that is not lazyness

Since most of the people join Brian server but also wanna use other servers such as MINE, they have to use TS 3.1.x because of it. So I can't update my server or else no one would join because they won't update TS because that would mean they can't join Brians server (which I explained is the most populated, used and important server of that MMORPG game)

Idk if I explained myself this time
 

Multivitamin

Well-Known Member
Tier III
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
Since the older TeamSpeak Client Version uses a different TeamSpeak API Version it would be required to support multiple seperated branches of Sinusbot (thats a reason why there is no 32 bit version) only a very small % of people (probably < 0.5%) would benefit of work which gets put into that.

He has this server that is the most used and he won't update it because many configurations he has applied to the TS will be lost when updating etc...
No TeamSpeak Server in the last 6 years which I am able to remember has any update issues, so the owner is just lazy.
Tbh its just a lazy excuse to run Sinusbot on outdated Server which used some cracked TeamSpeak Server Version, thats currently the only REAL reason why people dont update and we dont support this in anyway!
 

Aldoxisonfire

New Member
Well

I just need to adapt to the situation I lay out to you

I don't know if he uses cracks or bots, or whatever reason

What I know is that since all people use that server I have to use one that is also old

That is my situation and I try to have my own server and keep playing that game because we are a community and I have my friends that like my server because it is more private and friendly

But anyway, if you can't or don't want to help me that is fine. I have been using sinusbot for 1 year and now it seems useless for me now

Thank you for all the replies
 

TwentyFour

Well-Known Member
V.I.P.
But anyway, if you can't or don't want to help me that is fine. I have been using sinusbot for 1 year and now it seems useless for me now
If you re-read our replies, you would see, that we tried to help, which means we want to help (else I guess no one would bother replying), but there is just no technical way to make your wish come true. Let me give you an example.

If I want to play Pinball 3D, I need to run Win XP. If the other games I play won't run on XP, I have many options:
- Have Win 10 -> stop playing Pinball
- Have Win XP -> stop playing newer games
- Have two PCs -> play both
- Have a VM on Win 10 -> play Pinball in the VM
- ...

These are all solutions, all with different pros and cons. Only you can decide the one suitable for your needs.
Just one thing is safe, there is no "easy" option of having both in the same OS on the same machine.

In my opinion you are too obsessed getting the one solution you want. For example, you never even asked if there is a simple way to use both clients at the same time without updating and downgrading. So you could join "Brian's" old server, and have your new version server at the same time.

Feel free to try out old SinusBot versions here & here, but you have to live and deal with their bugs, old scripting engine, etc...
 

Aldoxisonfire

New Member
I am not obsessed

If you re-read my posts you will see my second post asks if there is a fix

Which is pretty much asking if there is any posible solution to fix the problem lol

Those are Linux versions, the thread explicitly mentions Windows

Anyway the old Windows version that works for Ts 3.1.x can't run it says it has expired, so no use on that

I will keep trying to find a solution, either with Sinusbot or not. Since the community likes to listen to music while we all play

Thank you

PD: Btw the bot works pretty well when everything is updated I know, thanks for it. The problem is that I can't have it updated for the reasons I told you. That I can't change and I need to adapt and fix it however I can :)
 
Last edited:

Similar threads

Top