• If you need help or want to discuss things, you now can also join us on our Discord Server!

Sinusbots teamspeak not opening

Erkan53

New Member
Sinusbot works fine but whenever i activate the bot teamspeak doesnt show up even in the right bottom corner tried to reinstall this so many times but this works perfectly fine on my personal computer it doesnt work owindows server 2012 r2 if there is anything i need to install like java or something like that please send me the links so i can make the bot work on my windows server
 

Erkan53

New Member
There is nothing in the faqs
Also i searched alot for this problem couldnt find it

i have the sinusbots latest version
İ have the teamspeaks 3.1.10 version (befıre you say this is the problem this version works perfectly fine on my own pc)
İ copied the sinusbot folder in my pc and uploaded it to my windows server
And on my windows server i open my sinusbot then start my bot there is nothing on the screen on right bottom corner no teamspeak icons but on task managers processes tabs there is teamspeak client i tried to close that teamspeak client and tried to start the bot but this time no teamspeak was opened i even tried to reboot the server
 

TwentyFour

Well-Known Member
V.I.P.
i have the sinusbots latest version
There is no "latest version". That's just a lazy form of expressing "I think I am up-to-date".
In your bot's backend, go to Settings -> Info -> About and copy your full version (e.g. 1.0.0-beta.10-202ee4d)
İ have the teamspeaks 3.1.10 version (befıre you say this is the problem this version works perfectly fine on my own pc)
Despite the fact this outdated client-version might work in one setup, it does not automatically mean, that it is working in another setup. Especially when the point of time of the installation is different.
We can't provide support for old versions, so follow the FAQs and install the versions linked there, including a recent ts-client.
As of today, this means Bot-version 1.0.0-beta.10 and TS-client 3.3.2.
İ copied the sinusbot folder in my pc and uploaded it to my windows server
Installing a programm via an installer IS NOT the same as simply copying over its files.
 

Erkan53

New Member
There is no "latest version". That's just a lazy form of expressing "I think I am up-to-date".
In your bot's backend, go to Settings -> Info -> About and copy your full version (e.g. 1.0.0-beta.10-202ee4d)

Despite the fact this outdated client-version might work in one setup, it does not automatically mean, that it is working in another setup. Especially when the point of time of the installation is different.
We can't provide support for old versions, so follow the FAQs and install the versions linked there, including a recent ts-client.
As of today, this means Bot-version 1.0.0-beta.10 and TS-client 3.3.2.

Installing a programm via an installer IS NOT the same as simply copying over its files.
i did install the program via the sinusbot installer i tried that too i even tried to use an installer that was meant for teamspeak 3.1 i thought that would fix the problem im gonna tryit one more time

edit:

1.0.0-alpha.5-9767656
sinusbot version
edit: i have managed to work it on the server but now the problem is http://prntscr.com/r07uj2

and also the version im using on the server is
SinusBot 1.0.0-beta.10-202ee4d
 
Last edited:

TwentyFour

Well-Known Member
V.I.P.
the teamspeak version is 3.0.13.8 so i guess this is not possible.
This version is over 30 months old! Holy quakamoly! 🤯
Why would you use such?

The SinusBot needs a respective TS-client version, which can be found here.
You can't use a new bot with an old ts-client version, neither vice versa. Anyways you should be only using a recent version.

Go with the suggested installation route, otherwise you can't be helped.
 

Erkan53

New Member
well you see im playing a game which alot of players use this teamspeak server version and there is no way to make all of these server use the latest teamspeak server version unless teamspeak makes an update where you can only use the latest versions
 

TwentyFour

Well-Known Member
V.I.P.
Don't mix up TeamSpeak server and client versions.
There are some dependencies between server and client versions: (e.g.)

- Client version 3.2.0 dropped support for TS-servers pre 3.1.0
- Client version 3.3.x is needed for SinusBot.beta10.

This means:
Server 3.0.13.8 won't work with Client 3.3.x, which is needed for SinusBot.beta10.

So in some way TeamSpeak "is making you" to use latest server version. In my experience, there are just two reasons people do not update:
- pure laziness
- cracked servers
 

Erkan53

New Member
more like cheap servers? they are really cheap 512 users for 5 dollars and 32 users on new version for 4 dollars
 

TwentyFour

Well-Known Member
V.I.P.
more like cheap servers? they are really cheap 512 users for 5 dollars and 32 users on new version for 4 dollars
C'mon, don't be gullible.
No genuine hoster or reseller would even think about selling outdated versions. Those are all from illegal instances!

Since you got a VPS, install your own TeamSpeak server? Cost: 0$ for 32 slots
You're a gaming community? Get a sponsored license... Cost: 0$ for 512 slots

And since we're getting off-topic:
Upgrade your server, otherwise there is no supported way to run SinusBot.
 

Erkan53

New Member
32 wouldnt be enough 128 is needed and i dont think they would give me a sponsored license for just one game server
 

Similar threads

Top