• If you need help or want to discuss things, you now can also join us on our Discord Server!
  • Happy New Year everyone! A new version (1.0.0-beta.16) is out for Linux, fixing an issue that could lock the bot up when using it with TS3. Please visit the resources section or the main page (https://www.sinusbot.com) for the new package.

TS Client verbraucht unnormal Ram

PlayTronix

Member
Guten Tag,
seit gestern ist unser ganzer Server durch den SinusBot abgestürzt. Nach genauem untersuchen haben wir herausgefunden, das der TS Client nach 1 Minuten den ganzen Ram von dem Server beansprucht. Wir haben schon den data/ts3 Ordner gelöscht. Hat leider nicht geholfen.

Hier sind die Daten von dem Diagnostics Script:

Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
 - Operating System: Debian GNU/Linux 10 (buster)
 - Kernel: Linux 4.19.0-8-amd64 x86_64
 - Load Average: 0.67 1.25 3.82
 - Uptime: 0 days, 4 hours, 2 minutes, 14 seconds
 - OS x64 check: OK
 - OS Updates: 0 (well done!)
 - OS Missing Packages: None
 - OS APT Last Update: 21.03.2020 14:59:36 CET +01:00:00
 - Shell Locale: en_US.UTF-8
 - Bot Start Script: not found
 - CPU:
    Architecture:        x86_64
    CPU(s):              4
    Thread(s) per core:  1
    Core(s) per socket:  4
    Socket(s):           1
    Model name:          Intel(R) Xeon(R) CPU E5-2650 v2 @ 2.60GHz
    CPU MHz:             2599.998
    Hypervisor vendor:   KVM
    Virtualization type: full
 - RAM: 2.42 GB/7.79 GB in use (31%)
 - SWAP: 0 B/0 B in use (0%) (SWAP disabled)
 - DISK: 18.12 GB/58.99 GB in use (30%)
 - Package versions:
   - libglib: 2.58.3-2+deb10u2

BOT INFORMATION
 - Status: not running
 - Webinterface: port locally not reachable (Port: 8087)
 - Binary: /opt/sinusbot/sinusbot
 - Binary Info: MD5 Hash: 224b687db910b732fe5a7cfec4f6c78e, Perms: 777, User: sinusbot
 - Version: 1.0.0-beta.10-202ee4d
 - TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: aa483aea105cb62033392b1ce6d317ab
   - TS3 Client: aa483aea105cb62033392b1ce6d317ab
 - Config:
   - LogLevel = 3
   - TS3Path = /opt/sinusbot/teamspeak3-client/ts3client_linux_amd64 (Version 3.3.2)
   - YoutubeDLPath = /usr/local/bin/youtube-dl (does exist, version: 2020.02.16)
 - Installed scripts: advertising.js; alonemode.js; AntiProxy.js; AutomaticServerGroupAssigner.js; badnickname.js; bookmark.js; command.js; CountOnlineUsers.js; followme.js; KuschelBan.js; norecording.js; OKlib.js; PrivatChannelManager.js; Private_Channel_Manager.js; Reconnect.js; rememberChannel.js; support (2).js; support-pp(1).js; tsSiteVoteSystem.js; twitchLiveChecker.js; Twitch_Status.js; unusedChannelDeleter.js; welcome.js; ZTSupport_-_SupportChannel_With_ServerGroup_Support.js

BOT TECHNICAL INFORMATION
 - File exists:
   - TS3Client/libqxcb-glx-integration.so: no
 - LDD output:
    linux-vdso.so.1 (0x00007ffcff7d5000)
    libswresample.so.2 => /opt/sinusbot/libswresample.so.2 (0x00007fd252cae000)
    libavfilter.so.6 => /opt/sinusbot/libavfilter.so.6 (0x00007fd252956000)
    libavformat.so.57 => /opt/sinusbot/libavformat.so.57 (0x00007fd252555000)
    libavcodec.so.57 => /opt/sinusbot/libavcodec.so.57 (0x00007fd251bf0000)
    libavutil.so.55 => /opt/sinusbot/libavutil.so.55 (0x00007fd25197c000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fd25196b000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fd2517e6000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fd2517c5000)
    libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fd251641000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fd251627000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fd251466000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007fd251248000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fd25123c000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fd252eca000)

REACHABILITY CHECKS
 - HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
 - HTTPS check with IPv6 mode: IGNORED [Disabled]
 - DNS resolution check: SUCCESS [www.sinusbot.com resolved to 104.28.15.74]
 - Update server checks:
    update01.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update02.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update03.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]

TIME INFORMATION
 - Time (local): 21.03.2020 15:14:10 CET +01:00:00
 - Time (remote): 21.03.2020 15:14:10 CET +01:00:00
 - Time (difference): 0 secs (Time diff less than 2 secs. Good.)
 - Timezone: Europe/Berlin

OTHER INFORMATION
 - TeamSpeak3 Version: 3.3.2
 - youtube-dl Version: 2020.02.16
 - DiagScript Version: 0.8.0
==========================================================
 

fabm3n

Well-Known Member
Tier II
Tier III
Tier I
is awesome!
Insider
Du könntest den TS Client mal auf die 3.5.X updaten und dann nochmal den data/ts3 Ordner löschen. Falls das Problem weiterhin auftritt kannst du mehr Informationen liefern (Logs etc)?

Weitere Sachen:
youtube-dl ist nicht aktuell
Die Sinubot Binary läuft gerade auf 777 Permissions, 755 ist empfohlen ;)
 
Top