• If you need help or want to discuss things, you now can also join us on our Discord Server!

Solved youtube-dl download problem | ERROR: This video is unavailable

MrAsinesin

New Member
Hey! For some time I got a problem with downloading from youtube. Every time I want to download something after a few seconds this error appears. I tried everything, update youtube-dl, SinusBot, change the max upload limit and nothing helped. In the console, there's nothing interesting the bot is working fine, I also tried to download manually using youtube-dl command with link to the video and it worked, so I don't know what is going on... Can anybody help me?

Bez tytułu.png

Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
 - Operating System: Ubuntu 18.04.4 LTS
 - Kernel: Linux 4.15.0-55-generic x86_64
 - Load Average: 1.30 0.80 0.56
 - Uptime: 194 days, 14 hours, 6 minutes, 46 seconds
 - OS x64 check: OK
 - OS Updates: 3 (updates available!)
 - OS Missing Packages: None
 - OS APT Last Update: 10.02.2020 22:22:23 CET +01:00:00
 - Shell Locale: en_US.UTF-8
 - Bot Start Script: not found
 - CPU:
    Architecture:        x86_64
    CPU(s):              1
    Thread(s) per core:  1
    Core(s) per socket:  1
    Socket(s):           1
    Model name:          Intel Core Processor (Haswell, no TSX)
    CPU MHz:             2095.062
    Virtualization:      VT-x
    Hypervisor vendor:   KVM
    Virtualization type: full
 - RAM: 516.46 MB/1.89 GB in use (26%)
 - SWAP: 0 B/0 B in use (0%) (SWAP disabled)
 - DISK: 5.86 GB/19.21 GB in use (30%)
 - Package versions:
   - libglib: 2.56.4-0ubuntu0.18.04.4

BOT INFORMATION
 - Status: running (PIDs: 6851 6850, User: grajkarczma)
 - Webinterface: port locally reachable (Port: 8087)
 - Binary: /home/grajkarczma/SinusBot/sinusbot
 - Binary Info: MD5 Hash: 224b687db910b732fe5a7cfec4f6c78e, Perms: 755, User: grajkarczma
 - Version: 1.0.0-beta.10-202ee4d
 - TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: aa483aea105cb62033392b1ce6d317ab
   - TS3 Client: aa483aea105cb62033392b1ce6d317ab
 - Config:
   - LogLevel = 10 (debug log active)
   - TS3Path = /home/grajkarczma/SinusBot/TeamSpeak3-Client/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 (Version 3.3.0)
   - YoutubeDLPath = /home/grajkarczma/SinusBot/youtube-dl (does exist, version: 2019.07.30)
 - Installed scripts: advertising.js; alonemode.js; bookmark.js; command.js; followme.js; norecording.js; rememberChannel.js; sinusbot-commands.js; welcome.js

BOT TECHNICAL INFORMATION
 - File exists:
   - TS3Client/libqxcb-glx-integration.so: yes
 - LDD output:
    linux-vdso.so.1 (0x00007ffd4f554000)
    libswresample.so.2 => /home/grajkarczma/SinusBot/libswresample.so.2 (0x00007f1f84d11000)
    libavfilter.so.6 => /home/grajkarczma/SinusBot/libavfilter.so.6 (0x00007f1f849b9000)
    libavformat.so.57 => /home/grajkarczma/SinusBot/libavformat.so.57 (0x00007f1f845b8000)
    libavcodec.so.57 => /home/grajkarczma/SinusBot/libavcodec.so.57 (0x00007f1f83c53000)
    libavutil.so.55 => /home/grajkarczma/SinusBot/libavutil.so.55 (0x00007f1f839df000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f1f837db000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f1f8343d000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f1f8321e000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f1f82e95000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f1f82c7d000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f1f8288c000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f1f8266f000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f1f82467000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f1f84f2b000)

REACHABILITY CHECKS
 - HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
 - HTTPS check with IPv6 mode: IGNORED [Disabled]
 - DNS resolution check: SUCCESS [www.sinusbot.com resolved to 104.28.14.74]
 - Update server checks:
    update01.sinusbot.com -> 104.28.14.74: SUCCESS [CODE #404]
    update02.sinusbot.com -> 104.28.14.74: SUCCESS [CODE #404]
    update03.sinusbot.com -> 104.28.14.74: SUCCESS [CODE #404]

TIME INFORMATION
 - Time (local): 10.02.2020 23:21:25 CET +01:00:00
 - Time (remote): 10.02.2020 23:21:25 CET +01:00:00
 - Time (difference): 0 secs (Time diff less than 2 secs. Good.)
 - Timezone: Europe/Paris

OTHER INFORMATION
 - TeamSpeak3 Version: 3.3.0
 - youtube-dl Version: 2019.07.30
 - DiagScript Version: 0.8.0
==========================================================
 

TwentyFour

Well-Known Member
V.I.P.
I tried everything, update youtube-dl, [...]

- youtube-dl Version: 2019.07.30
I'm afraid you didn't do everything, neither did you update it. :rolleyes:

You're version is more than 6 months old, most recent one is 2020.01.24
Also Google tells you, that this was a common error, being hotfixed back in September.

Strongly suggesting you to implement the automatic updates mentioned in the FAQ to prevent this from happening in the future.
 

MrAsinesin

New Member
Strange, because after entering a "youtube-dl -U" command I got an answer that the youtube-dl is up to date, so I tried to remove and download it again and it is working now. Thanks a lot and I implement an automatic update as you said, to not happen it again.
 

fabm3n

Active Member
Tier II
Tier III
Tier I
is awesome!
is uber awesome!
Insider
check the version manually youtube-dl --version
 

Similar threads

Top