• If you need help or want to discuss things, you now can also join us on our Discord Server!

Youtube Search and yt-dl wont work

Jujisho

New Member
fisrt sorry for my bad engish and i'm also new at linuw

i tried to install the yt-dl for my server host on linux and the sinusbot alway tell me yt_dl not available

also when using Youtube Search music won't play


- SinusBot 1.0.0-beta.3-735814e
-ts client 3.3.0 / server version 3.9.1 on linux

-os Debian 9.4 Stretch (stable) (64bits) / Linux ns3035990 4.9.168-xxxx-std-ipv6-64
- spec Intel i7-4790K (4c/8th) - 32GB DDR3 1333MHz - 240 GB SSD
- instance log :
2019-09-25T22:56:23+02:00 Done playing
2019-09-25T22:56:23+02:00 CHAT 2 [jujisho @ Jujisho] < yt https://www.youtube.com/watch?v=HS51rz_ZjK4 > / OK
2019-09-25T22:56:09+02:00 Done playing
2019-09-25T22:56:09+02:00 CHAT 2 [jujisho @ Jujisho] < yt https://www.youtube.com/watch?v=HS51rz_ZjK4 > / OK
2019-09-25T22:54:53+02:00 Storing configuration.
2019-09-25T22:54:38+02:00 TS/ERR 2564 e'access to default group is forbidden' x'' r'PR:{ddd03b24-a735-4155-a1c1-fce964eace31}:227/GCLL'
2019-09-25T22:54:38+02:00 Awaiting Callback (2): PR:{ddd03b24-a735-4155-a1c1-fce964eace31}:191/CUPD
2019-09-25T22:54:38+02:00 Awaiting Callback (2): PR:{ddd03b24-a735-4155-a1c1-fce964eace31}:190/CUPD
2019-09-25T22:54:38+02:00 Awaiting Callback (2): PR:{ddd03b24-a735-4155-a1c1-fce964eace31}:189/CUPD
2019-09-25T22:54:38+02:00 Awaiting Callback (2): PR:{ddd03b24-a735-4155-a1c1-fce964eace31}:188/CUPD
2019-09-25T22:54:37+02:00 TS |INFO | | |Statistics report: Not yet, next report on ven. oct. 18 15:54:03 2019
2019-09-25T22:54:37+02:00 TS |INFO |ClientUI | |Last update check was: sam. janv. 1 00:00:01 2022
2019-09-25T22:54:37+02:00 TS |INFO |Bookmarks | |Collecting autoconnect bookmarks
2019-09-25T22:54:37+02:00 New connection status 4; Error 0
2019-09-25T22:54:37+02:00 TS |INFO |PermManager | |Loading permissions from cache
2019-09-25T22:54:37+02:00 TS |INFO |ClientUI |1 |Connect status: Connection established
2019-09-25T22:54:37+02:00 BEATMAKER joined the channel
2019-09-25T22:54:37+02:00 New connection status 3; Error 0
2019-09-25T22:54:37+02:00 TS |INFO |ClientUI |1 |Connect status: Establishing connection
2019-09-25T22:54:37+02:00 New connection status 2; Error 0
2019-09-25T22:54:37+02:00 TS |INFO |ClientUI |1 |Connect status: Connected
2019-09-25T22:54:37+02:00 TS |DEVELOP |PktHandler | |Puzzle solve time: 2
2019-09-25T22:54:37+02:00 New connection status 1; Error 0
2019-09-25T22:54:37+02:00 TS |INFO |ClientUI |1 |Connect status: Connecting
2019-09-25T22:54:37+02:00 TS |INFO |PreProSpeex |1 |Speex version: 1.2rc1
2019-09-25T22:54:37+02:00 TS |INFO |ClientUI |1 |Initiating connection: 193.70.81.66:9987
2019-09-25T22:54:37+02:00 TS |INFO |ClientUI |1 |Connect to server: 193.70.81.66
2019-09-25T22:54:37+02:00 TS |INFO |ClientUI | |ts3server: 193.70.81.66?port=9987&nickname=%E2%84%A2MisTeRyA%20%20BOT&password=&cid=48&channelpassword=
2019-09-25T22:54:37+02:00 TS |INFO | | |successfully downloaded revocation list for myteamspeak id
2019-09-25T22:54:37+02:00 TS |INFO | | |successfully downloaded revocation list for accounting
2019-09-25T22:54:37+02:00 TS |INFO |ClientUI | |Using configuration location: /opt/sinusbot/data/ts3/0d564515-6a64-457f-b9d4-232be1fc635d/a0e60452-543b-4a3a-8a06-3aa7e378d781/settings.db
2019-09-25T22:54:37+02:00 TS |INFO |ClientUI | |Qt version: 5.12.1
2019-09-25T22:54:37+02:00 TS |INFO |ClientUI | |Failed to init text to speech engine
2019-09-25T22:54:37+02:00 TS |DEVELOP |ClientUI | |Notifications init: Soundpack path: /opt/sinusbot/TeamSpeak3-Client-linux_amd64/sound/nosounds
2019-09-25T22:54:37+02:00 TS>ClientQueryPlugin: currentServerConnectionChanged 1 (0)
2019-09-25T22:54:37+02:00 TS |INFO |Query | |listening on 127.0.0.1:25639
2019-09-25T22:54:37+02:00 TS |INFO |Plugins | |Loading plugin: libclientquery_plugin_linux_amd64.so
2019-09-25T22:54:37+02:00 TS |INFO |Plugins | |Loading plugin: libsoundbot_plugin.so
2019-09-25T22:54:37+02:00 TS |INFO |Addons | |Checking for addon updates...
2019-09-25T22:54:37+02:00 TS |ERROR |RevocationListCache| |Failed to import revocation list from cache
2019-09-25T22:54:37+02:00 TS |INFO |ClientUI | |Unable to create an Open GL context.
2019-09-25T22:54:37+02:00 TS |ERROR |SoundBckndIntf| |/opt/sinusbot/TeamSpeak3-Client-linux_amd64/soundbackends/libpulseaudio_linux_amd64.so error: INIT_PA_IMPL
2019-09-25T22:54:37+02:00 TS |ERROR |PulseAudio | |pa_context_connect failed -
2019-09-25T22:54:37+02:00 TS |ERROR |PulseAudio | |failed to connect to pulse audio server -
2019-09-25T22:54:37+02:00 TS |INFO | | |Using hardware aes
2019-09-25T22:54:37+02:00 TS |INFO | | |SystemInformation: Linux 4.9.168-xxxx-std-ipv6-64 #665790 SMP Mon Apr 8 08:31:26 UTC 2019 x86_64 Binary: 64bit
2019-09-25T22:54:37+02:00 TS |INFO | | |TeamSpeak 3 Client 3.3.0 (2019-06-18 09:29:01)
2019-09-25T22:54:37+02:00 TS>DUMP defined! Dumpdir is: /opt/sinusbot/data/ts3/0d564515-6a64-457f-b9d4-232be1fc635d/a0e60452-543b-4a3a-8a06-3aa7e378d781/crashdumps
2019-09-25T22:54:37+02:00 TS>Crashdump ENABLED, directory is: /opt/sinusbot/data/ts3/0d564515-6a64-457f-b9d4-232be1fc635d/a0e60452-543b-4a3a-8a06-3aa7e378d781/crashdumps
2019-09-25T22:54:37+02:00 Starting instance ts3server://193.70.81.66?port=9987&nickname=%E2%84%A2MisTeRyA%20%20BOT&password=&cid=48&channelpassword=
bot log :
2019-09-25T22:52:42+02:00 JOBS-ADD [admin] https://www.youtube.com/watch?v=HS51rz_ZjK4 OK
2019-09-25T18:12:53+02:00 Loading instance://a0e60452-543b-4a3a-8a06-3aa7e378d781
2019-09-25T18:12:53+02:00 Loading instance://98b90a3e-a80c-4f2c-99ac-40694e7ed6bf
2019-09-25T18:12:53+02:00 Loading instances
- config ini :
port : 8087
listen host : "0.0.0.0"
ts3path: "/opt/sinusbot/TeamSpeak3-Client-linux_amd64/ts3client-linux_amd64"
LogLevel = 10
i use chrome for the panel
script used in bot :
AFK mover (Away/Mute/Deaf/Idle)
CountOnlineUsers
Youtube Search
AloneMode
Welcome!
 

Attachments

Lala Sabathil

Donor
is awesome!
is uber awesome!
Contributor
Insider
You know that you have to set the path to the exetuable of Youtube dl in the configuration
 

Mugen

New Member
is there an actually tutorial with actually Versions.

I hosted my Bot on 4netplayers as my Teamspeak and i tested all Tutorials here

isnt working
 

Jujisho

New Member
always the same error after making the right path in the config ini for the yt dl


2019-10-14T21:59:06+02:00 Done playing
2019-10-14T21:59:06+02:00 CHAT 2 [jujisho @ Jujisho] < yt https://www.youtube.com/watch?v=lbWvVTvBw_s > / OK
2019-10-14T21:58:47+02:00 Done playing
2019-10-14T21:58:47+02:00 CHAT 2 [jujisho @ Jujisho] < yt https://www.youtube.com/watch?v=lbWvVTvBw_s > / OK
2019-10-14T21:57:22+02:00 Done playing
2019-10-14T21:57:22+02:00 CHAT 2 [jujisho @ Jujisho] < yt https://www.youtube.com/watch?v=lbWvVTvBw_s > / OK
 

olokos

Insider
Insider
type
which youtube-dl
in terminal outside of sinusbot directory
If you see it somewhere else than the sinusbot directory then this is your problem @Jujisho
At least that was the problem I was having
 

Similar threads

Top