1. The bot currently doesn't work with version 3.1 of the TS client. Please downgrade to an older version. Read this for more information on how to downgrade.

SinusBot Beta 0.9.18-8499d2c

Introducing Scripting and preparing for 1.0

  1. flyth
    GERMAN VERSION BELOW / DEUTSCHE VERSION UNTEN

    PLEASE DO NOT DOWNGRADE FROM VERSION 98d0cd5 TO AN EARLIER VERSION AS IT MIGHT BREAK STUFF. ALWAYS CHECK THE "UPDATES" TAB FOR THE LATEST INFORMATION ON THIS BETA.

    Thank you very much for participating in this beta test. Should you encounter any bugs, feel free to open a new ticket in this beta forum.

    Features
    • introduce scripting
    • audio filters
    • improved playlists
    • initial support for Mumble / Discord
    • many interface enhancements
    • stability improvements
    • better search capabilities
    • initial support for speech recognition
    • license system
    • ... many more things have been added, see the updates tab above
    Scripts

    New scripts can be added by copying them to the scripts-subfolder. There are some demos provided and a better documentation will follow soon. I hope to get a minimal "script store" running soon. Until then, feel free to share your scripts on the forums.

    Current (incomplete) documentation for the Script API can be found here.

    Upgrading

    Code:
    cd /opt/ts3bot
    curl -O https://www.sinusbot.com/dl/sinusbot-beta.tar.bz2
    tar -xjvf sinusbot-beta.tar.bz2
    Please adjust to your own paths.

    To upgrade, just extract the archive and overwrite the old files with the new ones.
    Please also update the plugin by copying it from plugin/libsoundbot_plugin.so to TeamSpeakClient/plugins/libsoundbot_plugin.so

    Be aware that the new binary is called sinusbot rather than ts3bot.

    After upgrading, xinit is not necessary anymore. Just launch the bot with ./sinusbot - however, if you're using screen, sudo or su, you have to use it in front of ./sinusbot as well.

    --------------------------------

    GERMAN

    Vielen Dank für die Teilnahme am Beta-Programm. Falls dir irgendwelche Bugs auffallen oder du Wünsche oder Kritik äußern willst, nutze bitte das Beta-Forum dafür.

    Features
    • Scripting
    • Audiofilter
    • verbesserte Playlists
    • initialer Support für Mumble und Discord
    • viele Interface-Verbesserungen
    • Stabilitäts-Verbesserungen
    • optimierte Suche
    • initiale Unterstützung für Spracherkennung
    • Lizenzsystem
    Scripts

    Neue Scripts können hinzugefügt werden, indem man sie in den scripts-Ordner kopiert. Es sind bereits einige Beispiele vorhanden und eine bessere Doku wird bald auch folgen. Die Hoffnung ist, bald auch einen kleinen "Script-Store" (natürlich gratis) zur Verfügung zu stellen. Bis dahin dürfen Scripts sehr gerne über das Forum geteilt werden.

    Die vorläufige und unvollständige API-Doku befindet sich hier.

    Upgrade

    Code:
    cd /opt/ts3bot
    curl -O https://www.sinusbot.com/dl/sinusbot-beta.tar.bz2
    tar -xjvf sinusbot-beta.tar.bz2
    Bitte an die eigenen Pfade anpassen.

    Um den Bot zu aktualisieren müssen lediglich das Archiv entpackt und die alten Dateiversionen überschrieben werden.
    Wichtig ist, dass ihr auch das Plugin durch kopieren von plugin/libsoundbot_plugin.so nach TeamSpeakClient/plugins/libsoundbot_plugin.so aktualisiert wird.

    Achtung: die neue ausführbare Datei heißt jetzt sinusbot statt ts3bot.

    Nach dem Upgrade ist xinit nicht mehr notwendig. Der Bot kann einfach mit ./sinusbot gestartet werden - wenn du allerdings screen, sudo oder su benutzt hast, gehört das nach wie vor vor das ./sinusbot.

Recent Reviews

  1. TecWar
    TecWar
    5/5,
    Version: 0.9.18-8499d2c
    Thank you :) 0.9.18 <3
  2. Marius Koschubat
    Marius Koschubat
    3/5,
    Version: 0.9.16-10f0fad
    Läuft nicht mehr, auch nicht mit kleinerer TeamSpeak Version, da TeamSpeak immer eine Fehlermeldung aufplöppen lässt vor dem connect und somit den Sinusbot zerschießt.
  3. Jumpy
    Jumpy
    5/5,
    Version: 0.9.16-10f0fad
    purrfect
  4. n00deL
    n00deL
    5/5,
    Version: 0.9.16-10f0fad
    Perfekt!
  5. Patschi
    Patschi
    5/5,
    Version: 0.9.16-10f0fad
    Made by flyth. Enough said.
  6. Mezir
    Mezir
    5/5,
    Version: 0.9.16-10f0fad
    Good job! ;)
  7. maurawa
    maurawa
    5/5,
    Version: 0.9.16-10f0fad
    Ämm ne frage ich habe mir jetzt die Zip runtergeladen....Wo muss die jetzt hin?
  8. TDJ
    TDJ
    5/5,
    Version: 0.9.16-10f0fad
    Klappt zuverlässig!
    Vielleicht noch die Links im Code oben anpassen, damit man nicht ausversehen die flasche Version herunterlädt :D
  9. Ice Sihaya
    Ice Sihaya
    5/5,
    Version: 0.9.15-b20cc30
    Works nice, very excited for mumble implementation ;)
  10. desolic
    desolic
    1/5,
    Version: 0.9.15-b20cc30
    Haben sich die Login-Daten geändert? Kann mich nicht mehr einloggen mit admin und foobar?!
    1. flyth
      Author's Response
      Für den einen Stern, gibt's auch nur ein Wort: FAQ. :)