• If you need help or want to discuss things, you now can also join us on our Discord Server!
  • Happy New Year everyone! A new version (1.0.0-beta.16) is out for Linux, fixing an issue that could lock the bot up when using it with TS3. Please visit the resources section or the main page (https://www.sinusbot.com) for the new package.

Solved Bot doesn't launch (and no output)

Status
Not open for further replies.

Luukuton

Member
Solved! A new working version has been released! Just download the latest version from here (at the time of writing 0.9.15-b20cc30 is the latest).

Operating System
: Debian 8.6 64bit
SinusBot Version: 0.9.12.3-36fce3c (newest)
TS3 Version: 3.0.19.4

Problem Description
After rebooting my whole server today, I couldn't start my SinusBot anymore. It doesn't output anything, it doesn't do anything. As you can see below. I have the latest version of SinusBot and TeamSpeak3 + I have copied the latest plugin (libsoundbot_plugin.so) to the plugins folder.

I have also tried "sudo apt-get update && sudo apt-get upgrade" and "sudo apt-get dist-upgrade".

//Edit, oh and I forgot to add. I tried a fresh new installation on a new server, didn't work.

Code:
[email protected]:~/SinusBot$ ./sinusbot
[email protected]:~/SinusBot$

My config:
Code:
TS3Path = "/home/bot/SinusBot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64"
ListenHost = "0.0.0.0"
DataDir = "/home/bot/SinusBot/data/"
ListenPort = 8087
LocalPlayback = false
EnableLocalFS = false
MaxBulkOperations = 300
LogLevel = 3
EnableProfiler = false
YoutubeDLPath = "/usr/local/bin/youtube-dl"
EnableDebugConsole = false
UploadLimit = 83886080
RunAsUser = 0
RunAsGroup = 0
InstanceActionLimit = 6
UseSSL = false
SSLKeyFile = ""
SSLCertFile = ""
Hostname = ""
SampleInterval = 60
StartVNC = false
EnableWebStream = false
LogFile = ""
LicenseKey = "XXXX"
IsProxied = false
DenyStreamURLs = []
Pragma = 0

[YoutubeDL]
  BufferSize = 524288
  MaxDownloadSize = 419430400
  MaxDownloadRate = 104857600
  CacheStreamed = false

[TS3]
  AvatarMaxWidth = 0
  AvatarMaxHeight = 0

[StreamRewrites]

[Scripts]
  AllowReload = false
  EnableTimer = false

[SpeechRecognition]
  Enable = false

[FFmpeg]
  UserAgent = "SinusBot"

[DAV]
  Enable = false

[XServer]
  Delay = 0
  Debug = false
 
Last edited:

kanalumaddela

Insider
Insider
English: The beta versions expire on a predefined date. This means you have to upgrade to the latest version, but by the looks of it, I think the latest version expired. @flyth can confirm this.

(From Google translate, someone please provide a better translation)
German: Die Beta-Versionen laufen zu einem vordefinierten Datum ab. Dies bedeutet, dass Sie auf die neueste Version aktualisieren müssen, aber durch die sieht es aus, ich glaube, die neueste Version abgelaufen ist. @flyth kann dies bestätigen.
 
Last edited:

LeonJoas

Active Member
Bei mir auch :/
Was kann man jetzt tun?
Ich habe mit scripts aus dem Forum und selbstgeschriebenen Scripts "einen Zentralen ServerBot" erstellt.
Dieser macht mit seinen 45 Scripts alles auf dem TS!
Was soll ich ohne den machen?
 

sachs

Member
With the latest version 0.9.8 you couldn't use any scripts and the beta is expired.
Somebody need to fix the beta version, I need also the scripts! :D
 
I ran into the same issue and some further testing confirms that the problem is related with the expiration of the current beta.
The tests were done with version 0.9.12.3-36fce3c, which is currently the latest available beta according to the resources section.

sinusbot immediatly exits with no error message when system time is set to 2016-10-29 21:04:26 UTC (timestamp 1477775066) or later.
For now the only workaround I've found is to manually set the system time to 2016-10-29 21:04:25 or earlier just before starting sinusbot.

For instance:
sudo date --set '2016-10-29 21:04:25' && ./sinusbot

Unfortunatly, this can't be applied on our production server because of the potential impact on the other services.

As we are not using custom scripts I've tried downgrading to 0.9.8 but this version seems plagued with the "TSClient quit" bug (https://github.com/flyth/ts3soundbot/wiki/Installation---Debian-&-Ubuntu-(v0.9.8)) and the described workarounds didn't work. Or this comes from compatibility issues with the latest TS3 client.

Thank you for looking into this quickly as production is currently interrupted.
 

Luukuton

Member
It seems that a new working version has been released! Just download the latest version from here (at the time of writing 0.9.15-b20cc30 is the latest).
 
Status
Not open for further replies.
Top