• If you need help or want to discuss things, you now can also join us on our Discord Server!

Bot kann Server nicht beitreten nach Installation

TOminerTV

Member
Hallo Sinusbot-Forum,

ich musste unsere Sinusbot auf einem neuen Root-Server neuinstallieren.
Selbes Problem wie immer er kann anfänglich nicht joinen, alle mir
bekannten Schritte bin ich schon durchgegangen:
- TS3 Client / SinusBot updaten (Sinusbot sollte aber wegen der Installation eh schon aktuell sein)
- Bot von der Konsole starten für genauere Fehlermeldung

Informationen:
Server: Ubuntu 20.04 LTS (AMD Core - 16 GB RAM)
Sinusbot: 1.0.0-beta.10-202ee4d

Bot wird per Skript gestartet
Installation erfolgte mit dieser Anleitung (hat früher immer geklappt): https://www.linuxsecrets.com/sinusbot-wiki/en:guides:installation:linux.html

Config.ini:
https://pastebin.com/XBiPeKxJ

Latest Log:
https://pastebin.com/H5kZ9gdv

Ich hoffe ihr könnt mir helfen, da ich ab hier echt nicht mehr weiter weiß.

Mfg
Tobias
 

Jniklas2

Donor
is awesome!
is uber awesome!
Insider
1. Die Anleitung ist keine offizielle Anleitung. Verwende entweder das Installerscript oder die Anleitung in der Documentation
2. Bei der verlinkten Anleitung ist ein völlig veralteter TS3 Client verlinkt
3. Bitte alle Infos, welche hier gefordert werden, bereitstellen (am besten mit dem Diag-Script)
 

Jniklas2

Donor
is awesome!
is uber awesome!
Insider
Das hilft schon gut weiter aber hier sind ein paar Punkte, die da auffallen bzw. die es dir unmöglich machen:
  1. Du solltest auf deinem Server mal Updates durchführen ;)
  2. Auf diesem Server wird der Sinusbot nicht funktionieren, da
    1. Der Kernel zu alt für alle TS3 Client Versionen ab 3.3+ ist
    2. Der Sinusbot 1.0.0-beta.10 (deine Version) braucht min. 3.3+
    3. Dein Server ist mithilfe von OpenVZ virtualisiert und da kann man den Kernel nicht aktualisieren (zumindest nicht als Kunde)
Also das einzige, was du machen kannst, ist bei einen anderen Server zu mieten, welcher auf KVM Basis virtualisiert wird. Alternativ wäre dedizierte Hardware
Für den neuen Server empfehle ich dir das Installer Script, welches hier verlinkt ist.
 

TOminerTV

Member
Jo danke, habs jetzt auch gesehen, wurden beim umstellen des Servers beschissen, das erklärt durchaus einiges 🙈.
 
Last edited:

TOminerTV

Member
Ok, nach Rücksprache mit unserem Anbieter ergab sich das wir früher die selben Hard- und Software Komponenten hatten. Ist es möglich das eine alte Version des Bots auf dieser Basis läuft?
 

Jniklas2

Donor
is awesome!
is uber awesome!
Insider
Die alten Bot Versionen unterstützen die aktuellen TS3 Versionen nicht mehr und zudem werden die alten Bot Versionen nicht mehr supported (wenn die denn überhaupt noch starten, denn da gibt es auch eine Zeitliche Beschränkung)

Ich kann dir wiederholt nur ein anderen Server empfehlen.
 

TOminerTV

Member
So, neuer Server ist gekauft. Problem bleibt aber bestehen, vielleicht könnt ihr mir ja jetzt helfen.
Hier der neue Output des Diag-Scripts:
https://pastebin.com/rfeW92G3

Fehlermeldung:
2021-03-20T17:53:06+01:00 TS>Available platform plugins are: xcb.
2021-03-20T17:53:06+01:00 TS>
2021-03-20T17:53:06+01:00 TS>This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
2021-03-20T17:53:06+01:00 TS>qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
2021-03-20T17:53:06+01:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2021-03-20T17:53:05+01:00 Starting instance ts3server

Mfg
Tobias
 
Last edited:

itsme

Donor
is awesome!
is uber awesome!
Servus, ich würde mal versuchen das QT Plugin (was immer das ist) zu deaktivieren und den BOT nochmalneu zu starten. Denn laut Deiner Fehlermeldung scheint mit diesem PLUGIN etwas nicht zu stimmen.

2021-03-20T17:53:06+01:00 TS>This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
 

MauriceR

Donor
is awesome!
Contributor
Das sieht mir eher danach aus, dass nicht alle benötigten Pakete installiert wurden.
Hast du diese Befehle ausgeführt?
Code:
apt-get update 
apt-get install -y x11vnc xvfb libxcursor1 ca-certificates curl bzip2 libnss3 libegl1-mesa x11-xkb-utils libasound2 libpci3 libxslt1.1 libxkbcommon0 libxss1 libxcomposite1 update-ca-certificates
Bei manchen Debian & Ubuntu Systemen wird übrigens noch folgendes gebraucht:
Code:
apt-get install libglib2.0-0

Alles ist hier nachlesbar
 

itsme

Donor
is awesome!
is uber awesome!
Wäre es nicht einfacher wenn er das Installer-Script durchlaufen lässt?
Gut, davon bin ich ausgegangen :/
 

MauriceR

Donor
is awesome!
Contributor
Tja, die offizielle Anleitung scheint nicht so zuverlässig zu sein, mit dem Script hat es jetzt geklappt, danke.

Habe gerade nochmal nachgeguckt und gesehen, dass das Script ein paar mehr Pakete Installiert, als in der Dokumentation angegeben sind.
Denke, dass in diesen Fall die Dokumentation mal geupdatet werden sollte.
 
Top