• If you need help or want to discuss things, you now can also join us on our Discord Server!
  • Happy New Year everyone! A new version (1.0.0-beta.16) is out for Linux, fixing an issue that could lock the bot up when using it with TS3. Please visit the resources section or the main page (https://www.sinusbot.com) for the new package.

Cant start SinusBot first time (Manual update i required)

Filk

New Member
Hi there.
I'm trying to run a SinusBot for Windows for the Discord. After installation, I'm launching a shortcut and run the 127.0.0.1:8087 in fierfox and nothing happens.
I tried to open port 8087 in the firewall, but the result is the same.

  • sinusbot-0.13.37
  • Windows 7 x64 (VMware 12)
  • 8GB ram, Xeon E31230 3.2 ghz
  • Fierfox, Explorer
  • TS3Path = ""
    ListenHost = "0.0.0.0"
    DataDir = "C:\\SinusBot\\data\\"
    ListenPort = 8087
    LocalPlayback = false
    EnableLocalFS = false
    MaxBulkOperations = 300
    LogLevel = 10
    EnableProfiler = false
    YoutubeDLPath = ""
    EnableDebugConsole = false
    UploadLimit = 83886080
    RunAsUser = 0
    RunAsGroup = 0
    InstanceActionLimit = 6
    UseSSL = false
    SSLKeyFile = ""
    SSLCertFile = ""
    Hostname = ""
    HostnameMask = ""
    SampleInterval = 60
    StartVNC = false
    EnableWebStream = false
    LogFile = ""
    LicenseKey = "yfZrHAYHy/6w5R1jURxnGs/J3xoOan/hqaKI028ahQc="
    IsProxied = false
    DenyStreamURLs = []
    Pragma = 0
    UserAgent = ""

    [YoutubeDL]
    BufferSize = 524288
    MaxDownloadSize = 419430400
    MaxDownloadRate = 104857600
    MaxSimultaneousChunkDownloads = 6
    CacheStreamed = false
    TimeoutSingleDownloader = 0
    TimeoutMultiDownloader = 0
    ChunkSize = 3145728

    [TS3]
    AvatarMaxWidth = 0
    AvatarMaxHeight = 0
    AllowGIF = false

    [StreamRewrites]

    [Scripts]
    AllowReload = false
    EnableTimer = false
    DisableLegacyEvents = false
    ScriptTimeout = 5

    [Themes]
    Default = ""

    [SpeechRecognition]
    Enable = false

    [FFmpeg]
    UserAgent = "SinusBot (0.13.37-f37f203)"

    [DAV]
    Enable = false

    [XServer]
    Delay = 0
    Debug = false

    [SHMem]
    Enable = false
    Size = 0
    Delay = 0
    Interval = 0

    [RadioStations]
    URL = ""
    UpdateInterval = 0
Hope for your help...
 

Filk

New Member
Hi,

Can you try another browser such has Google chrome ?
Hi, the same. Also i tried to run it on my laptop with Windows 10 and the result is the same.
In general I do not see Sinusbot.exe or something in proecess. Is it normal?
Also looks like this guy have the same problem https://forum.sinusbot.com/threads/help-my-sinusbot-does-not-start.5357/, so i tried

Code:
Open your CMD

cd ..

cd ..

cd SinusBot

sinusbot
Result:

C:\SinusBot> ___ ___ _ _ _ _ ___ ___ ___ _____ BETA
/ __|_ _| \| | | | / __| _ )/ _ \_ _|
\__ \| || .` | |_| \__ \ _ \ (_) || |
|___/___|_|\_|\___/|___/___/\___/ |_|

Version: 0.13.37-f37f203
(C) 2013-2018 Michael Friese. All rights reserved.

2018/05/22 00:15:34 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin advertising.js

2018/05/22 00:15:34 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin alonemode.js
2018/05/22 00:15:34 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin bookmark.js
2018/05/22 00:15:34 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin followme.js
2018/05/22 00:15:34 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin norecording.js

2018/05/22 00:15:34 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin rememberChanne
l.js
2018/05/22 00:15:34 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin welcome.js
a manual update is required

But i have correct time zone for my country...
 
Last edited:

GleoLP

Member
Did you open the sinusbot.exe file before? After starting, there should be an popup from Windows on the bottom right site. Click on that and you're
automatically logged in. You should connect with remote desktop.

Best regards
GleoLP
 

Filk

New Member
Did you open the sinusbot.exe file before? After starting, there should be an popup from Windows on the bottom right site. Click on that and you're
automatically logged in. You should connect with remote desktop.

Best regards
GleoLP
There is nothing in bottom right site. I run it every time but there is no "Sinusbot.exe" in process. Also i tried run it on my home PC and have same result:(
 

Filk

New Member
Try to reinstall Sinusbot (normaly: C:\Sinusbot\uninstall) and create an shortcut.
When i press uninstall.exe on my laptop, home PC or vmware PC nothing happens. So i try delete it manually and reinstall, but look like this dont help`s me
 

Filk

New Member
the problem is still relevant. Installed the English version of Windows for the sake of interest, but it also did not help. Any ideas?
 

Xuxe

Containerholic
Staff member
is awesome!
V.I.P.
Contributor
Insider
the problem is still relevant. Installed the English version of Windows for the sake of interest, but it also did not help. Any ideas?

Feel free to join the chat and pin me via @Xuxe ;) And provide the RDP credentials via PN please i would take a look.
 

Filk

New Member
Okay, its time for some mystyc. All this attempts I did on in my office inside my country. I tried run sinusbot on Windows 10 on my laptop, my home PC, virtual PC in my office and finally on 2 windows servers in office (2008 and 2012). Always with the same result.
But when i try install and run Sinusbot on windows server 2012 in Germany...ITS WORKS. WTF?! Same rules in windows fierwall, but in my country sinusbot dont want to run.
Can it be reason in time zones and the country where I am? And how can i fix it?
 

Filk

New Member
Okay, its time for some mystyc. All this attempts I did on in my office inside my country. I tried run sinusbot on Windows 10 on my laptop, my home PC, virtual PC in my office and finally on 2 windows servers in office (2008 and 2012). Always with the same result.
But when i try install and run Sinusbot on windows server 2012 in Germany...ITS WORKS. WTF?! Same rules in windows fierwall, but in my country sinusbot dont want to run.
Can it be reason in time zones and the country where I am? And how can i fix it?
UPD. Can it be the same problem as HERE?
And how to fix it? Becasue i need Sinusbot currently on server in my country.
 

Filk

New Member
@flyth I set free vpn and with it the sinebot works. I would be grateful if you can tell me why my original ip addresses do not work and what I can do about it.
 
Top