• If you need help or want to discuss things, you now can also join us on our Discord Server!

Disconnecting RDP, Bot mutes it self?

Jokke

Member
Hey wonderfull people of Sinus!


I come with most of pleasure, but a single question have struck my mind.

I have the sinusbot hosted on a windows machine, I setup it up and use it everyday, it's too close to being perfect now!
The thing is, when I disconnect from the RDP, the bot mutes it self. I'm pretty sure it's just a three click fix, but how?


Thanks for your work and time,

Have a good one
Jokke
 

irgendwr

no longer active
Staff member
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
Hi, we have heard this issue from a few people now but we can't fix it as far as I know.
The problem is that the TeamSpeak client mutes itself when you log out and this can't be disabled.
I'd recommend learning how to use linux and switching to it tbh.
 

Everlike

Well-Known Member
Contributor
@irgendwer is right!
To make it more clear:
You may use windows on your private computer, and if you´re in Teamspeak (unmuted and "undeafed") and then lock your screen (with win+ L) you can hear "microphone muted" -> so Teamspeak automatically mutes you when you lock your screen. The same seems to happen on your windows Server when you close the rdp. Unfortunately it seems that there is no way to disable this "auto mute"...
On Linux, there is no problem like this.
 

Lala Sabathil

Donor
is awesome!
is uber awesome!
Contributor
Insider
@irgendwer is right!
To make it more clear:
You may use windows on your private computer, and if you´re in Teamspeak (unmuted and "undeafed") and then lock your screen (with win+ L) you can hear "microphone muted" -> so Teamspeak automatically mutes you when you lock your screen. The same seems to happen on your windows Server when you close the rdp. Unfortunately it seems that there is no way to disable this "auto mute"...
On Linux, there is no problem like this.
For things like bots users should always use linux.
My opinion.
 

ZedZ

Member
i've came to the same problem today, but i found a workaround:

create a .bat file with this code:
Code:
for /f "skip=1 tokens=3" %%s in ('query user %USERNAME%') do (
  %windir%\System32\tscon.exe %%s /dest:console
)

then create a shortcut to the .bat file and configure it to start as an administrator.

now, if you leave the rdp session, don't close the window but start the shortcut to the .bat file.
this kicks you out of the rdp session without logging out your user -> bot doesn't get muted.

if anybody has a better solution, let me know :)

PS: thread about muting teamspeak while logged off: https://forum.teamspeak.com/threads/72927-Not-possible-Microphone-Mutes-on-Computer-Lock
 

Similar threads

Top