• If you need help or want to discuss things, you now can also join us on our Discord Server!
  • Happy New Year everyone! A new version (1.0.0-beta.16) is out for Linux, fixing an issue that could lock the bot up when using it with TS3. Please visit the resources section or the main page (https://www.sinusbot.com) for the new package.

Solved Event 'clientMove' on Discord usually not working

Hello,
i am experiencing a very weird bug which i tried to fix after several days of testing, but can't fix it.
I assume this is a bug in the 'clientMove' Event for Discord.
I wrote a script which greets everyone with a configured ClientID in the Sinusbot-Config and plays a sound file (with track://...) upon join.

The first tries were successful, but we found out it didn't work on every client that connected and it didn't really work well in the end.
I integrated an engine.log("MESSAGE") to find the problem, i realised the message usually never appears upon join, so the event 'clientMove' doesn't even get called.
Instead this Instance Log in the Web Panel appears to that time:
"state instable for discord connection"
If this user writes something in chat afterwards, the command.js Script logs the following:
"[ command:41:14] could not get author with ID=324290563832676373; replacing client with workaround"

My Sinusbot-Infos:
Version: 1.0.0-beta.14-dc94a7c
OS: Debian 11
Script is attached to this post :)

Any help appreciated! Thanks in advance.

Kind regards,
nerzlakai96
 

Attachments

  • joinmessage.js
    3.7 KB · Views: 1
I found out it may be something internal.
When i restart the Sinusbot, everything works, but after some time the Client/Author can't be fetched anymore so the Events related to a Client are not called anymore.
For example, i want the Sinusbot to join my channel and i write !join, the sinusbot will just not come (All rights are set correctly).
It just prints this as metioned above in Instance Log:
"[ command:41:14] could not get author with ID=324290563832676373; replacing client with workaround"

Same problem happens for the Event 'clientMove'.
I tried reinstalling the Sinusbot. The Teamspeak 3-Instance i use works flawless, it's just the Discord-Instance.

Does anybody else have this problem?
Thanks in advance and kind regards

My Sinusbot-Infos as mentioned above:
Version: 1.0.0-beta.14-dc94a7c
OS: Debian 11
 
Top