• If you need help or want to discuss things, you now can also join us on our Discord Server!

Not able to use any commands (teamspeak 3) // used to work before

oualid6496

Member
For some reason the bot doesn't react to any of my commands I've tried a bunch of them (!volume up, !next, !search...., !yt~) I have the right permissions I have triple checked that and the youtube dl is updated to it's latest version. I haven't changed anything about the permissions so I know that those are ok. I have group permissions and one permission directly connected with my uid.

Here is the instance log it gives some errors but im not experienced enhough to know what those are xd
Let me know if you need any more information, ty.
2020-02-08T03:10:24+01:00 New connection status 4; Error 0
2020-02-08T03:10:24+01:00 error on callback func: Uncaught exception: TypeError: Cannot read property 'name' of undefined at adminStaffStatus1.0.0:100:49 if (backend.getChannelByID(config.Channel).name() != replaceChannelName(config.channelName)) { ^ Stack trace: TypeError: Cannot read property 'name' of undefined at adminStaffStatus1.0.0:100:50
2020-02-08T03:10:24+01:00 New connection status 3; Error 0
2020-02-08T03:10:24+01:00 New connection status 2; Error 0
2020-02-08T03:10:23+01:00 New connection status 1; Error 0
2020-02-08T03:10:21+01:00 Could not send config: HTTP returned an error: Error; Code: 500; Message: Error
2020-02-08T03:10:21+01:00 Could not send var command: HTTP returned an error: Error; Code: 500; Message: Error
2020-02-08T03:10:15+01:00 Starting instance ts3server://oujda-ot.com?port=9987&nickname=%E2%96%88%20%E2%96%84%20%E2%96%8C%E2%96%84%20Oualid%20Playlist%20%E2%96%88%20%E2%96%84%20%E2%96%84%20%E2%96%88&password=&cid=108&channelpassword=
2020-02-08T03:10:14+01:00 Could not create Notifications-Tabletable Notifications already exists
2020-02-08T03:10:14+01:00 Could not create WhisperReceive-Tabletable WhisperReceive already exists
2020-02-08T03:10:14+01:00 Could not create Chat-Tabletable Chat already exists
2020-02-08T03:10:12+01:00 Auto-Playing last track
2020-02-08T03:10:12+01:00 script adminStaffStatus1.0.0 loaded
2020-02-08T03:10:12+01:00 Last track was c077fcb6-c7a1-422b-b043-a07b57b4e6e5, will auto-play soon
2020-02-08T03:10:12+01:00 Auto-Starting 36b1da52-74a1-4a4c-a20b-3cfe505aca17/884c7395-dbcc-4256-bcf7-4a2b9afa5927 in 500 ms...
2020-02-08T03:10:12+01:00 Initialization complete
2020-02-08T03:10:12+01:00 script OKlib loaded

Edit:
Btw I've installed some new scripts and I thought the problem was with them but then I've disabled all the scripts and removed the OKLib and restarted the bot again to test it but the bot still doesn't recognize any commands =/

Edit2:
Here is some extra info:
Sinusbot Version: SinusBot 1.0.0-beta.10-202ee4d
Teamspeak Client Version: 3.3.2 (25-8-2019)
Teamspeak Server Version: 3.11.0 (13.01.2020)
Windows Versiom: Windows Server 2016 Standard 64-bit
Hardware Specs: VPS, 2GB Ram, Processor Intel(R) Xeon(R) CPU E5-2680 v3 @ 2.50 GHz 2.50 GHz
Scripts: OKlib, One of them only, Server Join Alert, adminStaffStatus, League Of Legends Rankify, Welcome!

TS3Path = "D:\\SinusBot\\TeamSpeak 3 Client\\ts3client_win64.exe"
ListenHost = "0.0.0.0"
DataDir = "D:\\SinusBot\\data\\"
ListenPort = 8087
LocalPlayback = false
EnableLocalFS = false
MaxBulkOperations = 300
LogLevel = 10
EnableProfiler = false
YoutubeDLPath = ""
EnableDebugConsole = false
EnableInternalCommands = false
AllowStreamPush = false
UploadLimit = 83886080
RunAsUser = 0
RunAsGroup = 0
ExternalFileBase = ""
InstanceActionLimit = 6
UseSSL = false
SSLKeyFile = ""
SSLCertFile = ""
Hostname = ""
HostnameMask = ""
SampleInterval = 60
StartVNC = false
EnableWebStream = false
LogFile = ""
LicenseKey = "HIDDEN"
IsProxied = false
DenyStreamURLs = []
Pragma = 0
UserAgent = ""

[YoutubeDL]
BufferSize = 524288
MaxDownloadSize = 419430400
MaxDownloadRate = 104857600
MaxSimultaneousChunkDownloads = 6
CacheStreamed = false
TimeoutSingleDownloader = 0
TimeoutMultiDownloader = 0
ChunkSize = 3145728

[TS3]
AvatarMaxWidth = 0
AvatarMaxHeight = 0
AllowGIF = false

[StreamRewrites]

[Scripts]
Debug = false
AllowReload = false
EnableTimer = false
DisableLegacyEvents = false
DevMode = false
ScriptTimeout = 5

[Themes]
Default = ""

[SpeechRecognition]
Enable = false

[FFmpeg]
UserAgent = "SinusBot (1.0.0-beta.10-202ee4d)"
WaitTime = 0

[DAV]
Enable = false

[XServer]
Delay = 0
Debug = false

[SHMem]
Enable = false
Size = 0
Delay = 0
Interval = 0

[RadioStations]
URL = ""
UpdateInterval = 0

[TTS]
Enabled = false

2020-02-08T10:53:35+01:00 LOGIN [admin] OK
2020-02-08T10:53:19+01:00 Loading instance://c5da5e0e-adb2-46c0-b00e-d103f72b364e
2020-02-08T10:53:18+01:00 Loading instance://884c7395-dbcc-4256-bcf7-4a2b9afa5927
2020-02-08T10:53:18+01:00 Loading instances
 
Last edited:

Multivitamin

Well-Known Member
Tier III
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
Since beta.5 (i guess?) commands have been moved to seperate scritps, you need the default installed command.js and sinusbot-command.js, you probably have deleted those files after updating the bot
 

Similar threads

Top