• If you need help or want to discuss things, you now can also join us on our Discord Server!

Sinusbot access problem

Hello

Sometimes I can't access the sinusbot Web panel does not have access. I have access to the panel when I add the 2.ip address to the server (Access to 2 ip addresses) Then it goes again access. Is there a user experiencing such a problem? It's impossible for my ip address to be on the blacklist Because I have access to 2 ip addresses to server when I define additional ip
 

TwentyFour

BinusSot Junkie
V.I.P.
Contributor
Insider
You are probably connecting to the wrong IP/port then. Depending on your setup, you have to open or forward the port, you stated in your config (8087 per default), to access the web-interface properly.
I don't get your point with blacklisting though.
 
You are probably connecting to the wrong IP/port then. Depending on your setup, you have to open or forward the port, you stated in your config (8087 per default), to access the web-interface properly.
I don't get your point with blacklisting though.
It would not be wrong I was always connected
 

Multivitamin

Well-Known Member
Tier III
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
Please provide more infos:

is your server reachable at this time?
is the sinusbot up at this point?
does your pc has a working internet connection?
do you get any response from the sinusbot process?
check with curl if you have access locally to the sinusbot interface
check if you use a proxy that the proxy is reachable
provide logs
 
2019-05-06T14:43:54+03:00 TS/ERR 3329 e'connection failed, you are banned' x'flood prevention, please try again later' r''

What is this error ?
 

TwentyFour

BinusSot Junkie
V.I.P.
Contributor
Insider
Your bot triggers Teamspeak's flood prevention. Be sure to put your bot's IP on your TS-Server's whitelist query_ip_whitelist.txt
Wouldn't be to shabby to ensure, that your bot is also having the TS permisson b_client_ignore_antiflood
 

Multivitamin

Well-Known Member
Tier III
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
Be sure to put your bot's IP on your TS-Server's whitelist query_ip_whitelist.txt
This is actually not necessary for normal Clients it only affects the query interface default via port 10011, Sinusbot itself does not use any query

But the other permission as already mentioned (b_client_ignore_antiflood ) should fix it
 

TwentyFour

BinusSot Junkie
V.I.P.
Contributor
Insider
Make sure the bot can reach the SinusBot website, then it should work.

Could also be that your IP was banned due to abusing of the licence system. In that case contact @mxschmitt with your IP, so he can check.
 
Last edited:

TwentyFour

BinusSot Junkie
V.I.P.
Contributor
Insider
how can I see my Sinusbot IP cuz I just crashed my whole server with adding the bots id to the whitelist file.
Depends on which OS you're running the bot. The IP of your server, can be determined with hostname -I for example on linux.
 

Luca0408

Member
ok, I got everything but now the sinusbot wont start:




019-08-29T21:24:29+02:00 closing channels
2019-08-29T21:24:28+02:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019-08-29T21:24:28+02:00 Closed.
2019-08-29T21:24:28+02:00 TS>
2019-08-29T21:24:28+02:00 TS>Available platform plugins are: xcb.
2019-08-29T21:24:28+02:00 TS>
2019-08-29T21:24:28+02:00 TS>This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
2019-08-29T21:24:28+02:00 TS>qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
2019-08-29T21:24:28+02:00 TS>qt.qpa.xcb: could not connect to display unix/:40.0
2019-08-29T21:24:28+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2019-08-29T21:24:28+02:00 Starting instance ts3server://127.0.0.1?port=9987&nickname=grthgfbn&password=&channel=&channelpassword=
2019-08-29T21:24:28+02:00 About to run.
2019-08-29T21:24:28+02:00 Prespawn.
2019-08-29T21:24:16+02:00 Storing configuration.
2019-08-29T21:23:58+02:00 closing channels
2019-08-29T21:23:57+02:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019-08-29T21:23:57+02:00 Closed.
2019-08-29T21:23:57+02:00 TS>
2019-08-29T21:23:57+02:00 TS>Available platform plugins are: xcb.
2019-08-29T21:23:57+02:00 TS>
2019-08-29T21:23:57+02:00 TS>This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
2019-08-29T21:23:57+02:00 TS>qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
2019-08-29T21:23:57+02:00 TS>qt.qpa.xcb: could not connect to display unix/:40.0
2019-08-29T21:23:57+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2019-08-29T21:23:57+02:00 Starting instance ts3server://127.0.0.1?port=9987&nickname=grthgfbn&password=&channel=&channelpassword=
2019-08-29T21:23:57+02:00 About to run.
2019-08-29T21:23:57+02:00 Prespawn.
2019-08-29T21:23:51+02:00 BOT-CONFIG [admin] HOST CHANPW CHAN ANNOUNCE DESCRIPTION ANNOUNCESTR TTSURL CC OK
2019-08-29T21:23:16+02:00 Storing configuration.
2019-08-29T21:23:11+02:00 closing channels
2019-08-29T21:23:10+02:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019-08-29T21:23:10+02:00 Closed.
2019-08-29T21:23:10+02:00 TS>
2019-08-29T21:23:10+02:00 TS>Available platform plugins are: xcb.
2019-08-29T21:23:10+02:00 TS>
2019-08-29T21:23:10+02:00 TS>This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
2019-08-29T21:23:10+02:00 TS>qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
2019-08-29T21:23:10+02:00 TS>qt.qpa.xcb: could not connect to display unix/:40.0
2019-08-29T21:23:10+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2019-08-29T21:23:10+02:00 Starting instance ts3server://thefreeze.de?port=9987&nickname=grthgfbn&password=&channel=&channelpassword=
2019-08-29T21:23:10+02:00 About to run.
2019-08-29T21:23:10+02:00 Prespawn.
2019-08-29T21:23:08+02:00 BOT-CONFIG [admin] NICK NAME CHANPW CHAN ANNOUNCE DESCRIPTION ANNOUNCESTR TTSURL CC OK
2019-08-29T21:22:46+02:00 Storing configuration.
2019-08-29T21:22:39+02:00 closing channels
2019-08-29T21:22:39+02:00 eof from voice
2019-08-29T21:22:38+02:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019-08-29T21:22:38+02:00 Closed.
2019-08-29T21:22:38+02:00 TS>
2019-08-29T21:22:38+02:00 TS>Available platform plugins are: xcb.
2019-08-29T21:22:38+02:00 TS>
2019-08-29T21:22:38+02:00 TS>This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
2019-08-29T21:22:38+02:00 TS>qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
2019-08-29T21:22:38+02:00 TS>qt.qpa.xcb: could not connect to display unix/:40.0
2019-08-29T21:22:38+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2019-08-29T21:22:37+02:00 Starting instance ts3server://thefreeze.de?port=9987&nickname=%E2%9C%96%20Support%20%C2%BB2%20Bot%20%E2%9C%96%202&password=&channel=&channelpassword=
2019-08-29T21:22:37+02:00 About to run.
2019-08-29T21:22:37+02:00 Prespawn.
2019-08-29T21:22:36+02:00 BOT-CONFIG [admin] CHANPW CHAN ANNOUNCE DESCRIPTION ANNOUNCESTR TTSURL CC IDENTITY OK
2019-08-29T21:21:46+02:00 Storing configuration.
2019-08-29T21:21:18+02:00 closing channels
2019-08-29T21:21:17+02:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019-08-29T21:21:17+02:00 Closed.
2019-08-29T21:21:17+02:00 TS>
2019-08-29T21:21:17+02:00 TS>Available platform plugins are: xcb.
2019-08-29T21:21:17+02:00 TS>
2019-08-29T21:21:17+02:00 TS>This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
2019-08-29T21:21:17+02:00 TS>qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
2019-08-29T21:21:17+02:00 TS>qt.qpa.xcb: could not connect to display unix/:40.0
2019-08-29T21:21:17+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2019-08-29T21:21:17+02:00 Starting instance ts3server://thefreeze.de?port=9987&nickname=%E2%9C%96%20Support%20%C2%BB2%20Bot%20%E2%9C%96%202&password=&channel=&channelpassword=
2019-08-29T21:21:17+02:00 About to run.
2019-08-29T21:21:17+02:00 Prespawn.
2019-08-29T21:21:16+02:00 Storing configuration.
2019-08-29T21:21:14+02:00 BOT-CONFIG [admin] CHANPW CHAN ANNOUNCE DESCRIPTION ANNOUNCESTR TTSURL CC OK
2019-08-29T21:21:14+02:00 Invalid identity, ignoring (V).
2019-08-29T21:20:59+02:00 closing channels
2019-08-29T21:20:58+02:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019-08-29T21:20:58+02:00 Closed.
2019-08-29T21:20:58+02:00 TS>
2019-08-29T21:20:58+02:00 TS>Available platform plugins are: xcb.
2019-08-29T21:20:58+02:00 TS>
2019-08-29T21:20:58+02:00 TS>This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
2019-08-29T21:20:58+02:00 TS>qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
2019-08-29T21:20:58+02:00 TS>qt.qpa.xcb: could not connect to display unix/:40.0
2019-08-29T21:20:58+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
2019-08-29T21:20:58+02:00 Starting instance ts3server://thefreeze.de?port=9987&nickname=%E2%9C%96%20Support%20%C2%BB2%20Bot%20%E2%9C%96%202&password=&channel=&channelpassword=
2019-08-29T21:20:58+02:00 About to run.
2019-08-29T21:20:58+02:00 Prespawn.
2019-08-29T21:20:46+02:00 Storing configuration.
2019-08-29T21:20:30+02:00 closing channels
2019-08-29T21:20:29+02:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019-08-29T21:20:29+02:00 Closed.
2019-08-29T21:20:29+02:00 TS>
2019-08-29T21:20:29+02:00 TS>Available platform plugins are: xcb.
2019-08-29T21:20:29+02:00 TS>
2019-08-29T21:20:29+02:00 TS>This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
2019-08-29T21:20:29+02:00 TS>qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
2019-08-29T21:20:29+02:00 TS>qt.qpa.xcb: could not connect to display unix/:40.0
2019-08-29T21:20:29+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
 

Luca0408

Member
I installed it from my root server with a script. but how can I change the log level or how can I fix it? Sry but Im new to this
 

TwentyFour

BinusSot Junkie
V.I.P.
Contributor
Insider
Bot anhalten. In der config.ini den Punkt LogLevel = 10 setzen. Danach wieder starten.

Außerdem kannst du unter obigem Link das Diagnose-Skript laufen lassen, das sammelt dir ohne großes Zutun und Rückfragen fast alle wichtigen Infos, damit man dir helfen kann.
Dessen Ausgabe und die des Instance-Logs, sind unabdingbar um dem Problem auf die Schliche zu kommen.
 

Similar threads

Top