• If you need help or want to discuss things, you now can also join us on our Discord Server!

Sinusbot (Docker) won't connect to Teamspeak (Docker)

Eomer

Donor
is awesome!
Hey,

im running Sinusbot in a docker Container and Teamspeak in another Docker container and im trying to connect to the Teamspeak Server which doesn't work.

I did try different IP-Addresses like 127.0.0.1 or 0.0.0.0 or the external IP.

Here's the log. Any idea what could be the issue here?

2020-03-05T18:08:28+01:00 TSClient quit.
2020-03-05T18:08:27+01:00 New connection status 0; Error 1797
2020-03-05T18:08:27+01:00 The bot could not connect. This might have several reasons: the server doesn't exist at that address, the server password is wrong, the default channel doesn't exist, the bot has been banned, the server is an illegal installation, the password is wrong, the security level of your identity is too low, the nickname is too short or too long or the server does not allow the version of the client you are using. See our Wiki / Forums for more help.
2020-03-05T18:08:27+01:00 TS |INFO |ClientUI |1 |Failed to connect to server, want autoreconnect = 0
2020-03-05T18:08:27+01:00 TS |INFO |ClientUI |1 |Connect status: Disconnected
2020-03-05T18:08:22+01:00 TS |INFO |Integrations | |Requesting integration icon download from https://ts3services.teamspeak.com/integration_icons/twitch/twitch.svg
2020-03-05T18:08:22+01:00 TS |INFO | | |Statistics report: Setting next report date to: Mon Mar 30 17:08:22 2020
2020-03-05T18:08:22+01:00 TS |INFO | | |Statistics report: First run, report later in 1-30 days
2020-03-05T18:08:22+01:00 TS |INFO |ClientUI | |Last update check was: Sat Jan 1 00:00:01 2022
2020-03-05T18:08:22+01:00 TS |INFO |Bookmarks | |Collecting autoconnect bookmarks
2020-03-05T18:08:22+01:00 TS |DEVELOP |PktHandler | |Puzzle solve time: 3
2020-03-05T18:08:22+01:00 New connection status 1; Error 0
2020-03-05T18:08:22+01:00 TS |INFO |ClientUI |1 |Connect status: Connecting
2020-03-05T18:08:22+01:00 TS |INFO |ClientUI |1 |Initiating connection: 93.159.250.234:9987
2020-03-05T18:08:22+01:00 TS |INFO |ClientUI |1 |Connect to server: 93.159.250.234
2020-03-05T18:08:22+01:00 TS |INFO |ClientUI | |ts3server: 93.159.250.234?port=9987&nickname=SinusBot&password=&channel=&channelpassword=
2020-03-05T18:08:21+01:00 TS |INFO |ClientUI | |Using configuration location: /opt/sinusbot/data/ts3/868011e2-0b10-4585-b61a-c3db1eec60a2/052d68e1-da74-ab75-d17c-e364d7335e9d/settings.db
2020-03-05T18:08:21+01:00 TS |INFO |ClientUI | |Qt version: 5.12.1
2020-03-05T18:08:21+01:00 TS |INFO |ClientUI | |Failed to init text to speech engine
2020-03-05T18:08:21+01:00 TS |INFO | | |*** Time [INIT]: 196
2020-03-05T18:08:21+01:00 TS |INFO | | |*** Time [MAINWINDOW]: 195
2020-03-05T18:08:21+01:00 TS |INFO |Plugins | |Loading plugin: libsoundbot_plugin.so
2020-03-05T18:08:21+01:00 TS |INFO |Addons | |Checking for addon updates...
2020-03-05T18:08:21+01:00 TS |INFO | | |*** Time [ICONMANGER]: 108
2020-03-05T18:08:21+01:00 TS |INFO | | |successfully downloaded revocation list for accounting
2020-03-05T18:08:21+01:00 TS |INFO | | |successfully downloaded revocation list for myteamspeak id
2020-03-05T18:08:21+01:00 TS |ERROR |RevocationListCache| |Failed to import revocation list from cache
2020-03-05T18:08:21+01:00 TS |INFO |ClientUI | |Unable to create an Open GL context.
2020-03-05T18:08:21+01:00 TS |ERROR |SoundBckndIntf| |libpulse.so.0: cannot open shared object file: No such file or directory
2020-03-05T18:08:21+01:00 TS |INFO | | |Using hardware aes
2020-03-05T18:08:21+01:00 TS |INFO | | |SystemInformation: Linux 4.15.0-88-generic #88-Ubuntu SMP Tue Feb 11 20:11:34 UTC 2020 x86_64 Binary: 64bit
2020-03-05T18:08:21+01:00 TS |INFO | | |TeamSpeak Client 3.3.2 (2019-08-25 21:13:34)
2020-03-05T18:08:21+01:00 Starting instance ts3server://93.159.250.234?port=9987&nickname=SinusBot&password=&channel=&channelpassword=
2020-03-05T18:08:21+01:00 Could not insert into Profiles-Tableno such table: Profiles
2020-03-05T18:08:21+01:00 Could not delete from Profilesno such table: Profiles
2020-03-05T18:08:21+01:00 Could not insert into Profiles-Tableno such table: Profiles
2020-03-05T18:08:21+01:00 Could not delete from Profilesno such table: Profiles
2020-03-05T18:08:21+01:00 Could not insert into Profiles-Tableno such table: Profiles
2020-03-05T18:08:21+01:00 Could not delete from Profilesno such table: Profiles
2020-03-05T18:08:21+01:00 Could not insert into Profiles-Tableno such table: Profiles
2020-03-05T18:08:21+01:00 Could not delete from Profilesno such table: Profiles
2020-03-05T18:08:21+01:00 Could not insert into Profiles-Tableno such table: Profiles
2020-03-05T18:08:21+01:00 Could not delete from Profilesno such table: Profiles
2020-03-05T18:08:19+01:00 BOT-CONFIG [admin] HOST PORT CHANPW CHAN ANNOUNCE DESCRIPTION ANNOUNCESTR TTSURL CC OK
 

Eomer

Donor
is awesome!
Okay, i tried the ip address that docker gave the server:

172.17.0.4

That worked. I'll leave that here in case everyone faces the same problem.
 
Last edited:
Top