• If you need help or want to discuss things, you now can also join us on our Discord Server!
SinusBot for Windows (64bit)

SinusBot for Windows (64bit) 1.0.0-beta.3

No permission to download
Status
Not open for further replies.

flyth

is reticulating splines
Staff member
Developer
Contributor
flyth submitted a new resource:

SinusBot Beta - Preparing for 1.0

Finally, a new version for Windows has arrived!

There have been MANY changes since the last version, so I won't name them all. But now this version is on par again with the Linux release (a bit ahead even).

I hope you guys enjoy the many things that have been introduced to the Linux version in the past year, the hopefully increased stability, the hopefully less lagging and much more. It would be really great, if you could leave some feedback on how it worked out for you.

Thanks to all the...
Read more about this resource...
 

kanalumaddela

Insider
Insider
I'm not supposed to jealous of the windows version, but I am. :eek:

What I love
  • Ability to configure scripts without having to enable, configure, save, disable them.
  • Ability to download and install scripts without having to restart the bot (<--best feature)
  • Launching the interface from a shortcut and not having to enter a username/password on the first startup (or anytime for that matter when you use the shortcut)
What I don't love
  • It's not on linux yet hehe
  • When I try to access the web panel from another computer locally. It simply does not work and it might just be the computer I'm using or something else.
 

mxschmitt

Looking for another possibility to make sports.
Staff member
is awesome!
V.I.P.
Contributor
Insider
It's not on linux yet hehe
Will follow asap.
When I try to access the web panel from another computer locally. It simply does not work and it might just be the computer I'm using or something else.
For that you need to have the correct IP in your local network. Definitively no sinusbot issue. ;)
 

flyth

is reticulating splines
Staff member
Developer
Contributor
Thanks for the feedback! ;) Yup, those features (apart from the tray icon of course) will be coming to the next Linux version as well.
 

Lewey

Member
for some reason with the beta i get this when trying to launch an instance

2016-08-09T20:55:47+00:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2016-08-09T20:55:47+00:00 Error spawning instancefork/exec C:\SinusBot\TeamSpeak 3 Client\ts3client_win64.exe: The requested operation requires elevation.
2016-08-09T20:55:47+00:00 Starting instance ts3server://127.0.0.1?port=9987&nickname=TS3SB-Demobot&password=&cid=1&channelpassword=
2016-08-09T20:55:40+00:00 Initialization complete
 

flyth

is reticulating splines
Staff member
Developer
Contributor
for some reason with the beta i get this when trying to launch an instance

2016-08-09T20:55:47+00:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2016-08-09T20:55:47+00:00 Error spawning instancefork/exec C:\SinusBot\TeamSpeak 3 Client\ts3client_win64.exe: The requested operation requires elevation.
2016-08-09T20:55:47+00:00 Starting instance ts3server://127.0.0.1?port=9987&nickname=TS3SB-Demobot&password=&cid=1&channelpassword=
2016-08-09T20:55:40+00:00 Initialization complete
That's got nothing to do with the beta - I couldn't reproduce that, yet and I don't know a solution to it. Should anyone else do, I'd be really glad if they could comment on this.
 

Lewey

Member
That's got nothing to do with the beta - I couldn't reproduce that, yet and I don't know a solution to it. Should anyone else do, I'd be really glad if they could comment on this.
i found the problem for some reason windows was trying to run in compatibility mode, i have since changed that and works fine
 

flyth

is reticulating splines
Staff member
Developer
Contributor
i found the problem for some reason windows was trying to run in compatibility mode, i have since changed that and works fine
Great, thank you very much!
 

iCreeDx

New Member
Error spawning instancefork/exec C:\SinusBot\TeamSpeak 3 Client\ts3client_win64.exe: The requested operation requires elevation.
WHY?
 

Xuxe

Containerholic
Staff member
is awesome!
V.I.P.
Contributor
Insider
Error spawning instancefork/exec C:\SinusBot\TeamSpeak 3 Client\ts3client_win64.exe: The requested operation requires elevation.
Try Administrator, and make sure the bot is not running in Windows compatibility mode.
 

wazer

Member
Hello just stopping by to say, i just found out about this wonderfull tool, i have previousely used your soundboard to play music on my ts, but recently windows 10 update redstone 1 broke it for me. However I feature I was spooked about was the under scripts, there's a script called sound 0.1, I would really like to have this working for stream and files located on the machine, It does not seems to work, neither the playback speed or compression?

This is the one I'm talking about.

http://image.prntscr.com/image/660717b9d19e4b5385394977369c42e9.png

Also There's a welcome script also created by the owner, i think there's issues with the Poke option, does not seem to do anything when poke has been selected, how ever private message work.

http://image.prntscr.com/image/26a42ca6af5c41ca997cb068cd7883cb.png

Once again thanks for making this wonderfull tool and scripts available for us.

I'm using this currently beta for windows 10
 

kanalumaddela

Insider
Insider
Also There's a welcome script also created by the owner, i think there's issues with the Poke option, does not seem to do anything when poke has been selected, how ever private message work.

http://image.prntscr.com/image/26a42ca6af5c41ca997cb068cd7883cb.png
Does the bot have the permission to poke people? Does it have b_client_ignore_antiflood ? I haven't used that script for a while mainly because I'm not fond of receiving the same message everytime I connect to the server.
 

wazer

Member
Does the bot have the permission to poke people? Does it have b_client_ignore_antiflood ? I haven't used that script for a while mainly because I'm not fond of receiving the same message everytime I connect to the server.
The bot has FULLY and highest admin right.
 

wazer

Member
Then I suggest setting LogLevel = 10 in your config.ini, restart the bot and see what happens and look for any errors and paste them here (in a spoiler as code preferably).

2016-08-18T14:31:07+02:00 Storing configuration.
2016-08-18T14:30:51+02:00 Found Callback PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:43/DESC
2016-08-18T14:30:51+02:00 Awaiting Callback (1): PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:43/DESC
2016-08-18T14:30:50+02:00 Found Callback PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:42/DESC
2016-08-18T14:30:50+02:00 Awaiting Callback (1): PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:42/DESC
2016-08-18T14:30:49+02:00 Could not request updateNick: HTTP returned an error: Timeout while waiting for callback; Code: 500; Message: Timeout while waiting for callback
2016-08-18T14:30:46+02:00 SAMPLEX 1920 60
2016-08-18T14:30:42+02:00 SAMPLEX 3840 60
2016-08-18T14:30:42+02:00 Deleting channel
2016-08-18T14:30:42+02:00 Found Callback PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:35/DESC
2016-08-18T14:30:42+02:00 Awaiting Callback (1): PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:35/DESC
2016-08-18T14:30:42+02:00 New channel
2016-08-18T14:30:42+02:00 Found Callback PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:32/DESC
2016-08-18T14:30:42+02:00 Awaiting Callback (1): PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:32/DESC
2016-08-18T14:30:41+02:00 Found Callback PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:26/DESC
2016-08-18T14:30:41+02:00 Awaiting Callback (1): PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:26/DESC
2016-08-18T14:30:40+02:00 Found Callback PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:22/DESC
2016-08-18T14:30:40+02:00 Awaiting Callback (1): PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:22/DESC
2016-08-18T14:30:40+02:00 Could not update nick: nickname is already in use
2016-08-18T14:30:40+02:00 nickname is already in use
2016-08-18T14:30:40+02:00 Setting new nick failed
2016-08-18T14:30:40+02:00 TS/ERR 513 e'nickname is already in use' x'' r'PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:21/NICK'
2016-08-18T14:30:40+02:00 Found Callback PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:21/NICK
2016-08-18T14:30:40+02:00 Found Callback PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:20/DESC
2016-08-18T14:30:40+02:00 Awaiting Callback (1): PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:21/NICK
2016-08-18T14:30:40+02:00 Awaiting Callback (1): PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:20/DESC
2016-08-18T14:30:40+02:00 TS/ERR 2564 e'access to default group is forbidden' x'' r'PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:19/GCLL'
2016-08-18T14:30:39+02:00 Could not poke: invalid parameter size
2016-08-18T14:30:39+02:00 TS/ERR 1541 e'invalid parameter size' x'' r'PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:8/POKE'
2016-08-18T14:30:39+02:00 Found Callback PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:8/POKE
2016-08-18T14:30:39+02:00 New connection status 4; Error 0
2016-08-18T14:30:39+02:00 Awaiting Callback (1): PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:8/POKE
2016-08-18T14:30:39+02:00 wazer joined the channel
2016-08-18T14:30:39+02:00 New connection status 3; Error 0
2016-08-18T14:30:39+02:00 New connection status 2; Error 0
2016-08-18T14:30:39+02:00 New connection status 1; Error 0
2016-08-18T14:30:39+02:00 New channel
2016-08-18T14:30:39+02:00 Could not send description command: HTTP returned an error: Error; Code: 500; Message: Error
2016-08-18T14:30:39+02:00 Error on call #5
2016-08-18T14:30:39+02:00 TS/ERR 1794 e'not connected' r'DESC'
2016-08-18T14:30:39+02:00 Awaiting Callback (1): PR:{49665aee-83e9-4f45-97fa-b0a9824740ad}:2/NICK
2016-08-18T14:30:39+02:00 Could not send description command: HTTP returned an error: Error; Code: 500; Message: Error
2016-08-18T14:30:39+02:00 Error on call #5
2016-08-18T14:30:39+02:00 TS/ERR 1794 e'not connected' r'DESC'
2016-08-18T14:30:38+02:00 TS>DUMP defined! Dumpdir is: C:\SinusBot\data\/ts3/0c551956-b152-41a1-9f31-e593298d14fc/655bd411-fffc-419f-8048-225ebf143efe/\crashdumps
2016-08-18T14:30:38+02:00 TS>Crashdump ENABLED, directory is: C:\SinusBot\data\/ts3/0c551956-b152-41a1-9f31-e593298d14fc/655bd411-fffc-419f-8048-225ebf143efe/\crashdumps
2016-08-18T14:30:38+02:00 Starting instance ts3server://127.0.0.1?port=7777&nickname=%E2%96%BA%20Musik%20Talentet&password=&cid=113&channelpassword=
2016-08-18T14:30:38+02:00 Could not insert into Notifications-Tableno such table: Notifications
2016-08-18T14:30:38+02:00 Could not delete from Notificationsno such table: Notifications
2016-08-18T14:30:38+02:00 Could not insert into Notifications-Tableno such table: Notifications
2016-08-18T14:30:38+02:00 Could not delete from Notificationsno such table: Notifications
2016-08-18T14:30:38+02:00 < PrepareListener
2016-08-18T14:30:38+02:00 > PrepareListener
2016-08-18T14:30:38+02:00 Auto-Playing last track
2016-08-18T14:30:38+02:00 Last track was ecb35baa-7f47-4720-b18f-b2882f96771e, will auto-play soon
2016-08-18T14:30:38+02:00 Auto-Starting 0c551956-b152-41a1-9f31-e593298d14fc/655bd411-fffc-419f-8048-225ebf143efe in 500 ms...
2016-08-18T14:30:38+02:00 Initialization complete
2016-08-18T14:30:38+02:00 Loading script norecording
2016-08-18T14:30:38+02:00 Loading script aloneMode
2016-08-18T14:30:38+02:00 [BackToDefault] Back To Default initialized...
2016-08-18T14:30:38+02:00 Loading script BackToDefault
2016-08-18T14:30:38+02:00 Loading script Advanced Display Playback Information
2016-08-18T14:30:38+02:00 Loading script welcometext
2016-08-18T14:30:38+02:00 Loading script sound
2016-08-18T14:30:38+02:00 Loading script Reconnect

What I could see in the log that came closest to the error was

2016-08-18T14:30:39+02:00 Could not poke: invalid parameter size

Then I quickly checked the length of my poke size "if it could be that"

Teamspeak 3 allow max limit of 100 chars when poking, mine is on 99.

I suggest adding a limit so you cannot add more than 100 chars+spaces, in the welcome options for poke, just to be sure?. However since I'm under 100 chars and still not working something else must be broken.

Hi %n I'm a music bot. Listen to what I have to offer, or right click on me > change volume or mute


I did some more test just for the fun of it, it seems that the bot only will allow 98 max chars+spaces. However Ts3 default allow 100 chars. So it is indeed working but only with 98 oO ;).


Now this is solved how can i test the playback speed and compression of sounds with the sound 0.1 script?
 
Last edited:

Katzen48

Insider
Insider
Bis jetzt gibt es keine Probleme mit dem Bot. Es taucht lediglich eineFehlermeldung im Log auf.
Momentan verwenden wir das Script "Covatar".

Fehlermeldung:

"Could not send description command: HTTP returned an error: Timeout while waiting for callback; Code: 500; Message: Timeout while waiting for callback"

 

kanalumaddela

Insider
Insider
What I could see in the log that came closest to the error was

2016-08-18T14:30:39+02:00 Could not poke: invalid parameter size

Then I quickly checked the length of my poke size "if it could be that"

Teamspeak 3 allow max limit of 100 chars when poking, mine is on 99.

I suggest adding a limit so you cannot add more than 100 chars+spaces, in the welcome options for poke, just to be sure?. However since I'm under 100 chars and still not working something else must be broken.

Hi %n I'm a music bot. Listen to what I have to offer, or right click on me > change volume or mute


I did some more test just for the fun of it, it seems that the bot only will allow 98 max chars+spaces. However Ts3 default allow 100 chars. So it is indeed working but only with 98 oO ;).
If the max amount of characters when poking is 100 and you have 99, then it will always never work because ℅n represents the client' name when they connect, so you should really shorten that message down or just have the bot PM instead.
Now this is solved how can i test the playback speed and compression of sounds with the sound 0.1 script?
Just tested and nothing happens when changing the compression level or speed. I also never found "sinusbot.setFilter" in the scripting page under Help.
 

wazer

Member
If the max amount of characters when poking is 100 and you have 99, then it will always never work because ℅n represents the client' name when they connect, so you should really shorten that message down or just have the bot PM instead.

Just tested and nothing happens when changing the compression level or speed. I also never found "sinusbot.setFilter" in the scripting page under Help.
Lets hope he will implement it again, could really use it.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
R Windows Beta 11
S Windows Beta 2

Similar threads

Top