• TeamSpeak has reported a vulnerability in it's client that can potentially lead to RCE. A new version has been released that fixes it. So please update the client in your bot installation as soon as possible as well. Click here for more information.
  • If you need help or want to discuss things, you now can also join us on our Discord Server!

Sinusbot Not Support Any more Centos 7 ?

avadon

Member
I have try install it manual and with script in Centos 7 and can not because it ask for GLIBCXX_3.4.20 and CXXABI_1.3.8 and with the installer i have that error:

Please wait... This will take some seconds!
SinusBot could not start! Starting it directly. Look for errors!
/opt/sinusbot/sinusbot: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/sinusbot/sinusbot)
/opt/sinusbot/sinusbot: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/sinusbot/sinusbot)
Command which failed was: " su -c "$LOCATION/sinusbot" $SINUSBOTUSER". Please try to execute it manually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script. Line 1097.

Anysolution? or Sinusbot not support/run anymore to Centos 7 ?

Ty for your support
 

TwentyFour

Donor
is awesome!
/opt/sinusbot/sinusbot: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/sinusbot/sinusbot)
/opt/sinusbot/sinusbot: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/sinusbot/sinusbot)
Command which failed was: " su -c "$LOCATION/sinusbot" $SINUSBOTUSER". Please try to execute it manually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script. Line 1097.
There shouldn't be any reason for sinusbot not to run on CentOS 7. This doesn't look like a problem of the sinusbot itself, rather some dependencies of the installer script not met on your system. And that leads to an error and an unsuccessful finish of the script.
You should post that in the Discussion thread of the script to get some troubleshooting, if you want to use the installer.

But you said, you tried installing the bot manually, as explained here? At which point didn't you have success? (Post your console In- & Output)
 
Last edited:

avadon

Member
yes hae the same error when i try to run the ./sinusbot he ask for GLIBCXX_3.4.20' that is not on centos7 so i have to run from backup old sinusbot otherwise is not run :( and ofcourse is not playing any script
 

TwentyFour

Donor
is awesome!
Sounds like your OS is missing some packages/updates then!
Please read this and post the result. Especially the results of the diagnositic script would be really needed.

But for now you could use yum check-update and post the console output.
 

flyth

is reticulating splines
Staff member
Developer
Contributor
CentOS is sadly running with pretty old libs - in this case it's GCC 4.8.5 from 2015, while the newer bot version requires at least GCC 4.9 (current version is 8.3 btw).
I'll try to lower the requirements in the coming weeks, but I can't promise anything. You could try to manually get newer glibc / libstdc++ libs, I think other people from our community have done it successfully before.
 

avadon

Member
CentOS is sadly running with pretty old libs - in this case it's GCC 4.8.5 from 2015, while the newer bot version requires at least GCC 4.9 (current version is 8.3 btw).
I'll try to lower the requirements in the coming weeks, but I can't promise anything. You could try to manually get newer glibc / libstdc++ libs, I think other people from our community have done it successfully before.
I have try from some sites / forum some methods to Update to NON suport Libstdc to Centos7 but all was catastrophic in the end


Sounds like your OS is missing some packages/updates then!
Please read this and post the result. Especially the results of the diagnositic script would be really needed.

But for now you could use yum check-update and post the console output.
My OS is totaly full updated allready have speak with Centos, and they answer it was "The will never support more from GLIBCXX3.4.19" and they can not do nothing. in some other site i search some ppl they manage to update the libstdc++ to support 3.4.20+ BUT in end everyone they just destroy the server files because is imposible to run after the centos and they just reinstall all the server

The only Solution they say from Centos is to Run aps they support Centos and Max GLIBCXX3.4.19 otherwise to go to other IOS and can not go to other IOS because the most vPS they run Centos 7

So the only solution for now is to remain with totaly nonupdate sinusbot, and wait from [U]flyth[/U] next update maybe they will support Centos 7 in new version because the current version of Sinusbot is totaly NOT for Centos 7

Ty for your support and hope soon news really i ws love sinusbot and not want to leave it :(
 

flyth

is reticulating splines
Staff member
Developer
Contributor
Could you please try again with this version? This was a tough issue, but I hope that this will make the bot work on "older" systems again.
 

Similar threads

Top