• If you need help or want to discuss things, you now can also join us on our Discord Server!

A manual update is required

#25
I have problem with SinusBot.
I installed this with Installer Script and Manually but still not working. When I try to start the bot (by ./sinusbot) i got message: A manual update is required.
TS3 version: 3.1.8
Host: nazwa.pl
Country: Poland
IP: I could send this by PM

Diagnostic log:
Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
 - Operating System: Ubuntu 16.04.4 LTS
 - Kernel: Linux 4.4.0-92-generic x86_64
 - Load Average: 0.01 0.02 0.00
 - Uptime: 17 days, 3 hours, 27 minutes, 41 seconds
 - OS x64 check: OK
 - OS Updates: 16 (updates available!)
 - OS Missing Packages: None
 - OS APT Last Update: 10.03.2018 16:40:49 CET +01:00:00
 - SHELL LOCALE LANG: en_US.UTF-8
 - Bot Start Script: not found
 - DNS resolution check: www.sinusbot.com resolved to 104.18.40.220 -> OK
 - HTTPS check with IPv4 mode: FAILED  [Failed establishing connection to www.sinusbot.com, CODE #403]
 - HTTPS check with IPv6 mode: IGNORE
 - CPU:
    Architecture:          x86_64
    CPU(s):                2
    Thread(s) per core:    1
    Core(s) per socket:    1
    Socket(s):             2
    Model name:            Common KVM processor
    CPU MHz:               2599.998
    Hypervisor vendor:     KVM
    Virtualization type:   full
 - RAM: 696.14 MB/3.85 GB in use (17%)
 - SWAP: 0 B/0 B in use (0%) (SWAP disabled)
 - DISK: 3.32 GB/45.06 GB in use (7%)
 - Package versions:
   + libglib: 2.48.2-0ubuntu1

BOT INFORMATION
 - Status: not running
 - Webinterface: port locally not reachable (Port: 8087)
 - Binary: /opt/ts3soundboard8087/sinusbot
 - Binary Info: MD5 Hash: 9e74167de6a4b9931e381cc86bf05b3e, Perms: 755, User: ts4friends
 - Version: 0.13.37-f7e9ece
 - TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: 26551adc40e47c6d5d02517b8575d375
   - TS3 Client: 26551adc40e47c6d5d02517b8575d375
 - Config:
   - LogLevel = 10 (debug log active)
   - TS3Path = /opt/ts3soundboard8087/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 (Version 3.1.6)
   - YoutubeDLPath = not set (does exist anyway, version: 2018.03.03)
 - Installed scripts: advertising.js; alonemode.js; bookmark.js; followme.js; norecording.js; rememberChannel.js; welcome.js

TIME INFORMATION
 - Time (local): 10.03.2018 17:12:42 CET +01:00:00
 - Time (remote): 10.03.2018 17:12:42 CET +01:00:00
 - Time (difference): 0 secs (Time diff less than 2 secs. Good.)
 - Timezone: Europe/Warsaw

OTHER INFORMATION
 - TeamSpeak 3 Version: 3.1.6
 - youtube-dl Version: 2018.03.03
 - DiagScript Version: 0.7.0
==========================================================
Config.ini

Code:
TS3Path = "/opt/ts3soundboard8087/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64"
ListenHost = "0.0.0.0"
DataDir = "/opt/ts3soundboard8087/data/"
ListenPort = 8087
LocalPlayback = false
EnableLocalFS = false
MaxBulkOperations = 300
LogLevel = 10
EnableProfiler = false
YoutubeDLPath = ""
EnableDebugConsole = false
UploadLimit = 83886080
RunAsUser = 0
RunAsGroup = 0
InstanceActionLimit = 6
UseSSL = false
SSLKeyFile = ""
SSLCertFile = ""
Hostname = ""
HostnameMask = ""
SampleInterval = 60
StartVNC = false
EnableWebStream = false
LogFile = ""
LicenseKey = "JzTnK42RkLhfSpIHhuiJnj/cBWhcA8k//DeCnL1oHAI="
IsProxied = false
DenyStreamURLs = []
Pragma = 0

[YoutubeDL]
  BufferSize = 524288
  MaxDownloadSize = 419430400
  MaxDownloadRate = 104857600
  MaxSimultaneousChunkDownloads = 1
  CacheStreamed = false
  TimeoutSingleDownloader = 0
  TimeoutMultiDownloader = 0
  ChunkSize = 5242880

[TS3]
  AvatarMaxWidth = 0
  AvatarMaxHeight = 0
  AllowGIF = false

[StreamRewrites]

[Scripts]
  AllowReload = false
  EnableTimer = false
  DisableLegacyEvents = false
  ScriptTimeout = 5

[Themes]
  Default = ""

[SpeechRecognition]
  Enable = false

[FFmpeg]
  UserAgent = "SinusBot (0.13.37-f7e9ece)"

[DAV]
  Enable = false

[XServer]
  Delay = 0
  Debug = false

[SHMem]
  Enable = false
  Size = 0
  Delay = 0
  Interval = 0

[RadioStations]
  URL = ""
  UpdateInterval = 0
 

flyth

is reticulating splines
Staff member
Developer
Contributor
#26
@all: Please contact your hoster so that they can figure out a solution with cloudflare, as I think there are more services affected by this. I will try to setup an override for a couple of days tomorrow, but that won't be a final solution.
 
#29
Code:
Witam,

dziękujemy za kontakt. Wkrótce udzielimy odpowiedzi w niniejszym temacie.


Pozdrawiam,
Krzysztof Śmigielski


Dział Obsługi Klienta
I wrote to nazwa.pl, this is the reply.
 
#30
I'll try to install sinusbot by installer script and manually. In every way i have a problem with download current sinusbot. In install with script i have this problem:

Error on line 770. Report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script.
Command which failed was: "su -c "wget -q https://www.sinusbot.com/dl/sinusbot.current.tar.bz2" $SINUSBOTUSER". Please try to execute it manually and attach the output to the bug report in the forum thread.

In install manually i saw this :

--2018-03-10 20:56:59-- https://www.sinusbot.com/dl/sinusbot.current.tar.bz2
Resolving www.sinusbot.com (www.sinusbot.com)... 104.18.40.220, 104.18.41.220
Connecting to www.sinusbot.com (www.sinusbot.com)|104.18.40.220|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2018-03-10 20:56:59 ERROR 403: Forbidden.

I'll try to install this on ubuntu 16.04 and debian 9 on VPS.
 
#31
Hello i have problem with download sinusbot i see
HTTP request sent, awaiting response... 403 Forbidden
2018-03-11 12:20:59 ERROR 403: Forbidden.

i try install on ubuntu 16.04 and debian
 
#32
Code:
Witam,

przekazaliśmy zapytanie do administratorów, skontaktujemy się ponownie jak otrzymamy informacje zwrotne.


Pozdrawiam,
Damian Kołacz
 

Similar threads