• If you need help or want to discuss things, you now can also join us on our Discord Server!

Solved Bot is not connecting to my teamspeak server.

Daddy_Ahex

Member
The bot is not connecting to my teamspeak server. I already reinstalled / deleted all files and it's still not working. Can someone who got some experience tell me what the problem is? Down here is the "Instanz-Log":

2018-04-22T20:03:54+02:00 TS |INFO |ClientUI |1 |Connect status: Disconnected
2018-04-22T20:03:54+02:00 New connection status 1; Error 0
2018-04-22T20:03:54+02:00 TS |INFO |ClientUI |1 |Connect status: Connecting
2018-04-22T20:03:54+02:00 TS |INFO |PreProSpeex |1 |Speex version: 1.2rc1
2018-04-22T20:03:54+02:00 TS |INFO |ClientUI |1 |Initiating connection: 78.143.39.87:12950 ts39.nitrado.net
2018-04-22T20:03:54+02:00 TS |INFO |ClientUI |1 |Blacklist check ok
2018-04-22T20:03:54+02:00 TS |INFO |ClientUI |1 |Resolve successful: 78.143.39.87:12950
2018-04-22T20:03:54+02:00 TS |INFO |ClientUI |1 |Lookup finished: 78.143.39.87 12950 ts39.nitrado.net 0 0
2018-04-22T20:03:50+02:00 TS |INFO | | |Statistics report: Setting next report date to: Fri Apr 27 14:03:50 2018
2018-04-22T20:03:50+02:00 TS |INFO | | |Statistics report: First run, report later in 1-30 days
2018-04-22T20:03:50+02:00 TS |INFO |ClientUI | |Last update check was: Tue Jan 1 00:00:01 2019
2018-04-22T20:03:50+02:00 TS |INFO |TSDNS | |DNS resolve successful, "ts39.nitrado.net"=78.143.39.87
2018-04-22T20:03:50+02:00 TS |INFO |TSDNS | |SRV DNS resolve unsuccessful for "_ts3._udp.ts39.nitrado.net"
2018-04-22T20:03:50+02:00 TS |INFO |TSDNS | |No TSDNS found at "ts39.nitrado.net"
2018-04-22T20:03:50+02:00 TS |INFO |ClientUI |1 |Trying to resolve ts39.nitrado.net
2018-04-22T20:03:50+02:00 TS |INFO |ClientUI |1 |Connect to server: ts39.nitrado.net
2018-04-22T20:03:50+02:00 TS |INFO |ClientUI | |ts3server: ts39.nitrado.net?port=12950&nickname=Perception&password=&channel=&channelpassword=
2018-04-22T20:03:50+02:00 TS |INFO |ClientUI | |Using configuration location: /home/sinusbot/data/ts3/0d5649d5-10d6-4cfc-9986-5e9ac47b5bf3/49765161-22a8-4db8-ae6a-860c07fa1339/settings.db
2018-04-22T20:03:50+02:00 TS |INFO |ClientUI | |Qt version: 5.5.0
2018-04-22T20:03:50+02:00 TS |INFO |ClientUI | |Failed to init text to speech engine
2018-04-22T20:03:50+02:00 TS |INFO |Query | |listening on 127.0.0.1:25639
2018-04-22T20:03:50+02:00 TS |INFO | | |Loading plugin: libtest_plugin
2018-04-22T20:03:50+02:00 TS |INFO | | |Loading plugin: libsoundbot_plugin
2018-04-22T20:03:50+02:00 TS |INFO | | |Loading plugin: liblua_plugin
2018-04-22T20:03:50+02:00 TS |INFO | | |Loading plugin: libclientquery_plugin
2018-04-22T20:03:50+02:00 TS |ERROR |SoundBckndIntf| |/home/sinusbot/TeamSpeak3-Client-linux_amd64/soundbackends/libpulseaudio_linux_amd64.so error: INIT_PA_IMPL
2018-04-22T20:03:50+02:00 TS |ERROR |PulseAudio | |pa_context_connect failed
2018-04-22T20:03:50+02:00 TS |ERROR |PulseAudio | |failed to connect to pulse audio server
2018-04-22T20:03:50+02:00 TS |INFO | | |Using hardware aes
2018-04-22T20:03:50+02:00 TS |INFO | | |SystemInformation: Linux 2.6.32-042stab127.2 #1 SMP Thu Jan 4 16:41:44 MSK 2018 x86_64 Binary: 64bit
2018-04-22T20:03:50+02:00 TS |INFO | | |TeamSpeak 3 Client 3.0.18.2 (2015-10-22 11:14:48)
2018-04-22T20:03:50+02:00 Starting instance ts3server://ts39.nitrado.net?port=12950&nickname=Perception&password=&channel=&channelpassword=
2018-04-22T20:03:50+02:00 Could not create Notifications-Tabletable Notifications already exists
2018-04-22T20:03:50+02:00 Could not create WhisperReceive-Tabletable WhisperReceive already exists
2018-04-22T20:03:50+02:00 Could not create Chat-Tabletable Chat already exists
2018-04-22T20:03:49+02:00 Auto-Starting 0d5649d5-10d6-4cfc-9986-5e9ac47b5bf3/49765161-22a8-4db8-ae6a-860c07fa1339 in 500 ms...
2018-04-22T20:03:49+02:00 Initialization complete

Thanks for helping me out! :)
 

Diesmon

Tuetchen Dominator
is awesome!
Contributor
Insider
2018-04-22T20:03:50+02:00 TS |INFO | | |TeamSpeak 3 Client 3.0.18.2 (2015-10-22 11:14:48)

Not supported anymore. Probably also the reason why the bot wont connect (server is 3.1.x and therefore needs client 3.1.7 or later)

SO upgrade the SInusBot to 0.13.37 and the sinusBot ts3 client to 3.1.8
 

Daddy_Ahex

Member
Not supported anymore. Probably also the reason why the bot wont connect (server is 3.1.x and therefore needs client 3.1.7 or later)

SO upgrade the SInusBot to 0.13.37 and the sinusBot ts3 client to 3.1.8
Wo bekomme ich die neuere Version her? Benutze immer den aktuellsten Link zum installieren.
 

Daddy_Ahex

Member
So teamspeak is now installed. But I'm getting an error message while starting (./sinusbot) in terminal:

Library not found.
2018/04/23 11:45:23 X [MAIN] Starting up fake x-server...
Sanity checks failed, unable to run. Please read the installation-guide carefully and contact support if necessary.
 
Top