• If you need help or want to discuss things, you now can also join us on our Discord Server!

Solved Could not import file!

Status
Not open for further replies.

Kilian57

Donor
is awesome!
Hello everyone,
I noticed a few days ago that my queued yt-links stopped working. So i started investigating. I noticed that some songs worked and some not. I updatet the sinusbot, ts client and made sure youtube-dl is up to date too. I manually checked youtube-dl and it works fine. Uploading the same songs manually doesn't bring up any errors either.
But if I try to queue them with !qyt, they just get skipped. If I import them using the webinterface I get a "Could not import file" error.

So here's the log showing the error (log level 10)
2020-04-12T16:11:58+02:00 DOWNLOAD [admin] https://www.youtube.com/watch?v=8j9hG-nVkLc OK
2020-04-12T16:11:58+02:00 Downloading (multi) 3.2M with codec opus from youtube
2020-04-12T16:11:57+02:00 Probing https://r5---sn-4g5ednsr.googlevideo.com/videoplayback?expire=1586722317&ei=rSGTXpyPCpay1gKwm57gBQ&ip=144.76.45.220&id=o-AHihIjsIduC3cwgtG1tvq2aiQpmVWqlIU9R1Oni3rr8c&itag=251&source=youtube&requiressl=yes&mh=rU&mm=31,26&mn=sn-4g5ednsr,sn-f5f7lne6&ms=au,onr&mv=u&mvi=4&pl=21&vprv=1&mime=audio/webm&gir=yes&clen=3333585&dur=206.081&lmt=1575164932746296&mt=1586700550&fvip=5&keepalive=yes&c=WEB&txp=5531432&sparams=expire,ei,ip,id,itag,source,requiressl,vprv,mime,gir,clen,dur,lmt&lsparams=mh,mm,mn,ms,mv,mvi,pl&lsig=ALrAebAwRAIgaIvFJXx9ZbqbvgzGdxadYnTY2ldf2XXLDQM0k5vMVccCIFamKGA4FsEo4-QYNaP4BuRraiuy4NEkZ1_00AIvBJVm&sig=AJpPlLswRgIhAJeXemnQiRdfgsOz2c91pGoFxsxw2vtNwphiNX-yUwd0AiEAgMJvmZf-gxg6JnORqWk5_DPYhFpHPWaAsa1HthQ1dMI=&ratebypass=yes for HTTP range support
2020-04-12T16:11:57+02:00 Downloading thumbnail
2020-04-12T16:11:55+02:00 JOBS-ADD [admin] https://www.youtube.com/watch?v=8j9hG-nVkLc OK
2020-04-12T16:08:03+02:00 DOWNLOAD [admin] https://www.youtube.com/watch?v=eFTLKWw542g NOK
2020-04-12T16:08:03+02:00 Error loading file (/opt/sinusbot/data//store/2e97fc8e-6e06-476d-8dd5-7ec4d266eb01/e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855): Could not open file!
2020-04-12T16:08:03+02:00 Downloading (single) 3.7M with codec opus from youtube
2020-04-12T16:08:03+02:00 Probing https://r6---sn-4g5ednle.googlevideo.com/videoplayback?expire=1586722082&ei=wiCTXvO5LtGC7gOqsJCQDw&ip=144.76.45.220&id=o-AEMIzmXT9PxDVzhM9qoEY1M0JmYpzABTtq_f920e0LOu&itag=251&source=youtube&requiressl=yes&mh=m4&mm=31,26&mn=sn-4g5ednle,sn-f5f7lne6&ms=au,onr&mv=u&mvi=5&pl=21&gcr=ua&vprv=1&mime=audio/webm&gir=yes&clen=3901428&dur=245.401&lmt=1540279956675088&mt=1586700036&fvip=5&keepalive=yes&c=WEB&txp=5511222&sparams=expire,ei,ip,id,itag,source,requiressl,gcr,vprv,mime,gir,clen,dur,lmt&lsparams=mh,mm,mn,ms,mv,mvi,pl&lsig=ALrAebAwRAIgGdgy2yT9Os-Nsa8a3mmQW48wcBtGe1EWzF_Eiq7fZjsCIDIHpW5pOL9EyrquCbEUX5T7E_PDwxT3CJyjNCLpWqFZ&sig=AJpPlLswRQIgIskAHtfgxdWk6wvzQqFUOESH1NZlY0Dm3dYE1dpJX7sCIQDHpS649tzPZ0yChaq_zKJfn_4iFDXZfw5fGKhSiatvAw==&ratebypass=yes for HTTP range support
2020-04-12T16:08:03+02:00 Downloading thumbnail
2020-04-12T16:08:01+02:00 JOBS-ADD [admin] https://www.youtube.com/watch?v=eFTLKWw542g OK
As you can see it works fine with one video and doesn't with an other.

Here are the diagnostics
Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
- Operating System: Debian GNU/Linux 9.11 (stretch)
- Kernel: Linux 4.9.0-9-amd64 x86_64
- Load Average: 0.35 0.32 0.37
- Uptime: 8 days, 21 hours, 57 minutes, 2 seconds
- OS x64 check: OK
- OS Updates: 30 (updates available!)
- OS Missing Packages: None
- OS APT Last Update: 12.04.2020 14:56:21 CEST +02:00:00
- Shell Locale: en_US.UTF-8
- Bot Start Script: found at /etc/systemd/system/sinusbot.service [perms: 755]
- CPU:
    Architecture:          x86_64
    CPU(s):                8
    Thread(s) per core:    2
    Core(s) per socket:    4
    Socket(s):             1
    Model name:            Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
    CPU MHz:               2278.149
    Virtualization:        VT-x
- RAM: 5.81 GB/14.63 GB in use (39%)
- SWAP: 393.51 MB/7.99 GB in use (4%)
- DISK: 755.21 GB/2.67 TB in use (27%)
- Package versions:
   - libglib: 2.50.3-2+deb9u1

BOT INFORMATION
- Status: running (PIDs: 20758 20757, User: ts)
- Webinterface: port locally reachable (Port: 8087)
- Binary: /opt/sinusbot/sinusbot
- Binary Info: MD5 Hash: 224b687db910b732fe5a7cfec4f6c78e, Perms: 755, User: ts
- Version: 1.0.0-beta.10-202ee4d
- TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: aa483aea105cb62033392b1ce6d317ab
   - TS3 Client: aa483aea105cb62033392b1ce6d317ab
- Config:
   - LogLevel = 10 (debug log active)
   - TS3Path = /opt/sinusbot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 (Version 3.5.2)
   - YoutubeDLPath = /opt/sinusbot/youtube-dl (does exist, version: 2020.03.24)
- Installed scripts: advertising.js; alonemode.js; automaticCodec.js; AutomaticServerGroupAssigner.js; avatarbanner.js; away_mover.js; bookmark.js; come.js; command.js; defaultChannel+.js; followme.js; listplaylist.js; norecording.js; OKlib.js; rememberChannel.js; sinusbot-commands.js; SteamUserQuery.js; Trackskipper.js; tunakills_rankingsystem.js; welcome.js; youtube.js; Youtube_Search.js

BOT TECHNICAL INFORMATION
- File exists:
   - TS3Client/libqxcb-glx-integration.so: no
- LDD output:
    linux-vdso.so.1 (0x00007ffdf0bb6000)
    libswresample.so.2 => /opt/sinusbot/libswresample.so.2 (0x00007f7cf2e5c000)
    libavfilter.so.6 => /opt/sinusbot/libavfilter.so.6 (0x00007f7cf2b04000)
    libavformat.so.57 => /opt/sinusbot/libavformat.so.57 (0x00007f7cf2703000)
    libavcodec.so.57 => /opt/sinusbot/libavcodec.so.57 (0x00007f7cf1d9e000)
    libavutil.so.55 => /opt/sinusbot/libavutil.so.55 (0x00007f7cf1b2a000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f7cf1926000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f7cf1622000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f7cf1405000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f7cf1083000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f7cf0e6c000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f7cf0acd000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f7cf08b3000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f7cf06ab000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f7cf3076000)

REACHABILITY CHECKS
- HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
- HTTPS check with IPv6 mode: IGNORED [Disabled]
- DNS resolution check: SUCCESS [www.sinusbot.com resolved to 104.28.14.74]
- Update server checks:
    update01.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update02.sinusbot.com -> 104.28.14.74: SUCCESS [CODE #404]
    update03.sinusbot.com -> 104.28.14.74: SUCCESS [CODE #404]

TIME INFORMATION
- Time (local): 12.04.2020 16:48:38 CEST +02:00:00
- Time (remote): 12.04.2020 16:48:38 CEST +02:00:00
- Time (difference): 0 secs (Time diff less than 2 secs. Good.)
- Timezone: Europe/Berlin

OTHER INFORMATION
- TeamSpeak3 Version: 3.5.2
- youtube-dl Version: 2020.03.24
- DiagScript Version: 0.8.0
==========================================================

I don't really know what I can do anymore so i would be thankful for any advice.
Tell me if you need anything more.

Thank you and happy Easter
Kilian
 
Last edited:

DavidieHD

Member
i have the same problem, but i think the problem is the youtube-dl, she isnt uptodate from the produce of the addon, i think we have to wait that they update the youtube-dl
 
Status
Not open for further replies.

Similar threads

Top