• If you need help or want to discuss things, you now can also join us on our Discord Server!

Discord Sinusbot unter Windows kein Sound

Trak

Active Member
Hallo wie der Titel schon besagt, versuche ich gerade ein Discord Sinusbot unter Windows zu installieren. Der Bot kommt in den Discord Voice-Chat ohne Probleme jedoch spielt er dort keine Musik ab. In der instanz-Log seh ich als fehler:

error from conn reader: read tcp 109.230.239.25:61349->162.159.136.234:443: use of closed network connection

was heisst das nun?
 

Shiroo

Member
Ist ein Fehler der momentanen Stable version seitdem Discord ihre API geändert hat, suche mal nach der Beta8. Mit dieser funktioniert der Bot in Discord wieder, jedoch funktionieren jedenfalls auf meiner Seite die Commands noch nicht.
 

irgendwr

semi-inactive™
Staff member
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
Wie erwähnt bitte auf sinusbot >= 1.0.0-beta.8 updaten und im folgenden verlinkten fixes durchführen, damit die commands weiterhin funktionieren.

jedoch funktionieren jedenfalls auf meiner Seite die Commands noch nicht
Der fix dafür ist unter anderem in den Update-Notes zu finden: https://forum.sinusbot.com/resources/internal-windows-beta-64bit.150/updates#resource-update-1310

Hier auch nochmal ein post dazu:
Fix:
  1. Stop/Close SinusBot
  2. Download "sinusbot-commands.js" into your Script folder (default is C:/SinusBot/scripts): https://raw.githubusercontent.com/SinusBot/scripts/master/default-attached/sinusbot-commands.js
  3. Download "command.js" into your Script folder (default is C:/SinusBot/scripts): https://raw.githubusercontent.com/Multivit4min/Sinusbot-Command/master/command.js
  4. Be sure to save both as ".js" files and NOT as ".txt", otherwise it will not work. See screenshot below.
  5. Restart your SinusBot.
When downloading, save as .js and not .txt, as shown below.
1571667088207.png
 

Shiroo

Member
hey danke für den tipp, leider hab ich den Fix schon probiert und er funktioniert bei mir jedenfalls nicht oder ich mache eventuell was falsch. Ich speichere sinusbot-commands.js als javascript datei ab und ersetze die alte command.js mit der neuen. Er wirft dann eine Fehlermeldung mit Verweis auf command.js aus, wenn ich versuche einen Command im channel zu benutzen.

Einmal frisch neu installiert habe ich den Bot auch schon.
 

Similar threads

Top