• If you need help or want to discuss things, you now can also join us on our Discord Server!

`GLIBC_2.18' not found

anicetus

New Member
Hello guys,
I got problem with starting my bot, i switched to new VPS and i tried many things which i found on the forum to fix this problem, but still doesnt work... im using sinusbot installer like on the old vps (sinus bot works on old vps - i got same settings and other stuff). Any tips to fix this? thank you in advance :). btw yum update and other "easy" stuff i already done.

-------------------------------------------------------

Instance-Log:

2019-08-11T09:12:03+02:00 Storing configuration.
2019-08-11T09:11:35+02:00 closing channels
2019-08-11T09:11:34+02:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019-08-11T09:11:34+02:00 Closed.
2019-08-11T09:11:34+02:00 TS>/opt/sinusbot/teamspeak3-client/ts3client_linux_amd64: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by /opt/sinusbot/teamspeak3-client/libc++abi.so.1)
2019-08-11T09:11:34+02:00 eof from voice
2019-08-11T09:11:34+02:00 Starting instance ts3server://xx.xx.xx.xx?port=9987&nickname=SinusBot&password=&channel=&channelpassword=
2019-08-11T09:11:34+02:00 About to run.
2019-08-11T09:11:34+02:00 closing channels
2019-08-11T09:11:33+02:00 Prespawn.
2019-08-11T09:11:33+02:00 script command loaded
2019-08-11T09:11:33+02:00 module registered as command
2019-08-11T09:11:33+02:00 registered callback for event chat
2019-08-11T09:11:33+02:00 serialized function: true
2019-08-11T09:11:33+02:00 Auto-Starting 3002fe5f-3f1e-40a9-b9ee-71743b225767/619ef2c4-5767-40b9-b47d-3ad40fe4799d in 500 ms...
2019-08-11T09:11:33+02:00 Initialization complete
2019-08-11T09:11:33+02:00 executing script command
2019-08-11T09:11:33+02:00 TSClient quit. LogLevel has been increased, please try to connect again to see more details.
2019-08-11T09:11:33+02:00 Starting instance ts3server://xx.xx.xx.xx?port=9987&nickname=SinusBot&password=&channel=&channelpassword=

-------------------------------------------------------

hostnamectl:

Virtualization: kvm
Operating System: CentOS Linux 7 (Core)
CPE OS Name: cpe:/o:centos:centos:7
Kernel: Linux 3.10.0-957.27.2.el7.x86_64
Architecture: x86-64

-------------------------------------------------------
 

anicetus

New Member
So, i already update the kernel, but still a i got same problem :( should i try reinstall the bot?


Operating System: CentOS Linux 7 (Core)
CPE OS Name: cpe:/o:centos:centos:7
Kernel: Linux 4.4.188-1.el7.elrepo.x86_64
Architecture: x86-64
 

TwentyFour

Well-Known Member
is awesome!
V.I.P.
You could try getting all needed dependencies first: (hope this works on CentOS)
Code:
yum install -y x11vnc xvfb libxcursor1 ca-certificates bzip2 libnss3 libegl1-mesa x11-xkb-utils libasound2 libpci3 libxslt1.1 libxkbcommon0 curl libglib2.0-0
But imho the problem comes from CentOS. It's using pretty old libs and there were problems in the past as well. Strongly suggesting Debian 9/10 or Ubuntu 18.04, since those are officially supported by SinusBot.
 

anicetus

New Member
i already tried this code, but many packages arent available :( i dont know what is wrong with that but like you sad, it will be better to switch to debian. Thank you very much for fast replies and big thumbs up for this community!! :)

[[email protected] ~]# yum install -y x11vnc xvfb libxcursor1 ca-certificates bzip2 libnss3 libegl1-mesa x11-xkb-utils libasound2 libpci3 libxslt1.1 libxkbcommon0 curl libglib2.0-0
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: ftp.sh.cvut.cz
* elrepo: ftp.nluug.nl
* extras: ftp.sh.cvut.cz
* updates: ftp.sh.cvut.cz
No package x11vnc available.
No package xvfb available.
No package libxcursor1 available.
Package ca-certificates-2018.2.22-70.0.el7_5.noarch already installed and latest version
Package bzip2-1.0.6-13.el7.x86_64 already installed and latest version
No package libnss3 available.
No package libegl1-mesa available.
No package x11-xkb-utils available.
No package libasound2 available.
No package libpci3 available.
No package libxslt1.1 available.
No package libxkbcommon0 available.
Package curl-7.29.0-51.el7_6.3.x86_64 already installed and latest version
No package libglib2.0-0 available.
Nothing to do
 

flyth

is reticulating splines
Staff member
Developer
Contributor
Glibc version is usually pretty fixed throughout an OS release, so you might need to upgrade the entire OS.
 

Similar threads

Top