• TeamSpeak has reported a vulnerability in it's client that can potentially lead to RCE. A new version has been released that fixes it. So please update the client in your bot installation as soon as possible as well. Click here for more information.
  • If you need help or want to discuss things, you now can also join us on our Discord Server!

Solved Problem bei der Installation

Melvin00

New Member
Ich habe ein Problem bei der Installation auf mein VServer.

Der Bot findet den TS3 Client nicht Obwohl ich Teamspeak Installiert habe. Ich bitte um Hilfe.

3128
 

Himsel

Well-Known Member
Contributor
jopp, dass ist der installerscript. Trotzdem öffne mal bitte opt/sinusbot/congig.ini was steht da bei ts3path = ? ... eigentlich sollte ja alles richtig sein
 

TwentyFour

Well-Known Member
V.I.P.
is awesome!
Erstmal...
https://forum.sinusbot.com/threads/lies-mich-bevor-du-schreibst.146/

Dann hast du das Installerskript ja benutzt, wie wäre es denn, wenn du mal von dort das Log der Konsole reinkopierst? Dann sieht man zB, ob dort bei der Installation alles korrekt von Statten geht.
Alternative einfach den ganzen Prozess nochmal wiederholen, und schauen ob das Resultat des gleiche ist.
Wir haben ja keine Glaskugel hier stehen, und wissen was auf deinem Setup abgeht...

Du gehst ja auch in keine Werkstatt und sagst, mein Auto geht nicht, bitte repariert es... hast aber weder dein Auto vor Ort dabei, noch kannst du dem Mechaniker sagen, von welche Marke dein Auto ist :rolleyes:
 

Himsel

Well-Known Member
Contributor
hmm... versuche doch mal den ts3 client selbst runterzuladen bitte
Code:
wget https://files.teamspeak-services.com/releases/client/3.2.3/TeamSpeak3-Client-linux_amd64-3.2.3.run
 

Himsel

Well-Known Member
Contributor
Code:
apt-get install ca-certificates
und versuche den sinusbot installer nochmal oder erst einmal teamspeak client runterzuladen
 

wiesel77

Member
Ich habe nach der Neuinstallation leider das Problem das er nicht mehr mit dem TS verbindet und ich habe alles nachgeschaut was hier stand ..... Ohne Erfolg.


2019-04-27T10:38:37+02:00 Starting instance ts3server://62.75.156.199?port=9987&nickname=Radio-Bot&password=&channel=&channelpassword=
2019-04-27T10:38:37+02:00 Could not insert into Profiles-Tableno such table: Profiles
2019-04-27T10:38:37+02:00 Could not delete from Profilesno such table: Profiles
2019-04-27T10:38:37+02:00 Could not insert into Profiles-Tableno such table: Profiles
2019-04-27T10:38:37+02:00 Could not delete from Profilesno such table: Profiles
2019-04-27T10:38:37+02:00 Could not insert into Profiles-Tableno such table: Profiles
2019-04-27T10:38:37+02:00 Could not delete from Profilesno such table: Profiles
2019-04-27T10:38:37+02:00 Could not insert into Profiles-Tableno such table: Profiles
2019-04-27T10:38:37+02:00 Could not delete from Profilesno such table: Profiles
2019-04-27T10:38:37+02:00 Could not insert into Profiles-Tableno such table: Profiles
2019-04-27T10:38:37+02:00 Could not delete from Profilesno such table: Profiles
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:37+02:00 Could not insert into Application-Tableno such table: Application
2019-04-27T10:38:37+02:00 Could not delete from Applicationno such table: Application
2019-04-27T10:38:21+02:00 BOT-CONFIG [admin] HOST CHANPW CHAN ANNOUNCE DESCRIPTION ANNOUNCESTR TTSURL CC OK
2019-04-27T10:37:55+02:00 BOT-CONFIG [admin] NICK NAME CHANPW CHAN ANNOUNCE DESCRIPTION ANNOUNCESTR TTSURL CC OK
2019-04-27T10:37:33+02:00 TSClient quit.
2019-04-27T10:37:32+02:00 Could not request shutdown. Please make sure that the plugin is installed correctly; HTTP returned an error: Timeout; Code: 500; Message: Timeout
2019-04-27T10:37:17+02:00 Already online.
desweiteren wenn ich den Bot starten will per SSh kommt diese Meldung --> Failed to start sinusbot.service: The name org.freedesktop.PolicyKit1 was not provided by any .service files
 
Last edited:

wiesel77

Member
https://forum.sinusbot.com/threads/lies-mich-bevor-du-schreibst.146/

Fehlen zu viele Informationen um dir adäquat helfen zu können. Daskönnte eine alte TS Version sein, alte Bot Version, generell falsch konfigurierte Linuxinstallationen.
Was aber nie schadet, ist alle Daten zu backuppen, alles zu löschen, und komplett und sauber neu aufsetzen.

Was meinst du mit Neuinstallation? Installer Skript, oder manuell?
Ich habe per Installer Skript installiert ....... geschweige wollte ich nur Updaten und zack ging nichts mehr.....
Ich habe die SinusBot 1.0.0-beta.1-06a54d7 drauf ......
so wie auf dem Server die TS version 3.7.1

Wie meinst Du das mit dem Beckup und neu machen genau ?? Sonst läuft der Server Sauber


Falls Du meinst den Bot ganz neu aufzusetzen das habe ich auch schon gemacht und immer schön den server neu gestartet... auch das Ohne erfolg.
 
Last edited:

TwentyFour

Well-Known Member
V.I.P.
is awesome!
Du speicherst den Inhalt von /opt/sinusbot, löscht dann alles, und machst eine komplette Neuinstallation. Sollte diese ohne Probleme laufen, überträgst du deine Settings in diese Version, oder versucht eben Stück für Stück die Backupfiles wieder einzuspielen.

Gehe nicht davon aus, dass du vor dem Update ein Backup gemacht hast, und du dieses wieder einspielen könntest?
Von welcher Sinusbot Version aus hast du denn geupdated?

Trotzdem, lese bitte meinen Link von oben. Ohne die Infos zB. vom DiagScript, ist das alles Raterei. Beim Threadersteller, wars dann letztendlich eine alte TS-Client Version. Könnte bei dir auch sein, denn kA welche Version du hast. So muss dir niemand alles aus der Nase ziehen. ;)
 
Last edited:

wiesel77

Member
Du speicherst den Inhalt von /opt/sinusbot, löscht dann alles, und machst eine komplette Neuinstallation. Sollte diese ohne Probleme laufen, überträgst du deine Settings in diese Version, oder versucht eben Stück für Stück die Backupfiles wieder einzuspielen.

Gehe nicht davon aus, dass du vor dem Update ein Backup gemacht hast, und du dieses wieder einspielen könntest?
Von welcher Sinusbot Version aus hast du denn geupdated?

Trotzdem, lese bitte meinen Link von oben. Ohne die Infos zB. vom DiagScript, ist das alles Raterei. Beim Threadersteller, wars dann letztendlich eine alte TS-Client Version. Könnte bei dir auch sein, denn kA welche Version du hast. So muss dir niemand alles aus der Nase ziehen. ;)

Nein natürlich nicht gemacht vorher .... ist aber auch kein Problem wieder alles so einzstellen wie ich es möchte. Habe alles vom Server gelöscht und den Skript ausgeführt und trotzdem geht es nicht ....... Das ist auch alles neulad für mich wie kann ich das DiagScript erstellen ??
 

TwentyFour

Well-Known Member
V.I.P.
is awesome!
Steht in besagtem Link oben. Einfach mal 5 Minuten Zeit nehmen und sorgsam durchlesen.
Der konkrete Link zum DiagScript ist hier.

Code:
apt-get install bc binutils coreutils lsb-release util-linux
Ausführen, aber sollte meist schon alles installiert sein.

Code:
cd /opt/sinusbot/
curl -O https://raw.githubusercontent.com/patschi/sinusbot-tools/master/tools/diagSinusbot.sh
bash diagSinusbot.sh
Und dann bitte alles hier im Forum in ein CODE-Tag packen und posten.

P.S.: Und Backups immer angewöhnen! Das ist ein Minute Arbeit und spart meiste vielfaches davon...
 

wiesel77

Member
Also meinst Du das ?

[2019-04-27 12:21:30] [INFO] Starting diagSinusbot v0.7.1 [2018-05-23 22:20 UTC]...
[2019-04-27 12:21:30] [INFO] Checking for new diagnostic script version...
[2019-04-27 12:21:30] [OKAY] You are using the latest version.
[2019-04-27 12:21:30] [INFO] Detected operating system: Ubuntu 16.04.6 LTS
[2019-04-27 12:21:31] [INFO] Searching bot binary...
[2019-04-27 12:21:31] [DEBUG] Searching in directory '/root'...
[2019-04-27 12:21:31] [DEBUG] Searching in directory '/opt/sinusbot/'...
[2019-04-27 12:21:31] [DEBUG] Binary 'sinusbot' found.
[2019-04-27 12:21:31] [INFO] Binary found.
[2019-04-27 12:21:31] [DEBUG] Collecting information...
[2019-04-27 12:21:31] [INFO] (Scan may take some moments...)
[2019-04-27 12:21:31] [INFO] Collecting system information...
[2019-04-27 12:21:31] [DEBUG] Getting operating system version...
[2019-04-27 12:21:31] [WARNING] It seems your machine is a OpenVZ container. OpenVZ is known for failing on some checks in this diagnostic scripts. These are known limitations due to restrictions and the nature of the containering software.
[2019-04-27 12:21:31] [DEBUG] Checking DNS resolution...
[2019-04-27 12:21:31] [DEBUG] Checking web IPv4 access...
[2019-04-27 12:21:31] [DEBUG] Checking for locales...
[2019-04-27 12:21:31] [DEBUG] Getting processor information...
lscpu: failed to determine number of CPUs: /sys/devices/system/cpu/possible: No such file or directory
[2019-04-27 12:21:31] [DEBUG] Checking for available operating system updates...
[2019-04-27 12:21:32] [DEBUG] Getting RAM information...
diagSinusbot.sh: line 1299: 8388608 - : syntax error: operand expected (error token is "- ")
[2019-04-27 12:21:32] [DEBUG] Getting DISK information...
[2019-04-27 12:21:32] [DEBUG] Getting disk info by using command:
[2019-04-27 12:21:32] [DEBUG] $ df -Tl --total -t ext4 -t ext3 -t ext2 -t reiserfs -t jfs -t ntfs -t fat32 -t btrfs -t fuseblk -t simfs
[2019-04-27 12:21:32] [INFO] Collecting bot information...
[2019-04-27 12:21:32] [DEBUG] Trying to get SinusBot version using version parameter...
[2019-04-27 12:21:32] [DEBUG] Loading bot config file...
[2019-04-27 12:21:32] [DEBUG] Determining bot status...
[2019-04-27 12:21:32] [DEBUG] Reading ListenPort from bot configuration...
[2019-04-27 12:21:32] [DEBUG] Getting installed bot scripts...
[2019-04-27 12:21:32] [DEBUG] Reading LogLevel from bot configuration...
[2019-04-27 12:21:32] [DEBUG] Reading TS3Path from bot configuration...
[2019-04-27 12:21:32] [DEBUG] Trying to get ts3client version...
[2019-04-27 12:21:32] [DEBUG] Checking installation of bot plugin in ts3client...
[2019-04-27 12:21:33] [DEBUG] Checking for 'youtube-dl'...
diagSinusbot.sh: line 721: nc: command not found
xxd: sorry cannot seek.
[2019-04-27 12:21:34] [ERROR] Failed trieving remote time from NTP server time.google.com! Is any firewall blocking the NTP request, or is the DNS resolution failing?
[2019-04-27 12:21:34] [DEBUG] Generating output...
(standard_in) 1: syntax error
(standard_in) 1: syntax error
diagSinusbot.sh: line 322: [: -gt: unary operator expected
(standard_in) 1: syntax error
(standard_in) 1: syntax error
diagSinusbot.sh: line 322: [: -gt: unary operator expected
(standard_in) 1: syntax error
(standard_in) 1: syntax error
diagSinusbot.sh: line 322: [: -gt: unary operator expected


Please attach this output to your forum post:

Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
 - Operating System: Ubuntu 16.04.6 LTS (OpenVZ)
 - Kernel: Linux 4.4.0-042stab134.8 x86_64
 - Load Average: 0.14 0.30 0.41
 - Uptime: 0 days, 0 hours, 22 minutes, 9 seconds
 - OS x64 check: OK
 - OS Updates: 0 (well done!)
 - OS Missing Packages: None
 - OS APT Last Update: 27.04.2019 12:05:35 CEST +02:00:00
 - SHELL LOCALE LANG: en_US.UTF-8
 - Bot Start Script: not found
 - DNS resolution check: www.sinusbot.com resolved to 104.28.15.74 -> OK
 - HTTPS check with IPv4 mode: SUCCESS [Connection was established to www.sinusbot.com, CODE #200]
 - HTTPS check with IPv6 mode: IGNORE
 - CPU:
    (failed retrieving information)
 - RAM:  B/8.00 GB in use (%)
 - SWAP:  B/ B in use (%)
 - DISK: 7.92 GB/196.73 GB in use (4%)
 - Package versions:
   + libglib: 2.48.2-0ubuntu4.1

BOT INFORMATION
 - Status: running (PIDs: 8757 8756, User: sinusbot)
 - Webinterface: port locally reachable (Port: 8087)
 - Binary: /opt/sinusbot/sinusbot
 - Binary Info: MD5 Hash: 6f301dac3e4dfd45ce149933c5dadd08, Perms: 755, User: sinusbot
 - Version: 1.0.0-beta.1-06a54d7
 - TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: 59c9a688307aa73af9573029a7625fc5
   - TS3 Client: 59c9a688307aa73af9573029a7625fc5
 - Config:
   - LogLevel = 10 (debug log active)
   - TS3Path = /opt/sinusbot/teamspeak3-client/ts3client_linux_amd64 (Version 3.2.5)
   - YoutubeDLPath = /usr/local/bin/youtube-dl (does exist, version: 2019.04.24)
 - Installed scripts: advertising.js; alonemode.js; bookmark.js; command.js; countOnlineUsers.js; followme.js; norecording.js; rememberChannel.js; Support.js; welcome.js

TIME INFORMATION
 - Time (local): 27.04.2019 12:21:34 CEST +02:00:00
 - Time (remote): <Failed retrieving remote time!>
 - Time (difference): n/a secs
 - Timezone: Europe/Berlin

OTHER INFORMATION
 - TeamSpeak 3 Version: 3.2.5
 - youtube-dl Version: 2019.04.24
 - DiagScript Version: 0.7.1
==========================================================
Notice: For a better overview, post this data
in the forum within a CODE-tag!


[2019-04-27 12:21:34] [DEBUG] Done.
 

Similar threads

Top