• If you need help or want to discuss things, you now can also join us on our Discord Server!
  • Happy New Year everyone! A new version (1.0.0-beta.16) is out for Linux, fixing an issue that could lock the bot up when using it with TS3. Please visit the resources section or the main page (https://www.sinusbot.com) for the new package.

Sinusbot error to upload script with PuTTy

-invisible-

Member
Hello, I have a problem uploading some plugins with PuTTy uploading it from GitHub (Since I can't do it from WinSCP, because it doesn't let me enter the root user). I upload the github plugin to the 'scripts' folder when I reload the page, it doesn't appear in the scripts panel. I await your responses, thank you!
 

_maddiboy

Donor
is awesome!
hey,

that reads as if there were incorrect permissions settings.
Since my bots run on Portainer, I initially had the same problem. I solved by creating an extra user with the required rights for read/write/delete.
You best try this.

Otherwise it would be interesting to know how the Sinusbot is installed in your system.
 

MauriceR

Well-Known Member
Contributor
Hello, I have a problem uploading some plugins with PuTTy uploading it from GitHub (Since I can't do it from WinSCP, because it doesn't let me enter the root user). I upload the github plugin to the 'scripts' folder when I reload the page, it doesn't appear in the scripts panel. I await your responses, thank you!
Just reloading the page doesnt work. You need to set the right permissions to the file (via putty: chmod & chown) and also restart the bot. After that it should show on the website.
Some plugins might not show after restarting, but that might be because of an old, not compatible version
 
Top