• If you need help or want to discuss things, you now can also join us on our Discord Server!
  • Happy New Year everyone! A new version (1.0.0-beta.16) is out for Linux, fixing an issue that could lock the bot up when using it with TS3. Please visit the resources section or the main page (https://www.sinusbot.com) for the new package.

Upcoming Changes

gadu

Member
Hello,

Do you have any news about unlimited licenses ? Particularly for TeamSpeak on Windows ? "the change of terms takes effect on July 1st, 2022" (1 week after the original post, cf original post) but more than 5 months later, there is no unlocked and unrestricted version for all users for free as announced. Did I not understand the annoucement ?

Thank you in advance

Regards
 

giurap

Active Member
I'm a little confused about the instances. I'm a long time donor, but I never took any advantage of it due to the Windows version.
With this upcoming version, it'll be possible to run more than two instances on Windows?
 

gadu

Member
Hello,

I do not understand why there is no Windows version. The unlimited instance fonctionnality is available since this summler for linux but nothing for Windows ? This is the same problem as "could not decode downloader output: json: cannot unmarshal number 127.37 into Go struct field YTDLFormat.abr of type int" error: we have to use a patched old version of youtube-dl (1.5 years ago whereas the last version is 1 year old) because Windows version is not patched since 2 years... Youtube playback is very slow because there is no update... Do you have any solution for this issue ?

Thank you

Regards
 

EyupBey

Member
@flyth CentOS 7.6:
[[email protected] test]# ./sinusbot ./sinusbot: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by ./sinusbot) ./sinusbot: /lib64/libc.so.6: version `GLIBC_2.28' not found (required by ./sinusbot) ./sinusbot: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by ./sinusbot) ./sinusbot: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./sinusbot) ./sinusbot: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./sinusbot) ./sinusbot: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by /root/test/libavfilter.so.8) ./sinusbot: /lib64/libc.so.6: version `GLIBC_2.27' not found (required by /root/test/libavformat.so.59) ./sinusbot: /lib64/libc.so.6: version `GLIBC_2.28' not found (required by /root/test/libavformat.so.59) ./sinusbot: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by /root/test/libavcodec.so.59) ./sinusbot: /lib64/libc.so.6: version `GLIBC_2.28' not found (required by /root/test/libavutil.so.57)
 
Last edited:
@flyth CentOS 7.6:
[[email protected] test]# ./sinusbot ./sinusbot: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by ./sinusbot) ./sinusbot: /lib64/libc.so.6: version `GLIBC_2.28' not found (required by ./sinusbot) ./sinusbot: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by ./sinusbot) ./sinusbot: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./sinusbot) ./sinusbot: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./sinusbot) ./sinusbot: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by /root/test/libavfilter.so.8) ./sinusbot: /lib64/libc.so.6: version `GLIBC_2.27' not found (required by /root/test/libavformat.so.59) ./sinusbot: /lib64/libc.so.6: version `GLIBC_2.28' not found (required by /root/test/libavformat.so.59) ./sinusbot: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by /root/test/libavcodec.so.59) ./sinusbot: /lib64/libc.so.6: version `GLIBC_2.28' not found (required by /root/test/libavutil.so.57)
Had the same problem with Ubuntu 18 you need to Update your distro for safety to the newest one because glibc is not Supported on the older versions that fixed it for me so use a newer distro i also tried to get around this but nothing fixed it except for upgrading
 

EyupBey

Member
Had the same problem with Ubuntu 18 you need to Update your distro for safety to the newest one because glibc is not Supported on the older versions that fixed it for me so use a newer distro i also tried to get around this but nothing fixed it except for upgrading
Do you know which distros support this version? I tested with Ubuntu 22.04 and there was no problem.
 
Do you know which distros support this version? I tested with Ubuntu 22.04 and there was no problem.
As you used an older version of centos in the upper post i think the newest CentOS should work and yeah i also use ubuntu 22.04 works fine probably the older versions dont support the newest glibc
 

EyupBey

Member
As you used an older version of centos in the upper post i think the newest CentOS should work and yeah i also use ubuntu 22.04 works fine probably the older versions dont support the newest glibc
@flyth You should look at this and make a patch for it. Or you can publish open source of the old version of the current stabil version so we can edit it.
 
Top