• If you need help or want to discuss things, you now can also join us on our Discord Server!

Solved Youtube-DL not working.

Mavi

Donor
is awesome!
EDIT: I just tried to fiddle with the config again and removing the path to the youtube-dl worked (not sure what the problem was but it works now without an issue. Ooops)


Hello,

I freshly installed new Sinusbot, and downloaded the latest Youtube-DL, but every time I use the !yt or !ytdl command (with youtube link after the command of course). nothing happens.

Code:
2019-05-31T19:31:52+02:00 CHAT 1 [mavi @ Mavi] < yt [URL]https://youtu.be/kZa0HGNHKe4[/URL] > / OK
2019-05-31T19:31:52+02:00 PRIVATE-CHAT [Mavi] yt [URL]https://youtu.be/kZa0HGNHKe4[/URL]
2019-05-31T19:31:49+02:00 Storing configuration.
2019-05-31T19:31:47+02:00 new track info: Coldplay - Cemeteries of London (436f6c64706c6179202d2043656d65746572696573206f66204c6f6e646f6e)
2019-05-31T19:31:47+02:00 New channel a862eff2-8b24-418b-85d1-3eb7fa80033a () ID 2feddc00-efc2-4786-be70-00cb0b7cd068 (cc 0)
2019-05-31T19:31:47+02:00 Reseeding PRNG
2019-05-31T19:31:47+02:00 Playing idle trackplaylist://c32bc1b7-cb5f-4fb5-af28-1d5f8e88e7e8
2019-05-31T19:31:47+02:00 Done playing
2019-05-31T19:31:47+02:00 Channels now zero
2019-05-31T19:31:47+02:00 Deleting channel 7bc8693e-d07c-44a0-8b9f-71b09b2884c7 () ID 6c481250-2580-4005-ad0c-ad0b0e3e4685 (cc 1)
2019-05-31T19:31:47+02:00 Removing closed channel 7bc8693e-d07c-44a0-8b9f-71b09b2884c7 () ID 6c481250-2580-4005-ad0c-ad0b0e3e4685
2019-05-31T19:31:46+02:00 Sending stop to 7bc8693e-d07c-44a0-8b9f-71b09b2884c7 () ID 6c481250-2580-4005-ad0c-ad0b0e3e4685 #1
2019-05-31T19:31:46+02:00 CHAT 1 [mavi @ Mavi] < stop > / OK
2019-05-31T19:31:46+02:00 Stopping
2019-05-31T19:31:46+02:00 PRIVATE-CHAT [Mavi] stop
2019-05-31T19:31:40+02:00 CHAT 1 [mavi @ Mavi] < ytdl [URL]https://youtu.be/kZa0HGNHKe4[/URL] > / OK
2019-05-31T19:31:40+02:00 PRIVATE-CHAT [Mavi] ytdl [URL]https://youtu.be/kZa0HGNHKe4[/URL]
Here is my log, it just announces those two lines and that's it.. It just keeps playing the song it is already playing...

I tried using youtube-dl via a command line and that works without issues.
I had the same problem with my last Sinusbot instance, too.
Can someone please at least point me to the right direction for fixing this issue?

Thanks a lot,

Mavi
 
Last edited:

TwentyFour

Well-Known Member
is awesome!
V.I.P.
If your problem is solved, why don't you share your solution, so other people can profit as well?
 

Mavi

Donor
is awesome!
If your problem is solved, why don't you share your solution, so other people can profit as well?
I already shared my solution in the edit of the original post. Right when I was marking the thread as solved.
 

Multivitamin

Well-Known Member
Tier III
V.I.P.
Contributor
Insider
[URL]https://youtu.be/kZa0HGNHKe4[/URL] is not a valid url as far as i know, you need to get those bb codes removed
 

Mavi

Donor
is awesome!
[URL]https://youtu.be/kZa0HGNHKe4[/URL] is not a valid url as far as i know, you need to get those bb codes removed
That's not my command to SinusBot, that's SinusBot's reply to my command (it shows the clickable link in TS3 chat)
 

Multivitamin

Well-Known Member
Tier III
V.I.P.
Contributor
Insider
Code:
2019-05-31T19:31:40+02:00 PRIVATE-CHAT [Mavi] ytdl [URL]https://youtu.be/kZa0HGNHKe4[/URL]
this seems more like your command, as you already stated, the bot does not reply to your command

EDIT: Do you have assigned yourself permissions?
 

Mavi

Donor
is awesome!
this seems more like your command, as you already stated, the bot does not reply to your command
Then that's what the TS3 server outputs when you write an URL. Don't worry I am not using bb codes when I am giving the bot an URL...
 

Multivitamin

Well-Known Member
Tier III
V.I.P.
Contributor
Insider
Do you have assigned yourself permissions to use that type of command?
 

Mavi

Donor
is awesome!
Yes I do. But the problem is already solved, the thread is marked as Solved, too. The problem was in the config.ini, there was a wrongly stated youtube-dl path. I removed the path completely and put the youtube-dl directly in the Sinusbot folder.
 

Similar threads

Top