• If you need help or want to discuss things, you now can also join us on our Discord Server!

Zap-Hosting + Docker Fehler

RobertoL

New Member
Guten Tag,

ich weiß nicht ob ich hier Richtig bin und Hilfe bekommen kann, aber ich versuch es mal. (Sonst einfach löschen)

Ich habe mir heute ein Debian 10 vServer bei Zap-Hosting gemietet. 4 GB Arbeitsspeicher und 4 vCores auf dem Server habe ich über deren Webinterface eine Teamspeak 3 Server installiert und dann ein Autostart Script eingefügt für den TS3, hat auch alles Geklappt, dann habe ich gesehen das man ein Sinusbot installieren kann habe ich natürlich sofort gemacht. Bei dem Sinusbot wollte ich auch ein Startscript verwenden was sich schwierig erwiesen hat da Zap-Hosting den Sinusbot automatisch als Docker container installiert (Habe keine Erfahrung mit Docker). Mit ein bisschen suchen habe ich dann herausgefunden wie ich ein Container automatisch starten kann "docker update --restart unless-stopped HIER_MEINE_ContainerID" hat alles wunderbar Funktioniert Teamspeak startet neu und der Bot auch, aber leider gibt es ein Problem wenn ich den Sinusbot über das Zap-Hosting interface stoppe. Der bot Disconnect und 2 Sekunden danach geht der Teamspeak Server auch aus. Wenn ich den Container wieder auf "docker update --restart no HIER_MEINE_ContainerID" setze Passiert es nicht aber der Container Starte nicht bei reboot neu. Gibt es andere Möglichkeiten den Sinusbot im Container beim Reboot mit zu starten ?

Sinusbot Version : SinusBot 1.0.0-beta.5-b262b6a
Betriebssystem : Debian 10 - 64bit
Festplatte : 2.40 von 25 GB
RAM : 0.25-1 von 4.00 GB

Code:
TS3Path = "/opt/sinusbot/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64"
ListenHost = "0.0.0.0"
DataDir = "/opt/sinusbot/data/"
ListenPort = 8087
LocalPlayback = false
EnableLocalFS = false
MaxBulkOperations = 300
LogLevel = 10
EnableProfiler = false
YoutubeDLPath = "/usr/local/bin/youtube-dl"
EnableDebugConsole = false
AllowStreamPush = false
UploadLimit = 83886080
RunAsUser = 0
RunAsGroup = 0
ExternalFileBase = ""
InstanceActionLimit = 6
UseSSL = false
SSLKeyFile = ""
SSLCertFile = ""
Hostname = ""
HostnameMask = ""
SampleInterval = 60
StartVNC = false
EnableWebStream = false
LogFile = ""
LicenseKey = ""
IsProxied = false
DenyStreamURLs = []
Pragma = 0
UserAgent = ""

[YoutubeDL]
  BufferSize = 524288
  MaxDownloadSize = 419430400
  MaxDownloadRate = 104857600
  MaxSimultaneousChunkDownloads = 6
  CacheStreamed = false
  TimeoutSingleDownloader = 0
  TimeoutMultiDownloader = 0
  ChunkSize = 3145728

[TS3]
  AvatarMaxWidth = 0
  AvatarMaxHeight = 0
  AllowGIF = false

[StreamRewrites]

[Scripts]
  Debug = false
  AllowReload = false
  EnableTimer = false
  DisableLegacyEvents = false
  DevMode = false
  ScriptTimeout = 5

[Themes]
  Default = ""

[SpeechRecognition]
  Enable = false

[FFmpeg]
  UserAgent = "SinusBot (1.0.0-beta.5-b262b6a)"
  WaitTime = 0

[DAV]
  Enable = false

[XServer]
  Delay = 0
  Debug = false

[SHMem]
  Enable = false
  Size = 0
  Delay = 0
  Interval = 0

[RadioStations]
  URL = ""
  UpdateInterval = 0

[TTS]
  Enabled = false

  [[TTS.Modules]]
    Locale = "en-US"
    Filename = "voice_lstm_en-US.zvoice"
    PipelineFile = "voice_lstm_en-US/sfg/pipeline"
    Prefix = "voice_lstm_en-US/sfg/"
    Instances = 2

  [[TTS.Modules]]
    Locale = "de-DE"
    Filename = "voice_lstm_de-DE.zvoice"
    PipelineFile = "voice_lstm_de-DE/nfh/pipeline"
    Prefix = "voice_lstm_de-DE/nfh/"
    Instances = 2

Mit freundlichen Grüßen
Roberto
 

Lala Sabathil

Donor
is awesome!
is uber awesome!
Contributor
Insider
Nunja, erster Fehler: ZAP Hosting, ich lass das unkommentiert.
Wie wäre es mit crontab @reboot
 

EinfachRobin

Donor
is awesome!
Installier doch den Sinusbot einfach selbst per SSH? Mit dem installer Script musst du auch nichts können, außer ein mal c&p und dann die Fragen beantworten.
 

Lala Sabathil

Donor
is awesome!
is uber awesome!
Contributor
Insider
Btw, wo hast du gesehen dass man SinusBot installieren kann.
Bietet ZapHosting das an?
 

Rooty

Donor
is awesome!
is uber awesome!
Das wäre natürlich ein Ding wenn Zap-Hosting jetzt schon seit Jahren den Sinusbot anbietet und keine Lizenz hätte.....

Kann ich mir als so "großes" Hostingunternehmen fast gar nicht vorstellen. Soll ich das irgendwo melden oder jemanden Kontaktieren deswegen ?
 
Thread starter Similar threads Forum Replies Date
N Hilfe bei der Installation 6
lusu007 Hilfe bei der Installation 0

Similar threads

Top