• If you need help or want to discuss things, you now can also join us on our Discord Server!

DE diagSinusbot.sh - Sinusbot Diagnostik Script

xNS91

New Member
Guten Abend,

habe das Problem das der Bot keine yt links abspielt. Es kommt die Meldung "streaming" jedoch hört man nix und im Webinterface läuft auch die Musik nicht ab. Woran kann das liegen?

Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
 - Operating System: Debian GNU/Linux 9.11 (stretch)
 - Kernel: Linux 4.9.0-7-amd64 x86_64
 - Load Average: 1.16 0.61 0.37
 - Uptime: 1 days, 22 hours, 12 minutes, 17 seconds
 - OS x64 check: OK
 - OS Updates: 2 (updates available!)
 - OS Missing Packages: None
 - OS APT Last Update: 11.12.2019 04:43:57 UTC +00:00:00
 - Shell Locale: en_US.UTF-8
 - Bot Start Script: not found
 - CPU:
    Architecture:          x86_64
    CPU(s):                1
    Thread(s) per core:    1
    Core(s) per socket:    1
    Socket(s):             1
    Model name:            QEMU Virtual CPU version 2.5+
    CPU MHz:               2599.998
    Hypervisor vendor:     KVM
    Virtualization type:   full
 - RAM: 389.62 MB/492.37 MB in use (79%)
 - SWAP: 0 B/0 B in use (0%) (SWAP disabled)
 - DISK: 1.64 GB/9.81 GB in use (16%)
 - Package versions:
   - libglib: 2.50.3-2+deb9u1

BOT INFORMATION
 - Status: running (PIDs: 8365 8363, User: sinusbot)
 - Webinterface: port locally reachable (Port: 8087)
 - Binary: /opt/sinusbot/sinusbot
 - Binary Info: MD5 Hash: 2ee075d4cb2a3a640862b4eefa0fa6b1, Perms: 755, User: sinusbot
 - Version: 1.0.0-beta.5-b262b6a
 - TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: 2e771e4332cf87da1f72d58aa6923f9f
   - TS3 Client: 2e771e4332cf87da1f72d58aa6923f9f
 - Config:
   - LogLevel = 3
   - TS3Path = /opt/sinusbot/teamspeak3-client/ts3client_linux_amd64 (Version 3.3.2)
   - YoutubeDLPath = /usr/local/bin/youtube-dl (does exist, version: 2019.11.28)
 - Installed scripts: advertising.js; alonemode.js; Animated_Nickname.js; Auto_Channel_Creator.js; bookmark.js; command.js; followme.js; Lauftext__Ticker__APINewsticker_Support.js; norecording.js; Private_Channel_Manager.js; RankCSGO.js; rememberChannel.js; Tunakills_Rankingsystem.js; welcome.js; Youtube_Search.js; YT-search.js

BOT TECHNICAL INFORMATION
 - File exists:
   - TS3Client/libqxcb-glx-integration.so: no
 - LDD output:
    linux-vdso.so.1 (0x00007ffee51b1000)
    libswresample.so.2 => /opt/sinusbot/libswresample.so.2 (0x00007f06ea78f000)
    libavfilter.so.6 => /opt/sinusbot/libavfilter.so.6 (0x00007f06ea437000)
    libavformat.so.57 => /opt/sinusbot/libavformat.so.57 (0x00007f06ea036000)
    libavcodec.so.57 => /opt/sinusbot/libavcodec.so.57 (0x00007f06e96d1000)
    libavutil.so.55 => /opt/sinusbot/libavutil.so.55 (0x00007f06e945d000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f06e9259000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f06e8f55000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f06e8d38000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f06e89b6000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f06e879f000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f06e8400000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f06e81e6000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f06e7fde000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f06ea9a9000)

REACHABILITY CHECKS
 - HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
 - HTTPS check with IPv6 mode: IGNORED [Disabled]
 - DNS resolution check: SUCCESS [www.sinusbot.com resolved to 104.28.14.74]
 - Update server checks:
    update01.sinusbot.com -> 104.28.14.74: SUCCESS [CODE #404]
    update02.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update03.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]

TIME INFORMATION
 - Time (local): 11.12.2019 17:31:02 UTC +00:00:00
 - Time (remote): <Failed retrieving remote time!>
 - Time (difference): n/a secs
 - Timezone: Etc/UTC

OTHER INFORMATION
 - TeamSpeak3 Version: 3.3.2
 - youtube-dl Version: 2019.11.28
 - DiagScript Version: 0.8.0
==========================================================
Liebe Grüße
 

Patschi

Head of troll department / Xuxe dominator
Tier III
is awesome!
V.I.P.
is uber awesome!
Insider
Und inwiefern hat das was mit dem Diagnostic Script zu tun? Lies dir bitte den "READ ME / LESE MICH" Post im Forum durch, und eröffne einen eigenen Thread für dein Problem. Logs nicht vergessen.
 

MitoCode

Donor
is awesome!
Heyho, ich habe leider auch ein Problem... Hier schon einmal die SysInfos:

Code:
==========================================================
SINUSBOT RELATED
SYSTEM INFORMATION
 - Operating System: Debian GNU/Linux 9.13 (stretch)
 - Kernel: Linux 4.9.0-12-amd64 x86_64
 - Load Average: 0.23 0.41 0.22
 - Uptime: 21 days, 0 hours, 14 minutes, 48 seconds
 - OS x64 check: OK
 - OS Updates: 0 (well done!)
 - OS Missing Packages: None
 - OS APT Last Update: 27.07.2020 16:35:47 CEST +02:00:00
 - Shell Locale: en_US.UTF-8
 - Bot Start Script: found at /etc/systemd/system/sinusbot.service [perms: 644]
 - CPU:
    Architecture:          x86_64
    CPU(s):                2
    Thread(s) per core:    1
    Core(s) per socket:    1
    Socket(s):             2
    Model name:            Intel Core Processor (Haswell, no TSX)
    CPU MHz:               2394.442
    Virtualization:        VT-x
    Hypervisor vendor:     KVM
    Virtualization type:   full
 - RAM: 1.07 GB/7.61 GB in use (14%)
 - SWAP: 0 B/0 B in use (0%) (SWAP disabled)
 - DISK: 28.20 GB/78.74 GB in use (35%)
 - Package versions:
   - libglib: 2.50.3-2+deb9u2

BOT INFORMATION
 - Status: running (PIDs: 844 807, User: sinusbot)
 - Webinterface: port locally reachable (Port: 8087)
 - Binary: /opt/sinusbot/sinusbot
 - Binary Info: MD5 Hash: 224b687db910b732fe5a7cfec4f6c78e, Perms: 755, User: sinusbot
 - Version: 1.0.0-beta.10-202ee4d
 - TS3 Plugin: installed (md5 hash match)
   - Bot Plugin: aa483aea105cb62033392b1ce6d317ab
   - TS3 Client: aa483aea105cb62033392b1ce6d317ab
 - Config:
   - LogLevel =
   - TS3Path = /opt/sinusbot/ts/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 (Version 3.3.2)
   - YoutubeDLPath = /opt/sinusbot/youtube-dl (does exist, version: 2020.05.08)
 - Installed scripts: advertising.js; alonemode.js; bookmark.js; come.js; command.js; followme.js; norecording.js; rememberChannel.js; sinusbot-commands.js; welcome.js

BOT TECHNICAL INFORMATION
 - File exists:
   - TS3Client/libqxcb-glx-integration.so: yes
 - LDD output:
    linux-vdso.so.1 (0x00007ffc34be6000)
    libswresample.so.2 => /opt/sinusbot/libswresample.so.2 (0x00007f69b8718000)
    libavfilter.so.6 => /opt/sinusbot/libavfilter.so.6 (0x00007f69b83c0000)
    libavformat.so.57 => /opt/sinusbot/libavformat.so.57 (0x00007f69b7fbf000)
    libavcodec.so.57 => /opt/sinusbot/libavcodec.so.57 (0x00007f69b765a000)
    libavutil.so.55 => /opt/sinusbot/libavutil.so.55 (0x00007f69b73e6000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f69b71e2000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f69b6ede000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f69b6cc1000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f69b693f000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f69b6728000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f69b6389000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f69b616f000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f69b5f67000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f69b8932000)

REACHABILITY CHECKS
 - HTTPS check with IPv4 mode: SUCCESS [Connection established to www.sinusbot.com, CODE #200]
 - HTTPS check with IPv6 mode: IGNORED [Disabled]
 - DNS resolution check: SUCCESS [www.sinusbot.com resolved to 172.67.132.160]
 - Update server checks:
    update01.sinusbot.com -> 172.67.132.160: SUCCESS [CODE #404]
    update02.sinusbot.com -> 104.28.15.74: SUCCESS [CODE #404]
    update03.sinusbot.com -> 104.28.14.74: SUCCESS [CODE #404]

TIME INFORMATION
 - Time (local): 27.07.2020 16:41:24 CEST +02:00:00
 - Time (remote): <Failed retrieving remote time!>
 - Time (difference): n/a secs
 - Timezone: Europe/Paris

OTHER INFORMATION
 - TeamSpeak3 Version: 3.3.2
 - youtube-dl Version: 2020.05.08
 - DiagScript Version: 0.8.0
==========================================================
Hier noch der Instanz-Log:
Code:
2020-07-27T16:31:04+02:00 TS>This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
2020-07-27T16:31:04+02:00 TS>qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
2020-07-27T16:31:04+02:00 TS>qt.qpa.xcb: could not connect to display unix/:40.0
2020-07-27T16:31:04+02:00 TS>QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
Was ist zu tun?

MfG
Mito
 

Himsel

Donor
is awesome!
is uber awesome!
Contributor
@MitoCode
Vorweg: Das gehört nicht hier hin, da du ja keine Probleme mit dem diagnose script an sich hast. Lies mal, die letzte Antwort über dir ;)

- TS3Client/libqxcb-glx-integration.so: yes
Zunächst einmal diese Datei libqxcb-glx-integration.so löschen in /opt/sinusbot/ts/TeamSpeak3-Client-linux_amd64/xcbglintegrations

- TeamSpeak3 Version: 3.3.2
Den Client auf die neueste Version updaten schadet auch nicht. Selbstverständlich wieder die Datei dann löschen.

Alle dependencies vorhanden?
apt-get install -y x11vnc xvfb libxcursor1 ca-certificates curl bzip2 libnss3 libegl1-mesa x11-xkb-utils libasound2 libpci3 libxslt1.1 libxkbcommon0 libxss1 libxcomposite1

Also, diese Dinge würde ich erst einmal machen. Wenns nicht hilft eigenen Thread eröffnen!
 
Last edited:
Top