• If you need help or want to discuss things, you now can also join us on our Discord Server!

Sinusbot Android App

Lala Sabathil

Donor
is awesome!
Contributor
Insider
Per Browser ist bei deiner URL bei mir auch alles ok. Nur Java scheint deine URL nicht zu mögen. Ich versuche heute noch einmal etwas anderes und schaue, ob es dann funktioniert.
Java ist da eh immer komisch. Java hat in den seltesten Fällen alle Root/CA Zertifikate im store
 

irgendwr

no longer active, "retired" staff member
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
Das Zerti is auch recht neu(1.Woche) evtl.liegts ja daran 🤔
Das alter des Certs ist nicht wichtig, das entscheidende ist ob dem Aussteller (Certificate Authority (CA)/Root CA) vertraut wird.
(aber eigentlich wird Let's Encrypt bzw deren Root CA von den meisten vertraut ¯\_(ツ)_/¯)
 

PaInKiLLeR

Helping Hand
Da ich ja ein Talent zum Bug finden habe hier ein neuer 😎



Einmal eingeloggt kann man die App selbst wenn man wieder ausgeloggt wird ohne Probleme nutzen und sich erneut einloggen!

Kille ich aber den Task muss ich den Vorgang im Video wieder holen,hoffe Du kannst damit was anfangen 😏
 

blitzdose

Member
Contributor
Insider
Da ich ja ein Talent zum Bug finden habe hier ein neuer 😎



Einmal eingeloggt kann man die App selbst wenn man wieder ausgeloggt wird ohne Probleme nutzen und sich erneut einloggen!

Kille ich aber den Task muss ich den Vorgang im Video wieder holen,hoffe Du kannst damit was anfangen 😏
Das ist ja mal wieder sehr interessant 🤔. Ist es möglich, dass du mir einen Testaccount im SinusBot anlegst, damit ich schauen kann, was da bei der Anfrage auf deinen Server merkwürdiges passiert? Wenn das möglich ist, kannst du mir die Daten entweder hier privat schreiben oder per Email an: [email protected] senden.
Ich kann aber noch nicht sagen, ob ich es diese Woche schaffe zu schauen, was da schiefläuft ;)
 

phiomet

Active Member
Grüß dich,

ich habe ein Problem, welches durchaus mit meiner Konstellation am Server zusammenhängen kann.

Kurz zum Handy:
Huawei Mate 20 Pro mit Android 9.1 (Emui)

Server:
Debian 9
Nginx mit Reverse Proxy, der von 80 auf 8087 routet, wenn die Anfrage von sinusbot.phiomet.at kommt. So kann ich den Port an der Firewall zu lassen.

Zusätzlich läuft das über Cloudflare.

Das SSL Zertifikat ist gültig.

Trotzdem sagt mir die App, dem wäre nicht so.
 

Attachments

  • Screenshot_20191022_172844_de.blitzdose.sinusbot.jpg
    Screenshot_20191022_172844_de.blitzdose.sinusbot.jpg
    452.5 KB · Views: 5

irgendwr

no longer active, "retired" staff member
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
Grüß dich,

ich habe ein Problem, welches durchaus mit meiner Konstellation am Server zusammenhängen kann.

Kurz zum Handy:
Huawei Mate 20 Pro mit Android 9.1 (Emui)

Server:
Debian 9
Nginx mit Reverse Proxy, der von 80 auf 8087 routet, wenn die Anfrage von sinusbot.phiomet.at kommt. So kann ich den Port an der Firewall zu lassen.

Zusätzlich läuft das über Cloudflare.

Das SSL Zertifikat ist gültig.

Trotzdem sagt mir die App, dem wäre nicht so.
Port 80 ist http, da gibt es kein SSL Zertifikat.
Wenn du https benutzen möchtest dann benutz den richtigen Port: 443.
 

Dark84

Active Member
Hallo leider kann i mich in meinem sinusbot nicht einloggen über die app... Es kommt immer ip/URL nicht gefunden...

Wüsste denn wer ne Lösung??
Screenshot_20191023_182033_de.blitzdose.sinusbot.jpg
Siehe Bild...
 

blitzdose

Member
Contributor
Insider
Hallo leider kann i mich in meinem sinusbot nicht einloggen über die app... Es kommt immer ip/URL nicht gefunden...

Wüsste denn wer ne Lösung??
View attachment 3557
Siehe Bild...
Unter der URL läuft ein ganz normaler Webserver mit dem Port 443. Der SinusBot Server läuft auf Port 8087. Gibst du diesen in die App ein, sollte es funktionieren.
 

irgendwr

no longer active, "retired" staff member
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
Bin übrigens nach wie vor der Meinung:
statt IP/Hostname + Port würde ich eher nur ein URL Feld besser finden.
Das ist weniger verwirrend wenn man "https://sinusbot.foo.bla" eingibt statt das aufzusplitten in Protokoll, Host und Port.
Ein Großteil der Nutzer wird sicherlich nicht wissen was denn nun der default Port für das https-Protokoll ist :p
Wenn man das so eingibt wie im Browser ist das viiiel intuitiver. Sparst du dir ein Text Feld und eine Checkbox und hast weniger verwirrte User.
 

blitzdose

Member
Contributor
Insider
Bin übrigens nach wie vor der Meinung:

Das ist weniger verwirrend wenn man "https://sinusbot.foo.bla" eingibt statt das aufzusplitten in Protokoll, Host und Port.
Ein Großteil der Nutzer wird sicherlich nicht wissen was denn nun der default Port für das https-Protokoll ist :p
Wenn man das so eingibt wie im Browser ist das viiiel intuitiver. Sparst du dir ein Text Feld und eine Checkbox und hast weniger verwirrte User.
OK ich schreibe es mir jetzt Mal auf die To-Do Liste ;) Kommt dann mit dem nächsten Update
 

Dark84

Active Member
Unter der URL läuft ein ganz normaler Webserver mit dem Port 443. Der SinusBot Server läuft auf Port 8087. Gibst du diesen in die App ein, sollte es funktionieren.

Dann kommt leider das siehe Bild...
 

Attachments

  • Screenshot_20191023_215014_de.blitzdose.sinusbot.jpg
    Screenshot_20191023_215014_de.blitzdose.sinusbot.jpg
    224.8 KB · Views: 5
Top