• If you need help or want to discuss things, you now can also join us on our Discord Server!
Sinusbot Installer Script

EN Sinusbot Installer Script 1.5

No permission to download

Multivitamin

V.I.P.
V.I.P.
is awesome!
is uber awesome!
Contributor
Insider
Tier III
es geht um die letzte meldung da wo er abbricht


Command which failed was: " apt-get -y install libfontconfig libxtst6 screen xvfb libxcursor1 ca-certificates bzip2 psmisc libglib2.0-0 less cron-apt python iproute2 dbus libnss3 libegl1-mesa x11-xkb-utils libasound2 libxcomposite-dev libxi6". Please try to execute it manually and attach the output to the bug report in the forum thread.
 

Qhiliqq

Donor
is awesome!
is uber awesome!
Contributor
Insider
Licensed Partner
Tja ich habe die pakete Manuell installiert und dann den Installer nochmal laufen lassen und wenn ich sagte NO dann bricht er ja ab....
Ja du sollst doch auch nicht auf "No" drücken... Wenn du die alle manuell installiert hast, kannst du auf ja drücken, er überspringt die dann...
Außerdem hägst du genau an einem Paket, was auch dein Log sagt: iproute2
 

NUGOSS

Donor
is awesome!
Distributor ID: Debian
Description: Debian GNU/Linux 9.5 (stretch)
Release: 9.5
Codename: stretch

The installation is fine, after the startup error.
Starting the SinusBot. For first time.
2018/09/14 18:29:30 X [MAIN] Starting up fake x-server...
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin advertising.js
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin alonemode.js
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin bookmark.js
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin followme.js
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin norecording.js
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin rememberChannel.js
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin welcome.js
Failed to read password, try a reinstall again.

When you start it does not start at all

[email protected]:/opt/sinusbot$ ./sinusbot --override-password=newpassword
2018/09/14 18:19:05 X [MAIN] Starting up fake x-server...
___ ___ _ _ _ _ ___ ___ ___ _____ BETA
/ __|_ _| \| | | | / __| _ )/ _ \_ _|
\__ \| || .` | |_| \__ \ _ \ (_) || |
|___/___|_|\_|\___/|___/___/\___/ |_|

Version: 0.14.3-0e747fd
(C) 2013-2018 Michael Friese. All rights reserved.

2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin advertising.js
2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin alonemode.js
2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin bookmark.js
2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin followme.js
2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin norecording.js
2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin rememberChannel.js
2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin welcome.js
a manual update is required

The error was repeated on different OS versions with a clean installation
 

NUGOSS

Donor
is awesome!
NTP set and time synchronized
The result is the same
ntpq -pn
remote refid st t when poll reach delay offset jitter
==============================================================================
+195.78.244.34 193.27.209.211 3 u 67 128 377 37.828 2.159 0.832
-185.102.185.102 62.149.0.30 2 u 61 128 377 84.313 6.464 3.927
*193.27.208.100 .PPS. 1 u 122 128 377 38.735 -0.075 0.974
+193.27.209.211 62.149.0.30 2 u 66 128 377 37.056 3.566 0.666
 
Last edited:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
wget ist schon die neueste Version (1.18-5+deb9u2).
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
libssh-4 libuv1
Verwenden Sie »apt autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 20 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
nginx-full (1.10.3-1+deb9u1) wird eingerichtet ...
Job for nginx.service failed because the control process exited with error code.
See "systemctl status nginx.service" and "journalctl -xe" for details.
invoke-rc.d: initscript nginx, action "start" failed.
● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2018-09-14 20:52:23 CEST; 42ms ago
Docs: man:nginx(8)
Process: 8544 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=1/FAILURE)
Process: 8541 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
CPU: 144ms

Sep 14 20:52:21 srv.<hierkönnteihrewerbungstehen>.de nginx[8544]: nginx: [emerg] listen() to [:…se)
Sep 14 20:52:22 srv.<hierkönnteihrewerbungstehen>.de nginx[8544]: nginx: [emerg] listen() to 0.…se)
Sep 14 20:52:22 srv.<hierkönnteihrewerbungstehen>.de nginx[8544]: nginx: [emerg] listen() to [:…se)
Sep 14 20:52:22 srv.<hierkönnteihrewerbungstehen>.de nginx[8544]: nginx: [emerg] listen() to 0.…se)
Sep 14 20:52:22 srv.<hierkönnteihrewerbungstehen>.de nginx[8544]: nginx: [emerg] listen() to [:…se)
Sep 14 20:52:23 srv.<hierkönnteihrewerbungstehen>.de nginx[8544]: nginx: [emerg] still could no…d()
Sep 14 20:52:23 srv.<hierkönnteihrewerbungstehen>.de systemd[1]: nginx.service: Control process…s=1
Sep 14 20:52:23 srv.<hierkönnteihrewerbungstehen>.de systemd[1]: Failed to start A high perform…er.
Sep 14 20:52:23 srv.<hierkönnteihrewerbungstehen>.de systemd[1]: nginx.service: Unit entered fa…te.
Sep 14 20:52:23 srv.<hierkönnteihrewerbungstehen>.de systemd[1]: nginx.service: Failed with res…e'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: Fehler beim Bearbeiten des Paketes nginx-full (--configure):
Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von nginx:
nginx hängt ab von nginx-full (<< 1.10.3-1+deb9u1.1~) | nginx-light (<< 1.10.3-1+deb9u1.1~) | nginx-extras (<< 1.10.3-1+deb9u1.1~); aber:
Paket nginx-full ist noch nicht konfiguriert.
Paket nginx-light ist nicht installiert.
Paket nginx-extras ist nicht installiert.
nginx hängt ab von nginx-full (>= 1.10.3-1+deb9u1) | nginx-light (>= 1.10.3-1+deb9u1) | nginx-extras (>= 1.10.3-1+deb9u1); aber:
Paket nginx-full ist noch nicht konfiguriert.
Paket nginx-light ist nicht installiert.
Paket nginx-extras ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes nginx (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
nginx-full
nginx
E: Sub-process /usr/bin/dpkg returned an error code (1)


Gerade versucht Sinusbot per Installerscript auf die 3.2.1 Clientversion zu updaten. Ist mir neu dass ich nginx konfigurieren muss bevor ich update.
Jemand mit dem selben Problem?

LG theonlybrand
 

Qhiliqq

Donor
is awesome!
is uber awesome!
Contributor
Insider
Licensed Partner
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
wget ist schon die neueste Version (1.18-5+deb9u2).
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
libssh-4 libuv1
Verwenden Sie »apt autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 20 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
nginx-full (1.10.3-1+deb9u1) wird eingerichtet ...
Job for nginx.service failed because the control process exited with error code.
See "systemctl status nginx.service" and "journalctl -xe" for details.
invoke-rc.d: initscript nginx, action "start" failed.
● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2018-09-14 20:52:23 CEST; 42ms ago
Docs: man:nginx(8)
Process: 8544 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=1/FAILURE)
Process: 8541 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
CPU: 144ms

Sep 14 20:52:21 srv.<hierkönnteihrewerbungstehen>.de nginx[8544]: nginx: [emerg] listen() to [:…se)
Sep 14 20:52:22 srv.<hierkönnteihrewerbungstehen>.de nginx[8544]: nginx: [emerg] listen() to 0.…se)
Sep 14 20:52:22 srv.<hierkönnteihrewerbungstehen>.de nginx[8544]: nginx: [emerg] listen() to [:…se)
Sep 14 20:52:22 srv.<hierkönnteihrewerbungstehen>.de nginx[8544]: nginx: [emerg] listen() to 0.…se)
Sep 14 20:52:22 srv.<hierkönnteihrewerbungstehen>.de nginx[8544]: nginx: [emerg] listen() to [:…se)
Sep 14 20:52:23 srv.<hierkönnteihrewerbungstehen>.de nginx[8544]: nginx: [emerg] still could no…d()
Sep 14 20:52:23 srv.<hierkönnteihrewerbungstehen>.de systemd[1]: nginx.service: Control process…s=1
Sep 14 20:52:23 srv.<hierkönnteihrewerbungstehen>.de systemd[1]: Failed to start A high perform…er.
Sep 14 20:52:23 srv.<hierkönnteihrewerbungstehen>.de systemd[1]: nginx.service: Unit entered fa…te.
Sep 14 20:52:23 srv.<hierkönnteihrewerbungstehen>.de systemd[1]: nginx.service: Failed with res…e'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: Fehler beim Bearbeiten des Paketes nginx-full (--configure):
Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von nginx:
nginx hängt ab von nginx-full (<< 1.10.3-1+deb9u1.1~) | nginx-light (<< 1.10.3-1+deb9u1.1~) | nginx-extras (<< 1.10.3-1+deb9u1.1~); aber:
Paket nginx-full ist noch nicht konfiguriert.
Paket nginx-light ist nicht installiert.
Paket nginx-extras ist nicht installiert.
nginx hängt ab von nginx-full (>= 1.10.3-1+deb9u1) | nginx-light (>= 1.10.3-1+deb9u1) | nginx-extras (>= 1.10.3-1+deb9u1); aber:
Paket nginx-full ist noch nicht konfiguriert.
Paket nginx-light ist nicht installiert.
Paket nginx-extras ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes nginx (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
nginx-full
nginx
E: Sub-process /usr/bin/dpkg returned an error code (1)


Gerade versucht Sinusbot per Installerscript auf die 3.2.1 Clientversion zu updaten. Ist mir neu dass ich nginx konfigurieren muss bevor ich update.
Jemand mit dem selben Problem?

LG theonlybrand
Wir installieren weder nginx, noch konfigurieren wir dies.
Nginx hast du demnach selbst installiert.

Der Installer führt mit Sicherheit gerade ein apt-get update && apt-get upgrade durch, wodurch du nginx siehst.
 
I Don't know if that's the right thing you wanted but these are my last lines after executing 'apt-get update'





Fetched 215 kB in 1s (134 kB/s)
W: Failed to fetch http://security.debian.org/dists/jessie/updates/InRelease Unable to find expected entry 'main/binary-i3860/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-updates/InRelease Unable to find expected entry 'main/binary-i3860/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch https://packages.sury.org/php/dists/jessie/InRelease Unable to find expected entry 'main/binary-i3860/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie/Release Unable to find expected entry 'main/binary-i3860/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

i Don't know what's wrong i have been getting this ''errors'' if i can call them like that i'm not sure.
 

Keyinator_

Donor
is awesome!
Code:
su sinusbot
cd /opt/sinusbot
./sinusbot
Show us the output of this.
Code:
2018/09/16 15:26:12 X [MAIN] Starting up fake x-server...
Library version mismatch. Please copy the updated plugin to the client directory.
Sanity checks failed, unable to run. Please read the installation-guide carefully and contact support if necessary.
 
Last edited:

NUGOSS

Donor
is awesome!
I apologize, but there will be further practical advice on the installation. from what else can the problem arise?

Distributor ID: Debian
Description: Debian GNU/Linux 9.5 (stretch)
Release: 9.5
Codename: stretch

The installation is fine, after the startup error.
Starting the SinusBot. For first time.
2018/09/14 18:29:30 X [MAIN] Starting up fake x-server...
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin advertising.js
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin alonemode.js
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin bookmark.js
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin followme.js
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin norecording.js
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin rememberChannel.js
2018/09/14 18:29:30 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin welcome.js
Failed to read password, try a reinstall again.

When you start it does not start at all

[email protected]:/opt/sinusbot$ ./sinusbot --override-password=newpassword
2018/09/14 18:19:05 X [MAIN] Starting up fake x-server...
___ ___ _ _ _ _ ___ ___ ___ _____ BETA
/ __|_ _| \| | | | / __| _ )/ _ \_ _|
\__ \| || .` | |_| \__ \ _ \ (_) || |
|___/___|_|\_|\___/|___/___/\___/ |_|

Version: 0.14.3-0e747fd
(C) 2013-2018 Michael Friese. All rights reserved.

2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin advertising.js
2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin alonemode.js
2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin bookmark.js
2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin followme.js
2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin norecording.js
2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin rememberChannel.js
2018/09/14 18:19:06 [GENERAL/SCRIPTS] INFO Loading ScriptPlugin welcome.js
a manual update is required

The error was repeated on different OS versions with a clean installation
 

Similar threads