• If you need help or want to discuss things, you now can also join us on our Discord Server!
Sinusbot Installer Script

EN Sinusbot Installer Script 1.5

No permission to download
Command which failed was: " fi". Please try to execute it manually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script. Line 688.

[email protected]:~# fi
-bash: syntax error near unexpected token `fi'

Latest script version, Debian 8

PS: Dein Anti-AdBlock schlägt auch dann an, wenn der AdBlocker deaktiviert wurde.
 

Qhiliqq

Donor
is awesome!
is uber awesome!
Contributor
Insider
Licensed Partner
PS: Dein Anti-AdBlock schlägt auch dann an, wenn der AdBlocker deaktiviert wurde.
Ist eigentlich genau aus dem Grund deaktiviert. Ich schau aber nochmal rein, vl.. hab ich was vergessen zu deaktivieren.

Command which failed was: " fi". Please try to execute it manually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script. Line 688.
Ich kann den Fehler nicht nachvollziehen. "fi" ist nur das schließen einer "if"-Klausel, also kein eigenständiger Befehl.
Soeben habe ich den Installer auf einem Debian 8 System problemlos installieren können.
Versuche es vll. einfach nochmal?
 

rigojack

New Member
Command which failed was: " if [ -d /home/$SINUSBOTUSER ]; then". Please try to execute it manually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script. Line 733.
after posting it doesnt really do anything. what should i do :S
 

Kinge

Member
Sie verwenden Installer 1.5
Was soll der Installer tun?
1) Installieren
2) Aktualisieren
3) Entfernen
4) PW Reset
5) Beenden
#? 1
Überprüfen Sie, ob lsb-release und debconf-utils installiert sind ...
W: Das Repository 'http://apt.postgresql.org/pub/repos/apt $ Release' enthält keine Release-Datei.
E: Fehler beim Abrufen von http://apt.postgresql.org/pub/repos/apt/dists/$/{RELEASE}/binary-i386/Packages 404 Not Found [IP: 87.238.57.227 80]
E: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder stattdessen alte verwendet.
Befehl, der fehlgeschlagen ist: "fi". Bitte versuchen Sie es manuell auszuführen und hängen Sie die Ausgabe an den Fehlerbericht im Forum-Thread an.
Wenn es immer noch nicht funktioniert, melden Sie dies nur dem Autor unter https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/. Keine PN oder schlechte Bewertung, da dies ein Fehler Ihres Systems und nicht des Installationsskripts ist. Linie 266.
 

Qhiliqq

Donor
is awesome!
is uber awesome!
Contributor
Insider
Licensed Partner
Can't reproduce this error.
Which OS?

Command which failed was: " if [ -d /home/$SINUSBOTUSER ]; then". Please try to execute it manually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script. Line 733.
after posting it doesnt really do anything. what should i do :S
Which OS?
 

MossyMC

Member
Hey @Qhiliqq,

wir bekommen auch den Fehler
raw.png
beim Ausführen des Skripts.

OS ist Ubuntu 19.04 minimal 64-bit.
Btw., man kann das Skript nicht manuell downloaden, da kommt immer ein Error 500...

LG
 
Last edited:

thinksostream

Donor
is awesome!
Check if lsb-release and debconf-utils is installed...
E: The repository 'https://packages.sury.org/php bionic Release' does not have a Release file.
Command which failed was: " fi". Please try to execute it manually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script. Line 266.
[email protected]:~# fi
bash: syntax error near unexpected token `fi'
[email protected]:~#

Ubuntu 18.04.3 LTS
 

Meshii

Member
Hi @Qhiliqq,

I have this configuration
Ubuntu 14.04.6 LTS (GNU/Linux 4.2.0-42-generic x86_64)

Do you know if can work or I necessarily need Ubuntu 16?

Thanks
 

pyrolords

New Member
Hallo was mache ich hier Falsch ?

[email protected]:/opt/sinusbot$ ./sinusbot

___ ___ _ _ _ _ ___ ___ ___ _____
/ __|_ _| \| | | | / __| _ )/ _ \_ _|
\__ \| || .` | |_| \__ \ _ \ (_) || |
|___/___|_|\_|\___/|___/___/\___/ |_|

Version: 1.0.0-beta.5-b262b6a
(C) 2013-2019 Michael Friese. All rights reserved.

2019/12/29 22:00:20 ca33448e INFO Loading instances
2019/12/29 22:00:20 ca33448e INFO Loading instance://1a229952-158c-43d6-85d4-3785b35daf50
2019/12/29 22:00:20 ca33448e 1a229952 INFO Initialization complete
2019/12/29 22:00:20 [GENERAL/FFMPEG ] INFO FFmpeg/avcodec v3741798; license: LGPL version 2.1 or later; 81 codecs
2019/12/29 22:00:20 [GENERAL/FFMPEG ] INFO FFmpeg/avformat v3742052; license: LGPL version 2.1 or later; 143 formats
2019/12/29 22:00:20 [GENERAL/YTDL ] INFO youtube-dl checking...
2019/12/29 22:00:20 ca33448e 1a229952 INFO script command loaded
2019/12/29 22:00:21 [GENERAL/YTDL ] INFO youtube-dl version compatible, support enabled
2019/12/29 22:00:21 [GENERAL/!!!!!!!] NOTICE You may now configure and launch the bots from the webinterface. http://0.0.0.0:8087
error starting up: listen tcp 0.0.0.0:8087: bind: address already in [email protected]:/opt/sinusbot$
 

Multivitamin

Well-Known Member
Tier III
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
error starting up: listen tcp 0.0.0.0:8087: bind: address already in use

da läuft schon was auf dem port
mit netstat -tulpn siehst du was da läuft
 

pyrolords

New Member
wie du klar sehen kannst läuft da schon ein sinusbot auf diesem port, entweder schließt du ihn oder nutzt den bereits laufenden sinusbot

View attachment 3672

Mag sein nur kann ich diese nicht nutzen weil entweder existiert dieser nicht mehr oder ich habe kein Zugriff drauf weil wenn der laufen würde könnte ich ja auch per webinterface und IP-Adresse drauf zugreifen oder etwa nicht ?

Falls ich da falsch liegen solle bitte ich darum das mir vielleicht wer von euch Hilft wäre nett
 

B3rm3J0

New Member
Im having problems to use the script on CentOS 8. No problems with Ubuntu 18.04. I tried to execute manually the command, also failed.
Anyone has it working on CentOS 8? I need to work with centos because my VPS has it installed.
 

Attachments

Similar threads

Top