• If you need help or want to discuss things, you now can also join us on our Discord Server!
  • Happy New Year everyone! A new version (1.0.0-beta.16) is out for Linux, fixing an issue that could lock the bot up when using it with TS3. Please visit the resources section or the main page (https://www.sinusbot.com) for the new package.
Sinusbot Installer Script

EN Sinusbot Installer Script 1.5

No permission to download

LogoJK

New Member
Probably 100th one having the NTP Problem. Yk at some point as a creator you cannot push this into a Software error 100% on client side. If it happen this regularly on Clean installs. (As you can see by every second Post here)


I'd really appreciate any kind of even help attempts here because this really is a bother. Thankyou very much (only to people actually considering helping even tho it maybee go out of only this skrips fault)
1659384427254.png
 

damirot

Member
Hello, when i run script i get this error:

Command which failed was: " apt-get -y install libfontconfig libxtst6 screen xvfb libxcursor1 ca-certificates bzip2 psmisc libglib2.0-0 less cron-apt python iproute2 dbus libnss3 libegl1-mesa x11-xkb-utils libasound2 libxcomposite-dev libxi6 libpci3 libxslt1.1 libxkbcommon0 libxss1". Please try to execute it manually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script. Line 631.


Same when i run manually.
Server version - Ubuntu 22.04.1 LTS fresh installed vps
 

EinfachRobin

Donor
is awesome!
Hello, when i run script i get this error:

Command which failed was: " apt-get -y install libfontconfig libxtst6 screen xvfb libxcursor1 ca-certificates bzip2 psmisc libglib2.0-0 less cron-apt python iproute2 dbus libnss3 libegl1-mesa x11-xkb-utils libasound2 libxcomposite-dev libxi6 libpci3 libxslt1.1 libxkbcommon0 libxss1". Please try to execute it manually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script. Line 631.


Same when i run manually.
Server version - Ubuntu 22.04.1 LTS fresh installed vps
You should post the output. What happens when you run it manually?
 

damirot

Member
You should post the output. What happens when you run it manually?
Same error: apt-get -y install libfontconfig libxtst6 screen xvfb libxcursor1 ca-certificates bzip2 psmisc libglib2.0-0 less cron-apt python iproute2 dbus libnss3 libegl1-mesa x11-xkb-utils libasound2 libxcomposite-dev libxi6 libpci3 libxslt1.1 libxkbcommon0 libxss1
 

damirot

Member
Hello,

since Ubuntu 22.04 doesn't have a Python Package (only a Python3) it might be a good Idea to update the Installer with 'Phyton3' and ''Phyton-Is-Phyton3' for Ubuntu 22.04,
else you will get a lot of Errors.
Hi, did you fix this error?
I have same problem with installation python on ubuntu 22.04
 

panko

Active Member
For anybody having the NTP issue the problem could be resolved setting your Debian 11 container (I use Proxmox for virtualization) to Privileged Container, not the best option because the container could overwrite host time and date. Best option is to download the script and completely remove the part containing #Setting Server Time as specified below.

Cheers.
1661949325123.png
 

steveq7

Active Member
Job for ntp.service failed because the control process exited with error code.
See "systemctl status ntp.service" and "journalctl -xeu ntp.service" for details .
Command which failed was: " service ntp start". Please try to execute it m anually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com /threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause t his is an error of your system not of the installer script. Line 674.
 

steveq7

Active Member
Job for ntp.service failed because the control process exited with error code.
See "systemctl status ntp.service" and "journalctl -xeu ntp.service" for details .
Command which failed was: " service ntp start". Please try to execute it m anually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com /threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause t his is an error of your system not of the installer script. Line 674.
what i have to do?
 

Lala Sabathil

Donor
is awesome!
Contributor
Insider
@steveq7 don't post multiple messages, one is enough.

And as it says it's an error of your system.
You might try first to execute it manually and search this forum first. This was posted like a thousand times already
 

Hoschy

Member
For anybody having the NTP issue the problem could be resolved setting your Debian 11 container (I use Proxmox for virtualization) to Privileged Container, not the best option because the container could overwrite host time and date. Best option is to download the script and completely remove the part containing #Setting Server Time as specified below.

Cheers.
View attachment 4562

Hi

I also use Proxmox. Your tip worked.
Many Thanks
 

X-Nightmare-X

Active Member
Moin Leute, das Installer Script hat das Problem, dass Python nicht existiert. Habe den Befehl manuell ausgeführt, da wird mir gesagt, dass es in anderen Quellen referenziert ist. Hab jetzt Mal Python 2 genommen. Also ist alles in dem Befehl erfolgreich installiert/geupdatet. Trotzdem kommt immer wieder der gleiche Fehler und das Script stoppt. Wie kann ich den "Fehler" im Script umgehen?
Liegt ja nicht wie angegeben an meinem System, sondern am Script was nur den Fehler erkennt das Python nicht installiert werden kann. Man sollte dann einprogrammieren, dass anstatt Python - Python 2 oder ähnliches genommen wird. Oder die Installation trotzdem fortzusetzen ist.

MfG ✌️
 
Hello,

since Ubuntu 22.04 doesn't have a Python Package (only a Python3) it might be a good Idea to update the Installer with 'Phyton3' and ''Phyton-Is-Phyton3' for Ubuntu 22.04,
else you will get a lot of Errors.
Using python version 3.9.7 but still error.

Error :

Command which failed was: " apt-get install -y --no-install-recommends libfontconfig libxtst6 screen xvfb libxcursor1 ca-certificates bzip2 psmisc libglib2.0-0 less python iproute2 dbus libnss3 libegl1-mesa x11-xkb-utils libasound2 libxcomposite-dev libxi6 libpci3 libxslt1.1 libxkbcommon0 libxss1". Please try to execute it manually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script. Line 633.
 

BoxTecnho

Member
Its a usefull script, but .. just out of curiosity, you guys should rewrite the script code to something simple and updated with current linux versions
 

Doctorik

New Member
Hi, well:

Command which failed was: "# redMessage "Cronjob already set for SinusBot updater"!". (insert your classic text here). Line 914.
It's even commented out, any idea where is the problem?
1674953346844.png
 

7quit

Member
Hey, when I try to run Sinusbot on my Ubuntu server via the following installer (https://sinusbot.github.io/installer/), I get the following error message:
I have the following Ubuntu Version: Ubuntu 22.04.1 LTS


Code:
[email protected] ~ # bash <(wget -O - 'https://raw.githubusercontent.com/SinusBot/installer-linux/master/sinusbot_installer.sh')

Redirecting output to ‘wget-log’.
Checking for the latest installer version
/dev/fd/63: line 94: 3: No such file or directory
This is the automatic installer for latest SinusBot. USE AT YOUR OWN RISK!
You can choose between installing, upgrading and removing the SinusBot.
Installer by Philipp Esswein | DAThosting.eu - Your game-/voiceserver hoster (only german).
Please rate this script at: https://forum.sinusbot.com/resources/sinusbot-installer-script.58/
You're using installer 1.5
What should the installer do?
1) Install
2) Update
3) Remove
4) PW Reset
5) Quit
#? 5
Exit now!
[email protected] ~ # bash <(wget -O - 'https://raw.githubusercontent.com/SinusBot/installer-linux/master/sinusbot_installer.sh')

Redirecting output to ‘wget-log.1’.
Checking for the latest installer version
/dev/fd/63: line 94: 3: No such file or directory
This is the automatic installer for latest SinusBot. USE AT YOUR OWN RISK!
You can choose between installing, upgrading and removing the SinusBot.
Installer by Philipp Esswein | DAThosting.eu - Your game-/voiceserver hoster (only german).
Please rate this script at: https://forum.sinusbot.com/resources/sinusbot-installer-script.58/
You're using installer 1.5
What should the installer do?
1) Install
2) Update
3) Remove
4) PW Reset
5) Quit
#? 1
Check if lsb-release and debconf-utils is installed...
Vormals nicht ausgewähltes Paket debconf-utils wird gewählt.
(Lese Datenbank ... 113988 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../debconf-utils_1.5.79ubuntu1_all.deb ...
Entpacken von debconf-utils (1.5.79ubuntu1) ...
debconf-utils (1.5.79ubuntu1) wird eingerichtet ...
Trigger für man-db (2.10.2-1) werden verarbeitet ...
Scanning processes...
Scanning linux images...

Running kernel seems to be up-to-date.

No services need to be restarted.

No containers need to be restarted.

No user sessions are running outdated binaries.

No VM guests are running outdated hypervisor (qemu) binaries on this host.
Done!
Automatically chosen system.d for your startscript!
Automatic usage or own directories?
1) Automatic
2) Own path
3) Quit
#? 1
Should I install TeamSpeak or only Discord Mode?
1) Both
2) Only Discord
3) Quit
#? 1
SinusBot isn't installed yet. Installer goes on.
This SinusBot version is only for private use! Accept?
1) No
2) Yes
#? 2
Should YT-DL be installed/updated?
1) Yes
2) No
#? 1
Update the system packages to the latest version? (Recommended)
1) Yes
2) No
#? 1
Starting the installer now!
Updating the system in a few seconds!
This could take a while. Please wait up to 10 minutes!
Searching latest TS3-Client build for hardware type x86_64 with arch amd64.
Detected latest TS3-Client version as 3.5.6
Installing necessary packages. Please wait...
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libevent-pthreads-2.1-7 libopts25 sntp
Vorgeschlagene Pakete:
  ntp-doc
Die folgenden Pakete werden ENTFERNT:
  systemd-timesyncd
Die folgenden NEUEN Pakete werden installiert:
  libevent-pthreads-2.1-7 libopts25 ntp sntp
0 aktualisiert, 4 neu installiert, 1 zu entfernen und 4 nicht aktualisiert.
Es müssen 855 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 2.296 kB Plattenplatz zusätzlich benutzt.
Holen:1 http://de.archive.ubuntu.com/ubuntu jammy/main amd64 libevent-pthreads-2.1-7 amd64 2.1.12-stable-1build3 [7.642 B]
Holen:2 http://de.archive.ubuntu.com/ubuntu jammy/universe amd64 libopts25 amd64 1:5.18.16-4 [59,5 kB]
Holen:3 http://de.archive.ubuntu.com/ubuntu jammy/universe amd64 ntp amd64 1:4.2.8p15+dfsg-1ubuntu2 [721 kB]
Holen:4 http://de.archive.ubuntu.com/ubuntu jammy/universe amd64 sntp amd64 1:4.2.8p15+dfsg-1ubuntu2 [67,1 kB]
Es wurden 855 kB in 0 s geholt (4.136 kB/s).
(Lese Datenbank ... 114020 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von systemd-timesyncd (249.11-0ubuntu3.6) ...
Vormals nicht ausgewähltes Paket libevent-pthreads-2.1-7:amd64 wird gewählt.
(Lese Datenbank ... 114006 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libevent-pthreads-2.1-7_2.1.12-stable-1build3_amd64.deb ...
Entpacken von libevent-pthreads-2.1-7:amd64 (2.1.12-stable-1build3) ...
Vormals nicht ausgewähltes Paket libopts25:amd64 wird gewählt.
Vorbereitung zum Entpacken von .../libopts25_1%3a5.18.16-4_amd64.deb ...
Entpacken von libopts25:amd64 (1:5.18.16-4) ...
Vormals nicht ausgewähltes Paket ntp wird gewählt.
Vorbereitung zum Entpacken von .../ntp_1%3a4.2.8p15+dfsg-1ubuntu2_amd64.deb ...
Entpacken von ntp (1:4.2.8p15+dfsg-1ubuntu2) ...
Vormals nicht ausgewähltes Paket sntp wird gewählt.
Vorbereitung zum Entpacken von .../sntp_1%3a4.2.8p15+dfsg-1ubuntu2_amd64.deb ...
Entpacken von sntp (1:4.2.8p15+dfsg-1ubuntu2) ...
libopts25:amd64 (1:5.18.16-4) wird eingerichtet ...
ntp (1:4.2.8p15+dfsg-1ubuntu2) wird eingerichtet ...
Created symlink /etc/systemd/system/network-pre.target.wants/ntp-systemd-netif.path → /lib/systemd/system/ntp-systemd-netif.path.
Created symlink /etc/systemd/system/multi-user.target.wants/ntp.service → /lib/systemd/system/ntp.service.
ntp-systemd-netif.service is a disabled or a static unit, not starting it.
libevent-pthreads-2.1-7:amd64 (2.1.12-stable-1build3) wird eingerichtet ...
sntp (1:4.2.8p15+dfsg-1ubuntu2) wird eingerichtet ...
Trigger für man-db (2.10.2-1) werden verarbeitet ...
Trigger für dbus (1.12.20-2ubuntu4.1) werden verarbeitet ...
Trigger für libc-bin (2.35-0ubuntu3.1) werden verarbeitet ...
Scanning processes...
Scanning linux images...

Running kernel seems to be up-to-date.

No services need to be restarted.

No containers need to be restarted.

No user sessions are running outdated binaries.

No VM guests are running outdated hypervisor (qemu) binaries on this host.
E: Für Paket »python« existiert kein Installationskandidat.
Command which failed was: "  apt-get install -y --no-install-recommends libfontconfig libxtst6 screen xvfb libxcursor1 ca-certificates bzip2 psmisc libglib2.0-0 less python iproute2 dbus libnss3 libegl1-mesa x11-xkb-utils libasound2 libxcomposite-dev libxi6 libpci3 libxslt1.1 libxkbcommon0 libxss1". Please try to execute it manually and attach the output to the bug report in the forum thread.
If it still doesn't work report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script. Line 633.
r
 
Last edited:

Bayern LP

Active Member
For anybody having the NTP issue the problem could be resolved setting your Debian 11 container (I use Proxmox for virtualization) to Privileged Container, not the best option because the container could overwrite host time and date. Best option is to download the script and completely remove the part containing #Setting Server Time as specified below.

Cheers.
View attachment 4562
Hello,

It does not work for me
 
Top