• TeamSpeak has reported a vulnerability in it's client that can potentially lead to RCE. A new version has been released that fixes it. So please update the client in your bot installation as soon as possible as well. Click here for more information.
  • If you need help or want to discuss things, you now can also join us on our Discord Server!

SSL Key und Cert

Dr._Pinguin

New Member
Moin,

ich komme einfach nicht weiter... Den Bot habe ich ohne Weiteres eingerichtet bekommen, er arbeitet auch problemlos. Ich bin jedoch derzeit daran alle Domains auf meinem Root auf Https umzustellen, doch bei dem Sinusbot verzweifel ich nur noch....

Ich habe in der config.ini folgendes eingetragen. Folgend habe ich versucht den Key und das Zertifikat in das Homeverzeichnis des Benutzers zu verschieben, was jedoch ebenfalls keinen Erfolg brachte. Erstellt wurde das Zertifikart mit Letsencrpyt bzw. certbot.

UseSSL = true
SSLKeyFile = "/home/sinusbot/cert/privkey.pm"
SSLCertFile = "/home/sinusbot/cert/fullchain.pm"

Ob im ~/live Verzeichnis, als auch im Homeverzeichnis des Benutzer erhalte ich beim Starten des Sinusbot folgende Fehlermeldung:

error starting up: open ~/home/sinusbot/cert/fullchain.pm: no such file or [email protected]:/opt/sinusbot$



Zuvor hatte ich die Fehlermeldung "Permission denied", aber die konnte ich problemlos durch die Rechtevergabe lösen. Dementsprechend kann der Pfad ja nicht so verkehrt sein... Vlt. weiß jemand von euch weiter, oder hatte bereits das selbe Problem.


Mfg.

Der Pinguin =)
 

Multivitamin

Well-Known Member
Tier III
V.I.P.
Contributor
Insider
du brauchst das zertifikat dennoch, empfohlen wird aber ein reverse proxy
 

Dr._Pinguin

New Member
Ja moin...
Ich habe absolut keine Ahnung wie ich das schaffe... ^^

Code:
<VirtualHost *:80>
    ServerName www.clusterstorm21.de

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    RewriteEngine on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

</VirtualHost>

<VirtualHost *:445>
    ServerName www.clusterstorm21.de

    SSLEngine On
    SSLCertificateFile    /etc/letsencrypt/live/clusterstorm21.de/cert.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/clusterstorm21.de/privkey.pem
    SSLCertificateChainFile /etc/letsencrypt/live/clusterstorm21.de/fullchain.pem

    ProxyPass / https://127.0.0.1:8087/
    ProxyPassReverse / https://127.0.0.1:8087/

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>
Das ist meine sinusbot.conf, die config.ini vom Sinus selbst habe ich schon konfiguriert. Aber Irgendwie ist das Webinterface garnicht mehr erreichbar ^^
Vlt. bin ich einfach nur blöd und verstehe etwas nicht :D
 

Multivitamin

Well-Known Member
Tier III
V.I.P.
Contributor
Insider
ohne logs kann ich auch nicht direkt sagen was da falsch läuft auf deinem webserver
 

Similar threads

Top