• If you need help or want to discuss things, you now can also join us on our Discord Server!
  • Happy New Year everyone! A new version (1.0.0-beta.16) is out for Linux, fixing an issue that could lock the bot up when using it with TS3. Please visit the resources section or the main page (https://www.sinusbot.com) for the new package.
Sinusbot Installer Script

EN Sinusbot Installer Script 1.5

No permission to download

Markus001

Member
Please type y to accept, n otherwise: y
Creating directory TeamSpeak3-Client-linux_amd64
Verifying archive integrity... All good.
Uncompressing TeamSpeak 3 Client for Linux on amd64 100%
TS3 client install done.
Downloading latest SinusBot.
Extracting SinusBot files.
SinusBot installation done.
Starting systemd installation
Failed to stop sinusbot.service: Unit sinusbot.service not loaded.
Error on line 818. Report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script.
Command which failed was: " service sinusbot stop". Please try to execute it manually and attach the output to the bug report in the forum thread.
 

liveuser

New Member
Great script, tnx!
Just one thing: install of youtube-dl happens under user who ran the script, so bin file is own by that user. But update for youtube-dl is running from sinusbot user -> no update happens. Need to chown youtube-dl for sinusbotuser or make cronjob from the name of user who ran the script.
edit: also you need to put full path to youtube-dl in cronjob.
 
Last edited:

NoxAgar

Member
Hay, ich brauch bitte hilfe bei mir kommt das
Check if lsb-release and debconf-utils is installed...
E: Failed to fetch https://www.youtube.com/redirect?v=...ebupd8team/java/ubuntu/dists/xenial/InRelease Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
E: Some index files failed to download. They have been ignored, or old ones used instead.
Error on line 260. Report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script.
Command which failed was: " apt-get -qq update". Please try to execute it manually and attach the output to the bug report in the forum thread.
 

mxschmitt

Moderator
Staff member
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
Hay, ich brauch bitte hilfe bei mir kommt das
Check if lsb-release and debconf-utils is installed...
E: Failed to fetch https://www.youtube.com/redirect?v=...ebupd8team/java/ubuntu/dists/xenial/InRelease Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
E: Some index files failed to download. They have been ignored, or old ones used instead.
Error on line 260. Report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script.
Command which failed was: " apt-get -qq update". Please try to execute it manually and attach the output to the bug report in the forum thread.
Bitte füre mal wie dort steht:
Code:
apt-get update
manuell aus :)
 

mxschmitt

Moderator
Staff member
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
Please type y to accept, n otherwise: y
Creating directory TeamSpeak3-Client-linux_amd64
Verifying archive integrity... All good.
Uncompressing TeamSpeak 3 Client for Linux on amd64 100%
TS3 client install done.
Downloading latest SinusBot.
Extracting SinusBot files.
SinusBot installation done.
Starting systemd installation
Failed to stop sinusbot.service: Unit sinusbot.service not loaded.
Error on line 818. Report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script.
Command which failed was: " service sinusbot stop". Please try to execute it manually and attach the output to the bug report in the forum thread.
Please try to execute:
service sinusbot stop
Code:
service sinusbot stop
manually and give us the output. :)
 

NoxAgar

Member
Bitte füre mal wie dort steht:
Code:
apt-get update
manuell aus :)

danke aber wenn ich apt-get update mach kommt das
Hit:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://cdn-fastly.deb.debian.org/debian stretch InRelease
Hit:3 http://cdn-fastly.deb.debian.org/debian stretch-updates InRelease
Hit:4 http://cdn-fastly.deb.debian.org/debian stretch Release
Err:5 https://www.youtube.com/redirect?v=...p://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease
Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
Fetched 49.0 kB in 0s (105 kB/s)
Reading package lists... Done
E: Failed to fetch https://www.youtube.com/redirect?v=...ebupd8team/java/ubuntu/dists/xenial/InRelease Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
E: Some index files failed to download. They have been ignored, or old ones used instead.
 

mxschmitt

Moderator
Staff member
is awesome!
V.I.P.
is uber awesome!
Contributor
Insider
danke aber wenn ich apt-get update mach kommt das
Hit:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://cdn-fastly.deb.debian.org/debian stretch InRelease
Hit:3 http://cdn-fastly.deb.debian.org/debian stretch-updates InRelease
Hit:4 http://cdn-fastly.deb.debian.org/debian stretch Release
Err:5 https://www.youtube.com/redirect?v=...p://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease
Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
Fetched 49.0 kB in 0s (105 kB/s)
Reading package lists... Done
E: Failed to fetch https://www.youtube.com/redirect?v=...ebupd8team/java/ubuntu/dists/xenial/InRelease Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
E: Some index files failed to download. They have been ignored, or old ones used instead.
The Installer-Script fails, because you've set a invalid apt repository. In this case the youtube.com's one. Try to delete this from /etc/apt/sources.list (if there is no youtube.com entry, then search for files in this directory: etc/apt/sources.list.d/). Then the installer-script should work fine. :)
 

NoxAgar

Member
The Installer-Script fails, because you've set a invalid apt repository. In this case the youtube.com's one. Try to delete this from /etc/apt/sources.list (if there is no youtube.com entry, then search for files in this directory: etc/apt/sources.list.d/). Then the installer-script should work fine. :)
Okay thx but there are 2 Youtube.com Urls witch one should i delete?
deb http://httpredir.debian.org/debian/ stretch main non-free contrib
deb http://httpredir.debian.org/debian/ stretch-updates main non-free contrib
deb https://www.youtube.com/redirect?v=...p://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
# deb-src https://www.youtube.com/redirect?v=...p://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
deb http://security.debian.org/ stretch/updates main non-free contrib
 

Brini

Helping Hand
Hey,

In der Beschreibung vom Installationsscript stand etwas von einer automatischen Installation von Updates, bzw. dass automatisch ein eintrag in den cronjobs erstellt wird. Ist diese Funktion schon verfügbar und ich habe sie einfach nicht entdeckt, oder kommt die noch? Und sollte die Funktion wirklich noch nicht verfügbar sein, wäre das wahrscheinlich dann auch etwas mehr Code, und nicht so eine kure Zeile die du mir nennen könntest, die ich dann bei mir schon eintragen kann oder?
 

Arcane

Donor
is awesome!
automatischen Installation von Updates,
Ist für den YouTube Downloader die Dateien das diese aktualisiert werden ist aber auch nur in dem Punkt gefragt wo man auswählt ob man es haben will. Daher genau lesen hilft gegen diese Verwirrung
 

KosmicReeds

Donor
is awesome!
Hey,

Tried to update the bot today by doing the update option. went through the update fine, got no errors, nothing, told me it updated successfully at the end and that it us up at the IP.

Anyway, I tried to go to the IP BotCP and it would not load, I did the status and it always says "Active: inactive (dead)", When I try as 'root' it says "The bot will not run as root-user" yet I have tried to start the bot with all users so root, sinusbot, ts3user. none work. I tried, stop, restart, start etc. all say inactive (dead)

Like I said, I have received no errors at all, nothing is telling me anything is wrong the bot just won't start after I updated it? Where is the log located for the bot? in-case this would help locate a problem?

Thanks.
 

BjoernEyHD

New Member
E: Some index files failed to download. They have been ignored, or old ones used instead.
Error on line 260. Report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script.
Command which failed was: " apt-get -qq update". Please try to execute it manually and attach the output to the bug report in the forum thread.


Hilfe Bitte
Lg Björn
 

Qhiliqq

Donor
is awesome!
Contributor
Insider
Licensed Partner
Hey,

Tried to update the bot today by doing the update option. went through the update fine, got no errors, nothing, told me it updated successfully at the end and that it us up at the IP.

Anyway, I tried to go to the IP BotCP and it would not load, I did the status and it always says "Active: inactive (dead)", When I try as 'root' it says "The bot will not run as root-user" yet I have tried to start the bot with all users so root, sinusbot, ts3user. none work. I tried, stop, restart, start etc. all say inactive (dead)

Like I said, I have received no errors at all, nothing is telling me anything is wrong the bot just won't start after I updated it? Where is the log located for the bot? in-case this would help locate a problem?

Thanks.
Start the bot manual:
- Login to your sinsubot user
- Switch to install dir
- ./sinusbot
And post the output here

E: Some index files failed to download. They have been ignored, or old ones used instead.
Error on line 260. Report this to the author at https://forum.sinusbot.com/threads/sinusbot-installer-script.1200/ only. Not a PN or a bad review, cause this is an error of your system not of the installer script.
Command which failed was: " apt-get -qq update". Please try to execute it manually and attach the output to the bug report in the forum thread.


Hilfe Bitte
Lg Björn
Command which failed was: " apt-get -qq update"
Steht doch da ;)
Einmal "apt-get update" ausführen. Da spinnt mit sicherheit was an deinem dpkg...
 

ManuPlaysLP

Member
Es steht ja in der Error Meldung drinne. Du musst den Command su -c "$LOCATION/sinusbot" $SINUSBOTUSER manuell in Putty eingeben und den Output hier in das Forum senden.
 
Top